summaryrefslogtreecommitdiff
path: root/dev-python/gevent
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /dev-python/gevent
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'dev-python/gevent')
-rw-r--r--dev-python/gevent/Manifest2
-rw-r--r--dev-python/gevent/gevent-1.3.7.ebuild72
2 files changed, 0 insertions, 74 deletions
diff --git a/dev-python/gevent/Manifest b/dev-python/gevent/Manifest
index 0a17fc0b4c78..fba8c8e70706 100644
--- a/dev-python/gevent/Manifest
+++ b/dev-python/gevent/Manifest
@@ -1,5 +1,3 @@
-DIST gevent-1.3.7.tar.gz 4614437 BLAKE2B 43d50c36fba2bedf41a7b33d38180f096b18846146953fa68325155f4a3cb6edb7352b9bb4cff5c7eca7a06ac25dc5b3e82a04545704fd0d6f43e9839a8749a1 SHA512 6dba487a9527eb352dc6a5f57120bf7973da655b3a331cad6637271b626c6e9e5439b20ee8abd9035ecb36e5259c99c69dea5ecdb8fa7ad0dbe28876c4d746d8
DIST gevent-1.4.0.tar.gz 5169595 BLAKE2B 0c78f67bc94d15419b8eadf8825d9657c6a7a82756308216e1ca94d5465c25836cb736b8b370a12d1003eb8614effd4110d8ed47ee2b0d7febc2bda4038adc0a SHA512 6771f4f2932055270e4f5a79ae815e93fd0f471defa7f437dc84907ea8b44672e05ae5eb6958f8d90580b2471785dce4044d9d1bbea0dd0c34c1381d88af0344
-EBUILD gevent-1.3.7.ebuild 1784 BLAKE2B 68dbdaf91c38e51a2a5bf462da4e01c5f7b1526b69736dc2dd9aad50f23d4a26c242d81fe6bf02705b8632e9a5d519deed3989d520b32a00d3549d39b1e6ca5e SHA512 25b2dbee6fbcc84371565d721590815eb861ccdb9711f77d56ddec1b0755be2f84b1b5a1afaf52e12bfbba79515c7d7ba20420878c4d517f0f8fa96e45758e8a
EBUILD gevent-1.4.0.ebuild 1714 BLAKE2B 004653a06d92f0668aaca427663197f4839c0c9fd5b0bc11e55e873215d26a3699205f91e8e71189ee40a7264867ad4deeb6e3b7d985a64a9f8b5dfa7ebb0e8d SHA512 66fb5a52bf63c00b39f071b3407ca179f41ae8e3180bac96133e2bd836dbe3c7c19d5b4db6ed27aba8dba339cbbb34daee526e1db286f7d00fbc465af7cce37c
MISC metadata.xml 374 BLAKE2B 87fe7f375b08bf4991954e018241ce4b150365409df516a12b79d221a037d718342dae60461663fac1d5af34458d352e287901e15fe68b1074927680055c204a SHA512 443f847333d35cd55f9c33624664569ecc8c2d0b7c74a358a716e0e133072edb0f29abfc36d6fb446db6890ae1319ad9d719a6e65e2bb35f9c9e9259379241fc
diff --git a/dev-python/gevent/gevent-1.3.7.ebuild b/dev-python/gevent/gevent-1.3.7.ebuild
deleted file mode 100644
index ca3ff75ab8ec..000000000000
--- a/dev-python/gevent/gevent-1.3.7.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{6,7} )
-PYTHON_REQ_USE="ssl(+),threads(+)"
-
-inherit distutils-r1 flag-o-matic
-
-MY_PV=${PV/_beta/b}
-MY_P=${PN}-${MY_PV}
-
-DESCRIPTION="Coroutine-based network library"
-HOMEPAGE="http://gevent.org/ https://pypi.org/project/gevent/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc examples"
-
-RDEPEND="
- >=dev-libs/libev-4.23
- >=net-dns/c-ares-1.12
- >=dev-python/greenlet-0.4.14
- virtual/python-greenlet[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
-
-# Tests take long and fail terribly a few times.
-# It also seems that they require network access.
-RESTRICT="test"
-
-S=${WORKDIR}/${MY_P}
-
-python_prepare_all() {
- export LIBEV_EMBED="false"
- export CARES_EMBED="false"
- export EMBED="false"
-
- distutils-r1_python_prepare_all
-}
-
-python_configure_all() {
- append-flags -fno-strict-aliasing
-}
-
-python_compile_all() {
- use doc && emake -C doc html
-}
-
-python_test() {
- cd src/greentest || die
-
- GEVENT_RESOLVER=thread \
- "${PYTHON}" testrunner.py --config known_failures.py || die
- GEVENT_RESOLVER=ares GEVENTARES_SERVERS=8.8.8.8 \
- "${PYTHON}" testrunner.py --config known_failures.py \
- --ignore tests_that_dont_use_resolver.txt || die
- GEVENT_FILE=thread \
- "${PYTHON}" testrunner.py --config known_failures.py $(grep -l subprocess test_*.py) || die
-}
-
-python_install_all() {
- local DOCS=( AUTHORS README.rst )
- use doc && local HTML_DOCS=( doc/_build/html/. )
- use examples && dodoc -r examples
-
- distutils-r1_python_install_all
-}