summaryrefslogtreecommitdiff
path: root/dev-python/gitdb
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
commit3517852e3b8a68d1e997770fc0650c5053bafc6c (patch)
tree44068672445b1418489aed82de58df3c470289e7 /dev-python/gitdb
parent0f15659d48c193027158492acb726297501202c5 (diff)
gentoo resync : 04.01.2022
Diffstat (limited to 'dev-python/gitdb')
-rw-r--r--dev-python/gitdb/Manifest4
-rw-r--r--dev-python/gitdb/gitdb-4.0.7.ebuild62
-rw-r--r--dev-python/gitdb/gitdb-4.0.8.ebuild4
3 files changed, 3 insertions, 67 deletions
diff --git a/dev-python/gitdb/Manifest b/dev-python/gitdb/Manifest
index c116808d97cd..b03275819edd 100644
--- a/dev-python/gitdb/Manifest
+++ b/dev-python/gitdb/Manifest
@@ -1,5 +1,3 @@
-DIST gitdb-4.0.7.tar.gz 394664 BLAKE2B 4a4586ac276c719110e7ad9ddccca8c0f45cca42f6740d990a974b043a749148088c495ad1939794382ff4094afa712cfa7f17619f371423f1b7a10e65ce72d2 SHA512 db63a613ee59249a3fccbd09fc0eca5747b166180bb5885737f849e339e81dfacd04f65e438fef241cf013cde33fe8c99a569c1599b2b5defd37b50e87dbdb0a
DIST gitdb-4.0.8.tar.gz 394637 BLAKE2B 8eb3b04664df0fb40b93ee814d94a2526d62127c3dd7d0908f8c3ab9c3fc4d7ad368ad6a4288e509ce2f6e43348cb4f3761aaf404040bad1c59bc920517888af SHA512 fa883bf135080a9defa039bf1f13aebdb91c7e8d397c870e24d7c13acc1b30fc32c6299b43c117657382c1908ace748b0967bc53e02c2d73633cc8603fcb8003
-EBUILD gitdb-4.0.7.ebuild 1362 BLAKE2B 429c66c0c1650384fbdba80ca77ed431089506101926d4ac52e8d889dbce6cf0bb881b723b37381787d7d65572bc68d998109e2244e25a1777eb23db87e884f3 SHA512 2124141bf42ddc0dcc4780cf69f8510ecce1a1f63b115ac0db2d97400e9a4f8a16c8bd2315b569ea5188fc005d775d08b08ac4533a14a0d3df9b07edafdeb117
-EBUILD gitdb-4.0.8.ebuild 1210 BLAKE2B a452790a27f8f6a8840c4d5f04a288a49e2e911996848c0068dbdc13d077cee7f24cebbc4a6cfc80c34a6fd77ddc101b57b1de41bddbef2c5bca78847673c508 SHA512 7b3d10d9ac6de2ad4a690dae87a4d6bdd1ae82b81e209d867a1af67c33da9bc17ad03dd9b49b465c248d2a2e4bfbcbcbbb8c8790d8f79c448a683a43734df157
+EBUILD gitdb-4.0.8.ebuild 1213 BLAKE2B b453536571a26cf14a5b7c7e414c027affe87f29f7b056303e2e6fea4ea2a343919ba39e909a5f76fc923ae745cae2f48ca7854186576de5ee0ce4ae1279b808 SHA512 5ff47e4daed0d67903cdbbab67e84a3aaded49375e2ab65431e0f2fcbdd8f54d3133699b6d4c4e09753c84703d37e17e265ca6d7b7cba4cd82327fa793fcb7ca
MISC metadata.xml 412 BLAKE2B 102f815a0eee2ea04a3c77b8b26f08760bbd64ee1f0b6b2523164f3b3fb576003865198574529332c2da8f6548f232b4cbc1bbc2e93fd7a437fe77dbde934ca7 SHA512 1f94c86c4366e0be10f89e3dbf935025bbf51d547b0ba65d99d2e97da0590de0d05fbe05e0277b0177fb1b2a9cea55cf824d332a224336d71cd49b0257fc31da
diff --git a/dev-python/gitdb/gitdb-4.0.7.ebuild b/dev-python/gitdb/gitdb-4.0.7.ebuild
deleted file mode 100644
index 908e5834607d..000000000000
--- a/dev-python/gitdb/gitdb-4.0.7.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="GitDB is a pure-Python git object database"
-HOMEPAGE="
- https://github.com/gitpython-developers/gitdb
- https://pypi.org/project/gitdb/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~ppc64 ~riscv x86"
-
-RDEPEND="
- >=dev-python/smmap-3.0.1[${PYTHON_USEDEP}]"
-BDEPEND="
- test? (
- dev-vcs/git
- )"
-
-distutils_enable_tests nose
-
-src_prepare() {
- # remove unnecessary version restriction
- # https://github.com/gitpython-developers/gitdb/issues/67
- sed -i -e '/smmap/s:,<4::' setup.py || die
- distutils-r1_src_prepare
-}
-
-src_test() {
- local i
-
- mkdir "${T}"/repo || die
- cd "${T}"/repo || die
-
- for (( i = 0; i < 2500; ++i )); do
- echo "${i}" > file"${i}" || die
- done
-
- git init || die
- git config user.email "you@example.com" || die
- git config user.name "Your Name" || die
- git add -A || die
- git commit -q -m ".." || die
- git clone --bare "${T}"/repo "${T}"/repo.git || die
- cd "${S}" || die
-
- distutils-r1_src_test
-}
-
-python_test() {
- #TRAVIS=1 disables performance tests which rely on the gitdb repo
- local -x TRAVIS=1
- local -x GITDB_TEST_GIT_REPO_BASE="${T}"/repo.git
- nosetests -v || die "Tests fail with ${EPYTHON}"
-}
diff --git a/dev-python/gitdb/gitdb-4.0.8.ebuild b/dev-python/gitdb/gitdb-4.0.8.ebuild
index 474422b5c464..56a76174a288 100644
--- a/dev-python/gitdb/gitdb-4.0.8.ebuild
+++ b/dev-python/gitdb/gitdb-4.0.8.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -14,7 +14,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc x86"
RDEPEND="
>=dev-python/smmap-3.0.1[${PYTHON_USEDEP}]"