summaryrefslogtreecommitdiff
path: root/dev-python/globre/globre-0.1.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/globre/globre-0.1.4.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/globre/globre-0.1.4.ebuild')
-rw-r--r--dev-python/globre/globre-0.1.4.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/globre/globre-0.1.4.ebuild b/dev-python/globre/globre-0.1.4.ebuild
new file mode 100644
index 000000000000..e5f0dd76320c
--- /dev/null
+++ b/dev-python/globre/globre-0.1.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 python3_6 )
+
+inherit distutils-r1
+
+DESCRIPTION="A glob matching library, providing an interface similar to the 're' module"
+HOMEPAGE="https://pypi.python.org/pypi/globre https://github.com/metagriffin/globre"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-3+"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/nose-1.3.0[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ nosetests --verbose || die
+}