summaryrefslogtreecommitdiff
path: root/dev-python/gnome-python-base
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/gnome-python-base
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/gnome-python-base')
-rw-r--r--dev-python/gnome-python-base/Manifest3
-rw-r--r--dev-python/gnome-python-base/gnome-python-base-2.28.1-r1.ebuild41
-rw-r--r--dev-python/gnome-python-base/metadata.xml12
3 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/gnome-python-base/Manifest b/dev-python/gnome-python-base/Manifest
new file mode 100644
index 000000000000..25e4b2260a72
--- /dev/null
+++ b/dev-python/gnome-python-base/Manifest
@@ -0,0 +1,3 @@
+DIST gnome-python-2.28.1.tar.bz2 562220 BLAKE2B 9bd14132974b6d42183debfc8f492fcee168a1671dfd27eead7aaa8d5ca12108bcda239b30df87bf41de3a0ab68191f095d63fdad05c151f6204f34f3bf14bdf SHA512 632d91d416f8209c2bc8d576d1229069e00f2cfeedb3441a5f151e12973ed740c0bb26d18d5c16cfeeb64ca35933537997277450001cffd96d8d5077027d45f2
+EBUILD gnome-python-base-2.28.1-r1.ebuild 1084 BLAKE2B 54421cf9521be56727d1bf96425a02a5d4dc50ad1038e7d5495d6ccb1881230cd3ae69c0a5871467c0218dee760917f9c8323f7c53dd48c7b6c8d42445eedd4c SHA512 1d97e3195c01aaffbd3c94b3f01a189d809f80208ddc232f0fc4c0a4ad6cdabe611af40dde0c81c851cf0edb2bf49e66dbc6165d36538bee4d4fd82dffcde9c4
+MISC metadata.xml 346 BLAKE2B 91249958bb5009cfc1acd263df53300b212a94fc654dc245e3f5540816d0260cd1e29d45a82677a5a38b66bb19579f05c8de49663f60c1827deaf71e0fe56504 SHA512 29ed867f32b1dc618689a6347b164ebe291bb061b90302dbfacd0c126a00bbcd7eaadcee11b075cb2c0fbf6e6534725a649a58e49dd1ea23cdd3f73af83ace77
diff --git a/dev-python/gnome-python-base/gnome-python-base-2.28.1-r1.ebuild b/dev-python/gnome-python-base/gnome-python-base-2.28.1-r1.ebuild
new file mode 100644
index 000000000000..540f323b3815
--- /dev/null
+++ b/dev-python/gnome-python-base/gnome-python-base-2.28.1-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+GCONF_DEBUG="no"
+PYTHON_COMPAT=( python2_7 )
+
+inherit versionator eutils gnome2 python-any-r1
+
+# This ebuild does nothing -- we just want to get the pkgconfig file installed
+
+MY_PN="gnome-python"
+DESCRIPTION="Provides the base files for the gnome-python bindings"
+HOMEPAGE="http://pygtk.org/"
+PVP="$(get_version_component_range 1-2)"
+SRC_URI="mirror://gnome/sources/${MY_PN}/${PVP}/${MY_PN}-${PV}.tar.bz2"
+
+IUSE=""
+LICENSE="LGPL-2.1"
+SLOT="2"
+RESTRICT="${RESTRICT} test"
+
+# From the gnome-python eclass
+RDEPEND=">=x11-libs/gtk+-2.6:2
+ >=dev-libs/glib-2.6:2
+ $(python_gen_any_dep '
+ >=dev-python/pygtk-2.14.0:2[${PYTHON_USEDEP}]
+ >=dev-python/pygobject-2.17:2[${PYTHON_USEDEP}]
+ ')
+ !<dev-python/gnome-python-2.22.1"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+KEYWORDS="alpha amd64 arm ia64 ~mips ppc ppc64 ~sh sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-solaris"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-allbindings
+}
diff --git a/dev-python/gnome-python-base/metadata.xml b/dev-python/gnome-python-base/metadata.xml
new file mode 100644
index 000000000000..e4e250dd8100
--- /dev/null
+++ b/dev-python/gnome-python-base/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+</maintainer>
+<maintainer type="project">
+ <email>gnome@gentoo.org</email>
+ <name>Gentoo GNOME Desktop</name>
+</maintainer>
+</pkgmetadata>