summaryrefslogtreecommitdiff
path: root/dev-python/gnome-python-base
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-08-18 18:16:17 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-08-18 18:16:17 +0100
commitfc637fb28da700da71ec2064d65ca5a7a31b9c6c (patch)
tree326613a08f25851c388715e205576a2e7d25dc4f /dev-python/gnome-python-base
parentb24bd25253fe093f722ab576d29fdc41d04cb1ee (diff)
gentoo resync : 18.08.2019
Diffstat (limited to 'dev-python/gnome-python-base')
-rw-r--r--dev-python/gnome-python-base/Manifest2
-rw-r--r--dev-python/gnome-python-base/gnome-python-base-2.28.1-r1.ebuild16
2 files changed, 11 insertions, 7 deletions
diff --git a/dev-python/gnome-python-base/Manifest b/dev-python/gnome-python-base/Manifest
index 25e4b2260a72..30bc14b29e8a 100644
--- a/dev-python/gnome-python-base/Manifest
+++ b/dev-python/gnome-python-base/Manifest
@@ -1,3 +1,3 @@
DIST gnome-python-2.28.1.tar.bz2 562220 BLAKE2B 9bd14132974b6d42183debfc8f492fcee168a1671dfd27eead7aaa8d5ca12108bcda239b30df87bf41de3a0ab68191f095d63fdad05c151f6204f34f3bf14bdf SHA512 632d91d416f8209c2bc8d576d1229069e00f2cfeedb3441a5f151e12973ed740c0bb26d18d5c16cfeeb64ca35933537997277450001cffd96d8d5077027d45f2
-EBUILD gnome-python-base-2.28.1-r1.ebuild 1084 BLAKE2B 54421cf9521be56727d1bf96425a02a5d4dc50ad1038e7d5495d6ccb1881230cd3ae69c0a5871467c0218dee760917f9c8323f7c53dd48c7b6c8d42445eedd4c SHA512 1d97e3195c01aaffbd3c94b3f01a189d809f80208ddc232f0fc4c0a4ad6cdabe611af40dde0c81c851cf0edb2bf49e66dbc6165d36538bee4d4fd82dffcde9c4
+EBUILD gnome-python-base-2.28.1-r1.ebuild 1134 BLAKE2B 6ef79ad4d1da5e4126ebef0758eaa2268666f38316110b2a3be703cde2abe9eaafe778b4ad7fd36953810d661274d2a29aca93d2805dde8f7e56994bcbbb9e2e SHA512 701ad668c662a3266aef5fc54c7e631f154b38168c9b21850f479eef5a08e1d9a4eaa3fee1e287d24bb57b8bbd32c113c77d1fc9eef3e0fd3d4c34ab8163481b
MISC metadata.xml 346 BLAKE2B 91249958bb5009cfc1acd263df53300b212a94fc654dc245e3f5540816d0260cd1e29d45a82677a5a38b66bb19579f05c8de49663f60c1827deaf71e0fe56504 SHA512 29ed867f32b1dc618689a6347b164ebe291bb061b90302dbfacd0c126a00bbcd7eaadcee11b075cb2c0fbf6e6534725a649a58e49dd1ea23cdd3f73af83ace77
diff --git a/dev-python/gnome-python-base/gnome-python-base-2.28.1-r1.ebuild b/dev-python/gnome-python-base/gnome-python-base-2.28.1-r1.ebuild
index 540f323b3815..e5b88706d9e3 100644
--- a/dev-python/gnome-python-base/gnome-python-base-2.28.1-r1.ebuild
+++ b/dev-python/gnome-python-base/gnome-python-base-2.28.1-r1.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
GCONF_DEBUG="no"
PYTHON_COMPAT=( python2_7 )
-inherit versionator eutils gnome2 python-any-r1
+inherit versionator eutils gnome2 python-r1
# This ebuild does nothing -- we just want to get the pkgconfig file installed
@@ -16,6 +16,7 @@ PVP="$(get_version_component_range 1-2)"
SRC_URI="mirror://gnome/sources/${MY_PN}/${PVP}/${MY_PN}-${PV}.tar.bz2"
IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
LICENSE="LGPL-2.1"
SLOT="2"
RESTRICT="${RESTRICT} test"
@@ -23,10 +24,9 @@ RESTRICT="${RESTRICT} test"
# From the gnome-python eclass
RDEPEND=">=x11-libs/gtk+-2.6:2
>=dev-libs/glib-2.6:2
- $(python_gen_any_dep '
- >=dev-python/pygtk-2.14.0:2[${PYTHON_USEDEP}]
- >=dev-python/pygobject-2.17:2[${PYTHON_USEDEP}]
- ')
+ ${PYTHON_DEPS}
+ >=dev-python/pygtk-2.14.0:2[${PYTHON_USEDEP}]
+ >=dev-python/pygobject-2.17:2[${PYTHON_USEDEP}]
!<dev-python/gnome-python-2.22.1"
DEPEND="${RDEPEND}
virtual/pkgconfig"
@@ -35,6 +35,10 @@ KEYWORDS="alpha amd64 arm ia64 ~mips ppc ppc64 ~sh sparc x86 ~x86-fbsd ~amd64-li
S="${WORKDIR}/${MY_PN}-${PV}"
+src_prepare() {
+ python_setup
+}
+
src_configure() {
gnome2_src_configure \
--disable-allbindings