summaryrefslogtreecommitdiff
path: root/dev-python/gnome-python-extras-base
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/gnome-python-extras-base
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/gnome-python-extras-base')
-rw-r--r--dev-python/gnome-python-extras-base/Manifest4
-rw-r--r--dev-python/gnome-python-extras-base/files/gnome-python-extras-base-2.25.3-python-libs.patch59
-rw-r--r--dev-python/gnome-python-extras-base/gnome-python-extras-base-2.25.3-r1.ebuild47
-rw-r--r--dev-python/gnome-python-extras-base/metadata.xml12
4 files changed, 122 insertions, 0 deletions
diff --git a/dev-python/gnome-python-extras-base/Manifest b/dev-python/gnome-python-extras-base/Manifest
new file mode 100644
index 000000000000..e62b76e79998
--- /dev/null
+++ b/dev-python/gnome-python-extras-base/Manifest
@@ -0,0 +1,4 @@
+AUX gnome-python-extras-base-2.25.3-python-libs.patch 2243 BLAKE2B 05e6d4383c91237fe248afbbe3e04f111b60f3119bcddb99c72adeb671c973379c6c241bdf184dc9dc81b67e347582f631dad175ca39036a3fe2a3f415a659fa SHA512 f9ddacdcffaaf6933e3ab28f843892a4754677a29987d512ebc3810245fb793f8a242b479e47fd63dc7756c817a510e04cda2548aa6bb4d88ce4649c2b1759ed
+DIST gnome-python-extras-2.25.3.tar.bz2 370489 BLAKE2B 9ca41f953ed75009f732c811372a560a1fcaf8e81bf4187117c40e61009296df62ed413cfc47194329bb92053762748cd14c3849d0f4a0fe7ccfff8ad72c3529 SHA512 6994b8b5d6ccc009edc7ddfad373b9164d8162f1007972652f6086dca30cac6941ab68ef467d15c972ab05c4ae0e19ec72edc2643636d22a01a3f5a719251467
+EBUILD gnome-python-extras-base-2.25.3-r1.ebuild 1307 BLAKE2B 3628d40a09589ef1acee78bf632b2337503c3c26cab23dcb5c014aaa5870d0ec12d77b6d034cc89ed3b3c8327f8cc3961f13fe6b5161d1b36ee5bf6ba1342acc SHA512 a82a22c5edb1049e12d5c4bbd137f7e560293bcb9d5813ecea0754c9a95c02c405599d13363afddbffd3919cfe202cc5ec30a22063203d1e401fbeb4e59e2410
+MISC metadata.xml 346 BLAKE2B 48d899b0b769e7edf07feeb6349bd66595360a1fd09a3c9bc5385485729eba9f1eb462e508e6691fe47dd571be396a29fa266fc998cc8d2ff772b353713fcda9 SHA512 e7e631f5ebe3a81d0431366152d6f7a2d21958a031746d6b2fd6ac9ef3f145d78fb30d1014b0912e9d720b3be7c6d2fdc544bb840a9f12fddf37ffdcf65933bd
diff --git a/dev-python/gnome-python-extras-base/files/gnome-python-extras-base-2.25.3-python-libs.patch b/dev-python/gnome-python-extras-base/files/gnome-python-extras-base-2.25.3-python-libs.patch
new file mode 100644
index 000000000000..ab691272cbb6
--- /dev/null
+++ b/dev-python/gnome-python-extras-base/files/gnome-python-extras-base-2.25.3-python-libs.patch
@@ -0,0 +1,59 @@
+From 7824fd5291f570de3c2c64185035d1a6a0a3445a Mon Sep 17 00:00:00 2001
+From: Alexandre Rostovtsev <tetromino@gentoo.org>
+Date: Mon, 13 Aug 2012 04:42:47 -0400
+Subject: [PATCH] Replace horrible slow python libs search
+
+---
+ acinclude.m4 | 36 ++----------------------------------
+ 1 files changed, 2 insertions(+), 34 deletions(-)
+
+diff --git a/acinclude.m4 b/acinclude.m4
+index 8694a65..f5373eb 100644
+--- a/acinclude.m4
++++ b/acinclude.m4
+@@ -59,40 +59,8 @@ $1],dnl
+ [AC_MSG_RESULT(not found)
+ $2])
+ CPPFLAGS="$save_CPPFLAGS"
+-
+- # This bit is copied from Planner. murrayc.
+- # Check for Python library path
+- AC_MSG_CHECKING([for Python library path])
+-
+- # Win32 has libpython25.a instead of libpython2.5.a, so we look
+- # for both. TODO: Only look for libpython25.a on Windows, and for
+- # libpython2.5.a on unix.
+- WIN32_PYTHON_VERSION=`echo $PYTHON_VERSION | sed "s,\.,,"`
+-
+- python_path=`dirname $PYTHON | sed "s,/bin.*$,,"`
+- for i in "$python_path/lib/python$PYTHON_VERSION/config/" "$python_path/lib/python$PYTHON_VERSION/" "$python_path/lib/python/config/" "$python_path/lib/python/" "$python_path/" ; do
+- if test -e "$i"; then
+- python_path=`find $i -type f -name libpython$PYTHON_VERSION.* -print | sed "1q"`
+- if test -n "$python_path" ; then
+- python_lib="python$PYTHON_VERSION"
+- break
+- fi
+-
+- # Additionally test WIN32_PYTHON_VERSION
+- python_path=`find $i -type f -name libpython$WIN32_PYTHON_VERSION.* -print | sed "1q"`
+- if test -n "$python_path" ; then
+- python_lib="python$WIN32_PYTHON_VERSION"
+- break
+- fi
+- fi
+- done
+-
+- python_path=`echo $python_path | sed "s,/libpython.*$,,"`
+- AC_MSG_RESULT([$python_path])
+- if test -z "$python_path" ; then
+- AC_MSG_ERROR([cannot find Python library path])
+- fi
+- AC_SUBST([PYTHON_LDFLAGS],["-L$python_path -l$python_lib"])
++PYTHON_LDFLAGS=`$PYTHON -c "import distutils.sysconfig; print('-L%s -lpython${PYTHON_VERSION}' % distutils.sysconfig.get_config_var('LIBDIR'))"`
++AC_SUBST([PYTHON_LDFLAGS],["$PYTHON_LDFLAGS"])
+ ])
+
+ dnl
+--
+1.7.8.6
+
diff --git a/dev-python/gnome-python-extras-base/gnome-python-extras-base-2.25.3-r1.ebuild b/dev-python/gnome-python-extras-base/gnome-python-extras-base-2.25.3-r1.ebuild
new file mode 100644
index 000000000000..cfcd4a3af74e
--- /dev/null
+++ b/dev-python/gnome-python-extras-base/gnome-python-extras-base-2.25.3-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit versionator autotools eutils gnome2 python-any-r1
+
+# This ebuild does nothing -- we just want to get the pkgconfig file installed
+MY_PN="gnome-python-extras"
+DESCRIPTION="Provides python the base files for the Gnome Python Desktop bindings"
+HOMEPAGE="http://pygtk.org/"
+PVP="$(get_version_component_range 1-2)"
+SRC_URI="mirror://gnome/sources/${MY_PN}/${PVP}/${MY_PN}-${PV}.tar.bz2"
+
+IUSE=""
+LICENSE="LGPL-2.1"
+SLOT="0"
+RESTRICT="test"
+
+# From the gnome-python-extras eclass
+RDEPEND=">=x11-libs/gtk+-2.4:2
+ >=dev-libs/glib-2.6:2
+ $(python_gen_any_dep '>=dev-python/pygtk-2.10.3:2[${PYTHON_USEDEP}]')
+ !<=dev-python/gnome-python-extras-2.19.1-r2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ gnome-base/gnome-common"
+# eautoreconf needs gnome-base/gnome-common
+
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+DOCS="AUTHORS COPYING* ChangeLog INSTALL NEWS README"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-python-libs.patch" #344231
+ sed -e "s/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/" -i configure.ac || die
+ eautoreconf
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-allbindings
+}
diff --git a/dev-python/gnome-python-extras-base/metadata.xml b/dev-python/gnome-python-extras-base/metadata.xml
new file mode 100644
index 000000000000..6cd5da0617a4
--- /dev/null
+++ b/dev-python/gnome-python-extras-base/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnome@gentoo.org</email>
+ <name>Gentoo GNOME Desktop</name>
+</maintainer>
+<maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+</maintainer>
+</pkgmetadata>