summaryrefslogtreecommitdiff
path: root/dev-python/google-api-python-client
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-07-10 12:25:06 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-07-10 12:25:06 +0100
commite810ac4a0e6af9f763f4433863042b34609075a7 (patch)
tree6fe0b3ff24f3b875be1564e273049c1e301d205b /dev-python/google-api-python-client
parentc218398bbbe70a616790cf146c28c1066b9284bf (diff)
gentoo auto-resync : 10:07:2024 - 12:25:06
Diffstat (limited to 'dev-python/google-api-python-client')
-rw-r--r--dev-python/google-api-python-client/Manifest2
-rw-r--r--dev-python/google-api-python-client/google-api-python-client-2.137.0.ebuild50
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/google-api-python-client/Manifest b/dev-python/google-api-python-client/Manifest
index ff66709b1705..b7e7b9b2f528 100644
--- a/dev-python/google-api-python-client/Manifest
+++ b/dev-python/google-api-python-client/Manifest
@@ -1,5 +1,7 @@
DIST google-api-python-client-2.134.0.tar.gz 11393129 BLAKE2B f5339dfa42f621dbdd145295a2c2710ef9e6e2af543ff5b9643bea884f9e0678065999d60cbf150a56e7b0d8c283588c53461c86eeb491a6ba2ad0c553a48344 SHA512 09a137ee3e3d8f38129fc02d8ffed8934daf6cfcd13904692f44038332da026b30d952048148c8c4fe5c4fed3347196574a860f58e1943312d19f6f03a01ab36
DIST google-api-python-client-2.136.0.tar.gz 11443821 BLAKE2B ee313274ec25e1262ad54b800cf524e58400886876d9133b7c6e1d9668e81bce7b73f96511679bcc2a0f565ca9b89c7d6bc7087213e53575542c5e0b5e566ff9 SHA512 e5e8302c71953f0971d3b3159d7689cd76520efa4cee9ca541e78a5fcb14387506963cb20da06ac5760af814ece5ded0bc3942381aa9e96fd6c620eb8933a6ed
+DIST google_api_python_client-2.137.0.tar.gz 11477114 BLAKE2B e0d7e64bfdd86bd882c8762b8d78fcd390152e569ca32df16fcbe91290508565086e4ca7e958d8d48ecaa6d5d23a0b1188b85f6a53004af54139977602c4f72c SHA512 442c08033fb12dbdcab3e45b911a9d43d93a4841369cd14344c9201a40b453d88ce602c3f45d965713ca826bec1f3e333f9425008d1cf1f59b6441283eb09807
EBUILD google-api-python-client-2.134.0.ebuild 1475 BLAKE2B d19c13ce0fe0968d44016c0c7b2a023f393c31af0758473d6996d06b87cf1c950757f442ac4a0d2f460f848ca45cc3b185d92eedf81249d63204b2c2b952096e SHA512 1c58462ddc1ed7da0d7130fda6daf0e6df229d5de9b99a6b9fd44489827554254025389543b40f7db725ce537ffc85c51551ea9512d4abefb02bade4613050b9
EBUILD google-api-python-client-2.136.0.ebuild 1478 BLAKE2B 4660fef51f05bc038cb079a4680f3cb5ce0fb8b6c0cbe609470d5a3e1106eb76da26fb969040e8eaa250581513a96fabc09b66b32641441707ab741ef9732ee8 SHA512 152bb175cb77bb8bec3da99cea918d8b2ad709d2f5ea671c30181b04a3ffb26656ccf8fa9301132019fb47f81253411ae7612e9c7271d3cb0d0d4ea6df9bc163
+EBUILD google-api-python-client-2.137.0.ebuild 1458 BLAKE2B 3f2366ba3a116f0433f2fdc1ff58a40c83b9b4db5a7cc375d3fc7fc1473467a577dd271cf719903ae54b0bc4458d058c923f6f51dd8148904233e6c7f6131a62 SHA512 12bbdda20594f6bc96e5938037cadb4d7a10774e337995b5d63671f23f1b2ea12f9d129e0f5c5bd3b49f4a1282663ccf65c7ae6ebf2848788308319805686751
MISC metadata.xml 538 BLAKE2B bf0b8ab3a89ce9ab1d2159f4c0ebfe3f2646aced20bd2006485510c12d22e83cc130fac979f699ae6431a610c8d2acf86c04b39bc262abaf167c20571a860810 SHA512 30d004d944055660165954f8475e57ba45cef56423c80a324118836d78e5376261409955155a40c9bd988f230f3e2fc44c6aeb6fae3028c78c55a382ccd83bff
diff --git a/dev-python/google-api-python-client/google-api-python-client-2.137.0.ebuild b/dev-python/google-api-python-client/google-api-python-client-2.137.0.ebuild
new file mode 100644
index 000000000000..cdad1f8ab5e5
--- /dev/null
+++ b/dev-python/google-api-python-client/google-api-python-client-2.137.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Google API Client for Python"
+HOMEPAGE="
+ https://github.com/googleapis/google-api-python-client/
+ https://pypi.org/project/google-api-python-client/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/httplib2-0.15[${PYTHON_USEDEP}]
+ <dev-python/httplib2-1[${PYTHON_USEDEP}]
+ >=dev-python/google-api-core-2.3.1[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.35.0[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-httplib2-0.1.0[${PYTHON_USEDEP}]
+ >=dev-python/uritemplate-3.0.0[${PYTHON_USEDEP}]
+ <dev-python/uritemplate-5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # require Internet access (and credentials)
+ tests/test_discovery.py::DiscoveryErrors::test_credentials_and_credentials_file_mutually_exclusive
+ tests/test_discovery.py::DiscoveryFromDocument::test_api_endpoint_override_from_client_options_mapping_object
+ tests/test_discovery.py::Universe::test_client_options_universe_configured_with_mtls
+ tests/test_discovery.py::Universe::test_universe_env_var_configured_with_mtls
+ )
+
+ epytest tests
+}