summaryrefslogtreecommitdiff
path: root/dev-python/google-auth-httplib2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-python/google-auth-httplib2
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-python/google-auth-httplib2')
-rw-r--r--dev-python/google-auth-httplib2/Manifest1
-rw-r--r--dev-python/google-auth-httplib2/google-auth-httplib2-0.1.0-r1.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/google-auth-httplib2/Manifest b/dev-python/google-auth-httplib2/Manifest
index 1354ad75d158..3df4e1a1209a 100644
--- a/dev-python/google-auth-httplib2/Manifest
+++ b/dev-python/google-auth-httplib2/Manifest
@@ -1,3 +1,4 @@
DIST google-auth-library-python-httplib2-0.1.0.tar.gz 25116 BLAKE2B dbb0393bafb1bbe67b99ac0783e687271c42256c7b283422b884b86d4c8a83222392a5514b812aae683ec7f887afa4bf81307079e676f793f02eb87e52a375e5 SHA512 52b0faf70e185cb89420377a06c77e2c45f6b910b85371fc2c42fdfb06a4ebca28b476201f9d179fbaa4a8bf7b6015703d023ddd95d482113e2cdbf79fd376b5
+EBUILD google-auth-httplib2-0.1.0-r1.ebuild 906 BLAKE2B 3c7834c0af615372c4dd568de34a4c3d97763b8475af77c120e44970da51c1ed4f5d9dd23279ede80d035868a9274dcc347c87927960e4c0b8be8affd9ff3652 SHA512 a7f09fa815b444af688563ede5abeb74fd67ad657ec8a4c6e96815dc508ecbe67a3b79ddd3a8d6d9d626fd4ae31deacf04edbc54c0d68896bfbc2dc0a6938644
EBUILD google-auth-httplib2-0.1.0.ebuild 871 BLAKE2B 25da43187da93a88b038f743c9028d5c1eb28439c71b26ebc9e3eee1b61bc6b3a02c84ea35fd452f27894efed28cfaae74a44512ba9f504aeea37c72d935ce86 SHA512 58b0a290f0821563d72671c087dcf31985fa2e9baebaa7d8fb159c50c808f2c1f608b7f7a873a266567bd310b9b7d6617f9a80db76309a2484ed1bf023f32ae2
MISC metadata.xml 539 BLAKE2B eefbb5db5d696a71dbc67ace7becb705ac048632e0434e516aa2fbc6e963ea86713beb4b1a2109e29e16b9844c2bf62ebbec527379c13f0f390d2cdae23e77e8 SHA512 03b6328fffb6014d3cccac0687e2b652b5522f345c125ec69c62dc020a8a6baaef444dbdfadef6dd8119d1a19449d57893e207ae4f2ac35d5592c23cad931c2c
diff --git a/dev-python/google-auth-httplib2/google-auth-httplib2-0.1.0-r1.ebuild b/dev-python/google-auth-httplib2/google-auth-httplib2-0.1.0-r1.ebuild
new file mode 100644
index 000000000000..c086d756d5e9
--- /dev/null
+++ b/dev-python/google-auth-httplib2/google-auth-httplib2-0.1.0-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+MY_P="google-auth-library-python-httplib2-${PV}"
+DESCRIPTION="httplib2 Transport for Google Auth"
+HOMEPAGE="https://pypi.org/project/google-auth-httplib2/
+ https://github.com/googleapis/google-auth-library-python-httplib2"
+SRC_URI="
+ https://github.com/googleapis/google-auth-library-python-httplib2/archive/v${PV}.tar.gz
+ -> ${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/httplib2[${PYTHON_USEDEP}]
+ dev-python/google-auth[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest