summaryrefslogtreecommitdiff
path: root/dev-python/google-auth-httplib2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/google-auth-httplib2
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/google-auth-httplib2')
-rw-r--r--dev-python/google-auth-httplib2/Manifest3
-rw-r--r--dev-python/google-auth-httplib2/google-auth-httplib2-0.0.2.ebuild39
-rw-r--r--dev-python/google-auth-httplib2/metadata.xml12
3 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/google-auth-httplib2/Manifest b/dev-python/google-auth-httplib2/Manifest
new file mode 100644
index 000000000000..2e464d22b82c
--- /dev/null
+++ b/dev-python/google-auth-httplib2/Manifest
@@ -0,0 +1,3 @@
+DIST google-auth-httplib2-0.0.2.tar.gz 10830 SHA256 56ad472d166aeddab10fbf6b6a39848c959379e12b9cbcb5ccf2530eda61b4de SHA512 ec111fdad930bfe3f8f97df70a8bef955920ab2cb0c383d7888ff444f19e5c176dd5aabe10f9a870c86035791a2b27e3e8e1276360626ff5e430db823da5efb0 WHIRLPOOL 8bf72785a168905a6d1a5d6f2ec093d54e93799f09c0e0f5e53bb0de96c200a8638ac68bc393cd0b4dce4cca4b6299a202086d943dec917ee8733aa792869a99
+EBUILD google-auth-httplib2-0.0.2.ebuild 1162 SHA256 62f29f26d4ac38446314d4858e64085559c3fa6507074a42f1b304dc9e5b8903 SHA512 0fcf7e99c549215ca65264ba2b9936a8af0149e2bcfc3b075e64860bfc3da982a6dc94d89eca5a7c6321751ff1b06b6bd4fb296b38d79df5df9a60bf1e4af8b4 WHIRLPOOL 0ccdc35a5fad325edff4d7d9b1c90d89d1d7bd9c702fc962150fcee8c9b3b1ce3a5816e103e7d033315a6eb9e3706e18f5e37628aeaf5ae50f777ca7a2d201a3
+MISC metadata.xml 422 SHA256 322f7d321267935e9f3336798db8ee0cd8c720d8c4a9765a59e02866cbe86adb SHA512 bba9deccadfaf0b663a2f6239633f20ee02838d98cfa25e4d8c399e5635c4cd0b811dbf821f18edf98b328a56a37146bc316aceed6b5b057ef5fd2cd151bbaa2 WHIRLPOOL 13e3b6810f849ff0c1d49b00b41f20a125f11d11c342539b1c25d9aa05c7f2dab9cd070d5bdb4ed3575e2ba2e6d148cb14c120b762e994000b3707b7d71ad4e7
diff --git a/dev-python/google-auth-httplib2/google-auth-httplib2-0.0.2.ebuild b/dev-python/google-auth-httplib2/google-auth-httplib2-0.0.2.ebuild
new file mode 100644
index 000000000000..ca26a78531f7
--- /dev/null
+++ b/dev-python/google-auth-httplib2/google-auth-httplib2-0.0.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
+
+inherit distutils-r1
+
+EGIT_COMMIT="607e86011141e8885b1f52826d57c8b5ff588ffc"
+MY_PN=google-auth-library-python-httplib2
+DESCRIPTION="httplib2 Transport for Google Auth"
+HOMEPAGE="https://pypi.python.org/pypi/google-auth-httplib2 https://github.com/GoogleCloudPlatform/google-auth-library-python-httplib2"
+# PyPi tarball is missing unit tests
+#SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="https://github.com/GoogleCloudPlatform/google-auth-library-python-httplib2/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~arm64 x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/httplib2[${PYTHON_USEDEP}]
+ dev-python/google-auth[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ )"
+
+S=${WORKDIR}/${MY_PN}-${EGIT_COMMIT}
+
+python_test() {
+ py.test -v || die "Tests failed under ${EPYTHON}"
+}
diff --git a/dev-python/google-auth-httplib2/metadata.xml b/dev-python/google-auth-httplib2/metadata.xml
new file mode 100644
index 000000000000..aaafa4650042
--- /dev/null
+++ b/dev-python/google-auth-httplib2/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>zmedico@gentoo.org</email>
+ <name>Zac Medico</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">google-auth-httplib2</remote-id>
+ <remote-id type="github">GoogleCloudPlatform/google-auth-library-python-httplib2</remote-id>
+ </upstream>
+</pkgmetadata>