summaryrefslogtreecommitdiff
path: root/dev-python/google-auth-oauthlib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-python/google-auth-oauthlib
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-python/google-auth-oauthlib')
-rw-r--r--dev-python/google-auth-oauthlib/Manifest4
-rw-r--r--dev-python/google-auth-oauthlib/google-auth-oauthlib-0.5.0.ebuild35
-rw-r--r--dev-python/google-auth-oauthlib/google-auth-oauthlib-0.5.1.ebuild35
3 files changed, 74 insertions, 0 deletions
diff --git a/dev-python/google-auth-oauthlib/Manifest b/dev-python/google-auth-oauthlib/Manifest
index 0fc060b76662..ec515ebd7658 100644
--- a/dev-python/google-auth-oauthlib/Manifest
+++ b/dev-python/google-auth-oauthlib/Manifest
@@ -1,3 +1,7 @@
DIST google-auth-library-python-oauthlib-0.4.6.gh.tar.gz 50982 BLAKE2B 93980a69777089125bca9f583cae0b64f9facf699da3ac135561a9cf135122d9e22a6c0be3325d366dd77a2240fb16d5c63633a216cfee07b9fceb2239227c86 SHA512 a20a85c073a6208d72c8f6ceb34544241f599e716b1191bfc52bcc367797efc18d0e2b94d4e433cec692282b00428bcb4d7e73ed48a26e66d6005189d5dddb77
+DIST google-auth-library-python-oauthlib-0.5.0.gh.tar.gz 52118 BLAKE2B 596f9af156030b0dbc0a35c3946ab865370fa326176fc33b04d55aa5d99950718d275f69b399d9afe303ee84f9c5823571eb4c144353f17fe6a64bbca7a35e18 SHA512 7da0d1c5e8c20aee843798c317a2c1edd29caf98abaf8895e354e20279c45395de4a522e21f11dbbe9e67c3bd984ded101b0cde04519b9256d80bdc42501a71a
+DIST google-auth-library-python-oauthlib-0.5.1.gh.tar.gz 53101 BLAKE2B 2edaad7dbe42834d440bb30bcf836e01a575616160af045844da6c853f93a3a7a1c80367bbe58d47dbbdaf9e5b061abf780d9edd48f311e30d79025c934c3764 SHA512 628da0161739c9f0ba5963db6f21da71fde01ff81340d9242adcc74468c92c290693cfa4d98affed79556299621e74083992b54346c14940c1e88c5a5c683408
EBUILD google-auth-oauthlib-0.4.6.ebuild 864 BLAKE2B 10b7813d88167227979f33417164a7b1dec78cc3f239a4ed5975d5057b2d39b94204d897ccd17eed81ee25656468ba5790dce531533d4099d7337b1e02dc59c5 SHA512 96e06c8be123e55b2dd9a0e26b70ea8edc9ecfb73b8e0550b209d1f46e819b06b4df4327ddd6a4b3d3f59441547bf88ce19cb5fcf6dfeb2b455df8c2f625c902
+EBUILD google-auth-oauthlib-0.5.0.ebuild 870 BLAKE2B 15490d4b6ea29d35ec776127502df685e10d4faef6f739349880ae046ede83aef28208c44b6090985e42aab170b077fd3ee9d9bfe81d2a312b05380951975bbf SHA512 dc7093ce0450448b8afefc9af564297ea3e538621512dd338181a2ec5d25071cdec073114dd6cc16f5ee71c5e77f4f38ceec57e3d8ccc36ae916703270025d1c
+EBUILD google-auth-oauthlib-0.5.1.ebuild 870 BLAKE2B 15490d4b6ea29d35ec776127502df685e10d4faef6f739349880ae046ede83aef28208c44b6090985e42aab170b077fd3ee9d9bfe81d2a312b05380951975bbf SHA512 dc7093ce0450448b8afefc9af564297ea3e538621512dd338181a2ec5d25071cdec073114dd6cc16f5ee71c5e77f4f38ceec57e3d8ccc36ae916703270025d1c
MISC metadata.xml 410 BLAKE2B 23af42a2aa614f119e10cf5d57c3c37abb69ad8d9b1e16445fb92c9f00bdd78f6b1a6a51dff4ebb98bbb03e0002e73eb68cffcf857372dd94848187637c60219 SHA512 c19dd3af098644d5068ec677be51615885bb1267ba9bfb867609725e2a824a74934e2fe25909ea7406c91ca405d44e4c7191a14d3d1bc7b3a60c29445456d3d1
diff --git a/dev-python/google-auth-oauthlib/google-auth-oauthlib-0.5.0.ebuild b/dev-python/google-auth-oauthlib/google-auth-oauthlib-0.5.0.ebuild
new file mode 100644
index 000000000000..4a1afbdaab4a
--- /dev/null
+++ b/dev-python/google-auth-oauthlib/google-auth-oauthlib-0.5.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+MY_P=google-auth-library-python-oauthlib-${PV}
+DESCRIPTION="Google Authentication Library"
+HOMEPAGE="
+ https://pypi.org/project/google-auth-oauthlib/
+ https://github.com/googleapis/google-auth-library-python-oauthlib"
+SRC_URI="
+ https://github.com/googleapis/google-auth-library-python-oauthlib/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/click-6.0.0[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-oauthlib-0.7.0[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? ( dev-python/mock[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests pytest
diff --git a/dev-python/google-auth-oauthlib/google-auth-oauthlib-0.5.1.ebuild b/dev-python/google-auth-oauthlib/google-auth-oauthlib-0.5.1.ebuild
new file mode 100644
index 000000000000..4a1afbdaab4a
--- /dev/null
+++ b/dev-python/google-auth-oauthlib/google-auth-oauthlib-0.5.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+MY_P=google-auth-library-python-oauthlib-${PV}
+DESCRIPTION="Google Authentication Library"
+HOMEPAGE="
+ https://pypi.org/project/google-auth-oauthlib/
+ https://github.com/googleapis/google-auth-library-python-oauthlib"
+SRC_URI="
+ https://github.com/googleapis/google-auth-library-python-oauthlib/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/click-6.0.0[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-oauthlib-0.7.0[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? ( dev-python/mock[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests pytest