summaryrefslogtreecommitdiff
path: root/dev-python/google-auth-oauthlib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-12 09:56:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-12 09:56:54 +0000
commitebc282ef4dfa408accac685565b8ee5f6faec119 (patch)
treec0a4f713228cda0ab17eed46f0bb7ca8cb8be2f6 /dev-python/google-auth-oauthlib
parent6c8694a707151d59555b0e4e48235f085ce166c3 (diff)
gentoo auto-resync : 12:02:2023 - 09:56:54
Diffstat (limited to 'dev-python/google-auth-oauthlib')
-rw-r--r--dev-python/google-auth-oauthlib/Manifest2
-rw-r--r--dev-python/google-auth-oauthlib/google-auth-oauthlib-1.0.0.ebuild39
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/google-auth-oauthlib/Manifest b/dev-python/google-auth-oauthlib/Manifest
index 09994c659451..8f4f58ef70f9 100644
--- a/dev-python/google-auth-oauthlib/Manifest
+++ b/dev-python/google-auth-oauthlib/Manifest
@@ -1,3 +1,5 @@
DIST google-auth-library-python-oauthlib-0.8.0.gh.tar.gz 71774 BLAKE2B 100aa01586f5df18453713610f3ed954a196e3d0c8d4dc15b8a67335951cbc2eaa15e3fa4bf7c7ba161418550bb7cfc68630fca0efe697a9c65ccbd7e0ce05d9 SHA512 3090d9b3ad25df6e8151e49a0cd96e7226aac2cecbbf289ccbc8cf4704ec86d882c11546b26f3a2ba9b047c19408f0cb939b9caf489aa935f49f8990ab7bfa55
+DIST google-auth-library-python-oauthlib-1.0.0.gh.tar.gz 71294 BLAKE2B f0f085ffbec620106f5e7ead56085cee4642932a0fea1bfeec01d1f3b77a8d97aa4e6cdbc29c303abebb30e1994de86cfbb6a950bb34fc243dd312b251afc5da SHA512 74eef43e4ce8de55170c7362eaddcd796c683b3d361d52ff02db1f74b301f12e57f0acb2b52fcc5a6e661b47e3066a780915955b8d933314646483b43c8c5b68
EBUILD google-auth-oauthlib-0.8.0-r2.ebuild 878 BLAKE2B 7516cef25ce2af84ea44bbf16a87af1399f7da90296c0549f7339b58a50147ca6a3a4bb7dfd11e9cf115872d6ad6b44c08baa76544e26a7f1cf348a9a82a0e5f SHA512 e33125b63875d02a5267017ddde5ca894901c6ffefed2c821237e0ce3b5cadf5dee0db3d9cd871d3398b707331a4d40fdec931fa8ab47d56afb3916640cc4732
+EBUILD google-auth-oauthlib-1.0.0.ebuild 878 BLAKE2B 7516cef25ce2af84ea44bbf16a87af1399f7da90296c0549f7339b58a50147ca6a3a4bb7dfd11e9cf115872d6ad6b44c08baa76544e26a7f1cf348a9a82a0e5f SHA512 e33125b63875d02a5267017ddde5ca894901c6ffefed2c821237e0ce3b5cadf5dee0db3d9cd871d3398b707331a4d40fdec931fa8ab47d56afb3916640cc4732
MISC metadata.xml 410 BLAKE2B 23af42a2aa614f119e10cf5d57c3c37abb69ad8d9b1e16445fb92c9f00bdd78f6b1a6a51dff4ebb98bbb03e0002e73eb68cffcf857372dd94848187637c60219 SHA512 c19dd3af098644d5068ec677be51615885bb1267ba9bfb867609725e2a824a74934e2fe25909ea7406c91ca405d44e4c7191a14d3d1bc7b3a60c29445456d3d1
diff --git a/dev-python/google-auth-oauthlib/google-auth-oauthlib-1.0.0.ebuild b/dev-python/google-auth-oauthlib/google-auth-oauthlib-1.0.0.ebuild
new file mode 100644
index 000000000000..428011855aa4
--- /dev/null
+++ b/dev-python/google-auth-oauthlib/google-auth-oauthlib-1.0.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+MY_P=google-auth-library-python-oauthlib-${PV}
+DESCRIPTION="Google Authentication Library"
+HOMEPAGE="
+ https://github.com/googleapis/google-auth-library-python-oauthlib/
+ https://pypi.org/project/google-auth-oauthlib/
+"
+SRC_URI="
+ https://github.com/googleapis/google-auth-library-python-oauthlib/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/click-6.0.0[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-2.15.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-oauthlib-0.7.0[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest