summaryrefslogtreecommitdiff
path: root/dev-python/google-auth
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-18 11:06:49 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-18 11:06:49 +0000
commitab3da91fb6c91a9df52fff8f991570f456fd3c7a (patch)
treee8f3bfa2c6c3d20ec3b9c352c839e23949068b6b /dev-python/google-auth
parent6abbf81ef2f298e3221ff5e67a1f3c5f23958212 (diff)
gentoo resync : 18.12.2020
Diffstat (limited to 'dev-python/google-auth')
-rw-r--r--dev-python/google-auth/Manifest2
-rw-r--r--dev-python/google-auth/google-auth-1.24.0.ebuild57
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/google-auth/Manifest b/dev-python/google-auth/Manifest
index 23f4426a7897..6d9517a4ff7d 100644
--- a/dev-python/google-auth/Manifest
+++ b/dev-python/google-auth/Manifest
@@ -1,3 +1,5 @@
DIST google-auth-1.20.1.tar.gz 107375 BLAKE2B 2f57cd9752c46891c59ed13e2ec8c6f98e5b3cd07d329769a78872877a17580c1ff5bb9da0381ef9bd4b6b9f72f04125ef71102543cfe1dc7bc3b09a5d5d9039 SHA512 6aad44b58c71f96c686606d6e8b6f273c64ce1559737920ccc31ad761442cad7f5fab19a59daee9408b284405a00c2de769c00221ac91bcfdd48851dba6f680f
+DIST google-auth-1.24.0.tar.gz 120351 BLAKE2B b0a78ad87622bc806cce72847d5dad3844afe080ffbcd822575dab6208952806360bed4e8756133d5b4fe2755f6cbeeb239b8f51634dd3d4cede9346372b689a SHA512 3e678dd946eb6c3c865cd35df1480a96ed35cf14b973f2239c5213b223a6569b4a9642609ac51243af75c662a08bbf0518d8592db97af297cf67c52b83019e30
EBUILD google-auth-1.20.1.ebuild 1519 BLAKE2B 975bbb50a2965ef5fa5e9b0ed8b374b0bde75691094803657c0577010654524d09ed22b68152dd9466a90849bf92ce135e6bf07d0f3eb61514a6d2d959c31697 SHA512 828fdeb4565666d4b7ed43d182f6968ba549c638389207ca094247835384eb329fccd6ba0ac7aa2462a8dca237fd77c60e07d58506a7e7197f1bb91ca0e5e3ea
+EBUILD google-auth-1.24.0.ebuild 1639 BLAKE2B 9f836c6fcf709d9179e640323059c30feabeb48f38b2445d7701aa2d2f39726bad21e74e73844d218b21fed8e96129d62a2f9fccdeb28d28b3a7710c95cab082 SHA512 c63e2444201d6394666204087a56401c16466b2d2df9af2e30066ba35770064058aef27868dccf61a8e03554a5eb8710338a0230aa37667d5d04fe7982e971ba
MISC metadata.xml 428 BLAKE2B 130f36eeb8949f23ff7658277485387897cc1688205de4f5ac7acd4e8e897a5212c07fbe36b4884f4b6d4c4755cbe1e99d0f9d37529a605d0f4df01445e7045a SHA512 82c278bcbbd1329e5b002b7382f11a5bcd8419080137ad09c51db944941669cf072401210d9990d1bb2adf98fd3e60f0f77415d9f2294e1cc2c68023040b9535
diff --git a/dev-python/google-auth/google-auth-1.24.0.ebuild b/dev-python/google-auth/google-auth-1.24.0.ebuild
new file mode 100644
index 000000000000..f33fd88d8afa
--- /dev/null
+++ b/dev-python/google-auth/google-auth-1.24.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Google Authentication Library"
+HOMEPAGE="https://github.com/GoogleCloudPlatform/google-auth-library-python https://pypi.org/project/google-auth/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/namespace-google[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-0.1.7[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-modules-0.2.1[${PYTHON_USEDEP}]
+ >=dev-python/rsa-3.1.4[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/cachetools-2.0.0[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/grpcio[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/moto[${PYTHON_USEDEP}]
+ dev-python/oauth2client[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # delete stray files included in the tarball
+ find "${S}"/tests -name '*.pyc' -delete || die
+ distutils-r1_src_prepare
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${ED}" -name '*.pth' -delete || die
+}