summaryrefslogtreecommitdiff
path: root/dev-python/google-auth
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
commite748ba9741f6540f4675c23e3e37b73e822c13a4 (patch)
tree23dece8beabb3a3d7c6c0273b0eb40b21c62a889 /dev-python/google-auth
parent908778078736bd36f7a60a2d576d415cb8e000fa (diff)
gentoo resync : 31.05.2021
Diffstat (limited to 'dev-python/google-auth')
-rw-r--r--dev-python/google-auth/Manifest2
-rw-r--r--dev-python/google-auth/google-auth-1.30.1.ebuild51
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/google-auth/Manifest b/dev-python/google-auth/Manifest
index cf1b4fbc0038..0c81d278b5d5 100644
--- a/dev-python/google-auth/Manifest
+++ b/dev-python/google-auth/Manifest
@@ -1,5 +1,7 @@
DIST google-auth-1.29.0.tar.gz 167058 BLAKE2B 0c6c9ac11330e46757bc554f7ae984d4ab94562e4524e0c579c0878fb093201240ebabc3a4f44f8d9f530a82ad5f84dd76100d57e2f874b78315c7f0d2cfb4fd SHA512 a6c8ca93ef493f16b7b16c2e1456891a09635bbc4a39053dc2c4cdca2f739692a74e4588c61c8aa5f06c1a5355ef304771770e26f1656edc0ef4c3c291df796d
DIST google-auth-1.30.0.tar.gz 169598 BLAKE2B 4b0a0e66255abc11c697ca2c3d77ea0b7cf72cc13f6b1630307018e6ea52bda57a1f856787394455d71c61b58103d4e5e24da62f6ffd95022042b48842efcbbe SHA512 d07d6946635071e601c684a60e99ecec532ec51425aa934ece48b124419cb4c69c7651505018471431a7cf14470f4f8d894a2121999d3a482d603d41e5a8e66c
+DIST google-auth-1.30.1.tar.gz 169244 BLAKE2B e496239807ab9ca64e1b5dc39726fa22b56d55f14883c983673064b8ea33f80dee013654d4808fead0d06e8b6ddc53554d094f42aede6e06224dc3a3c04e88d1 SHA512 7e35f5be9be160ddef4b579c2e5bc966f1d64f8f0bb75220e22fd3edb9c6f6140bdcf68055fdb13dd370e3d543206900cc9403237eb328d69418a384a4d0fe26
EBUILD google-auth-1.29.0.ebuild 1437 BLAKE2B 8ca006569936c4c27aba0c41a1101afc6cb03ee559e91c643525aa52e391edf48db40f0bc14b4f117e13cf18a85f0a3cbdf6fd5c7872878e7dde36e41c61f323 SHA512 36aae194362705122cbd36d52c431935d352b17fd0dda3221c17f900f71ab5b9e659295c2cfa3f21a67d831474ddda829435a07f997560241ea23b93755495e6
EBUILD google-auth-1.30.0.ebuild 1446 BLAKE2B 69be2bce49c90a3a12c84a8f73e256707913762472d0a8bc94b399c02a92ecb9f3e1f040f27397c31c397f0cf1c8a2eaceae0015617b513ff2b1ae689ecaab22 SHA512 a56700dd0ac48ea125f1723d1e2035c13b798167307412dcf0c0f408262abf9d2dce1c92a5138b8cbe63b981ce690c2a0aa0ea91b13c963589cb2a83cc295112
+EBUILD google-auth-1.30.1.ebuild 1446 BLAKE2B 69be2bce49c90a3a12c84a8f73e256707913762472d0a8bc94b399c02a92ecb9f3e1f040f27397c31c397f0cf1c8a2eaceae0015617b513ff2b1ae689ecaab22 SHA512 a56700dd0ac48ea125f1723d1e2035c13b798167307412dcf0c0f408262abf9d2dce1c92a5138b8cbe63b981ce690c2a0aa0ea91b13c963589cb2a83cc295112
MISC metadata.xml 520 BLAKE2B c54ed12c21d00df20c4a605471df6fda2da0ae4bdad730a543a61cb1aed9f159af9db78675c3132142494a32c951560cb9f56a42844a29c3fe65c7522b34cd3e SHA512 761949db3693b2102936c08e9d02c3bfc91a2f1f73489e0fe562c8a64ceb4c1908f9fc7c19f2f142be30fb421075ce2be4628fd4d7d88748a1ac4fa5d42a222f
diff --git a/dev-python/google-auth/google-auth-1.30.1.ebuild b/dev-python/google-auth/google-auth-1.30.1.ebuild
new file mode 100644
index 000000000000..4c3742ac5a32
--- /dev/null
+++ b/dev-python/google-auth/google-auth-1.30.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Google Authentication Library"
+HOMEPAGE="
+ https://github.com/googleapis/google-auth-library-python/
+ https://pypi.org/project/google-auth/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/namespace-google[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-0.1.7[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-modules-0.2.1[${PYTHON_USEDEP}]
+ >=dev-python/rsa-3.1.4[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/cachetools-2.0.0[${PYTHON_USEDEP}]
+ "
+BDEPEND="
+ test? (
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/grpcio[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/moto[${PYTHON_USEDEP}]
+ dev-python/oauth2client[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ dev-python/pyu2f[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${ED}" -name '*.pth' -delete || die
+}