summaryrefslogtreecommitdiff
path: root/dev-python/google-pasta/google-pasta-0.1.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-02-16 12:59:29 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-02-16 12:59:29 +0000
commit79599515788b85b18aa655e7b7f8cc05c1bbddd8 (patch)
treeade7cb031f363fad64c77139dea7aa3d81908537 /dev-python/google-pasta/google-pasta-0.1.1.ebuild
parent6bc2e4d7c5906e46a8f275a876ead6ec41aca5bb (diff)
gentoo resync : 16.02.1018
Diffstat (limited to 'dev-python/google-pasta/google-pasta-0.1.1.ebuild')
-rw-r--r--dev-python/google-pasta/google-pasta-0.1.1.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/google-pasta/google-pasta-0.1.1.ebuild b/dev-python/google-pasta/google-pasta-0.1.1.ebuild
new file mode 100644
index 000000000000..d361a804c7de
--- /dev/null
+++ b/dev-python/google-pasta/google-pasta-0.1.1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python{3_5,3_6} )
+inherit distutils-r1
+
+DESCRIPTION="AST-based Python refactoring library"
+HOMEPAGE="https://pypi.org/project/google-pasta/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+BDEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"