summaryrefslogtreecommitdiff
path: root/dev-python/gpep517/gpep517-9.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-24 14:53:22 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-24 14:53:22 +0100
commitf73bef95b39f4fbc8f0278c26ad1534e5eec322f (patch)
tree64bc7f001d8ccd5ed51b0a301b91aad797e72ac5 /dev-python/gpep517/gpep517-9.ebuild
parent28267a5e528b273fbd1b0f5f52ecaab4b03016ab (diff)
gentoo auto-resync : 24:07:2022 - 14:53:22
Diffstat (limited to 'dev-python/gpep517/gpep517-9.ebuild')
-rw-r--r--dev-python/gpep517/gpep517-9.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/gpep517/gpep517-9.ebuild b/dev-python/gpep517/gpep517-9.ebuild
new file mode 100644
index 000000000000..ee64cb1d660f
--- /dev/null
+++ b/dev-python/gpep517/gpep517-9.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
+EAPI=7
+
+DISTUTILS_USE_PEP517=no
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A backend script to aid installing Python packages in Gentoo"
+HOMEPAGE="
+ https://pypi.org/project/gpep517/
+ https://github.com/mgorny/gpep517/
+"
+SRC_URI="
+ https://github.com/mgorny/gpep517/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND="
+ >=dev-python/installer-0.5.0[${PYTHON_USEDEP}]
+ >=dev-python/tomli-1.2.3[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_install() {
+ python_domodule gpep517
+ python_newscript - gpep517 <<-EOF
+ #!${EPREFIX}/usr/bin/python
+ import sys
+ from gpep517.__main__ import main
+ sys.exit(main())
+ EOF
+}