summaryrefslogtreecommitdiff
path: root/dev-python/gpep517
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-17 00:01:35 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-17 00:01:35 +0100
commit6c9dc10e04cd513437e046ccca0e51a3d6d4dc7c (patch)
treeb7183e321a607f857cc5c62cfbd5bae7cbfb3982 /dev-python/gpep517
parent66113e7871aede225d661473925cea4cce9e6d23 (diff)
gentoo auto-resync : 17:05:2024 - 00:01:35
Diffstat (limited to 'dev-python/gpep517')
-rw-r--r--dev-python/gpep517/Manifest2
-rw-r--r--dev-python/gpep517/gpep517-16.ebuild48
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/gpep517/Manifest b/dev-python/gpep517/Manifest
index 1dfeaf30565c..53be8578a0f7 100644
--- a/dev-python/gpep517/Manifest
+++ b/dev-python/gpep517/Manifest
@@ -1,3 +1,5 @@
DIST gpep517-15.gh.tar.gz 17535 BLAKE2B 265c2392cc70f4a94f6b8329dbba0ec5eb821e687bba553009bdc5e230d856fe6f105c873a79ee7ca99fb75c072c3d3c3b4f716ca873d13a8e393b33a97c8540 SHA512 7c3b878220e907ef801301eadc0e3031dd3c31770cc50bb7119ab32f9244c8a33792b4896ddeffc5d4b7be9f1d881fba5179de155f11845f510e455be59fb92e
+DIST gpep517-16.gh.tar.gz 23951 BLAKE2B 9be3bf7845f85b756444e5699509cf12455ea71204fb0e9a4899000cd2802cc063cd785f490d6e3d9ac48bf79a9e43a0edcfb483d898f718be6d783a98834cdd SHA512 fcd7cb0f98003a8ecb9976cffe3d4140b16e537dbfcfa8e8416569cd7e38e8e9ab359b35c1e22b830dc2711b3c07f8e3113c0f6b73d415ce63ad5f7d76f180c6
EBUILD gpep517-15.ebuild 1167 BLAKE2B 4ea8bb133fe6c98e7a0eff96d91592378c45dc5a67e0760f4ed21f9321a66e1b0d41f0e7103a518051fd6108212c01a0cc39aabf82e9c545bb3a3365cab4b3dd SHA512 9c5439efac9cb2028a351a1059e56e007df3bdf1774729b0966c68f8826cb82fca825a4cdd226933af11ec41b18dfed2348a0c2cd611ed9eeceaeed27ba44cdd
+EBUILD gpep517-16.ebuild 1173 BLAKE2B 9f1c5e2bcff1266d2af629aea4d5e6b68ee5bfb9234ed2e930314dd259a98d611c8987c801f4ea9dbba57f789c5664a05944a77a74a2a362cc4132656def4ef4 SHA512 63e200c8b3b0a9bb8bcfcbfbe5ff3810d99366a4e1ab9784331e7c6fad90284461d2a42a405f12801bfa864834c82391b7172b96cd79bd5868388e61c0099ce4
MISC metadata.xml 396 BLAKE2B b67a7e2109f002e48023fc60f19fe2aa7f224010795434815a4c7c0d075dba6cb27e9d443ff86b84ba582a12b30dec5dc8ce9c91419dc2d04c1c61f45e901192 SHA512 402dc1c9cad90e122443599282d03d317a29d31189aa1532041104ae4b6292340b5744488075c9f52877f450561072ef4d8750db65412bcb81b2af5648078b37
diff --git a/dev-python/gpep517/gpep517-16.ebuild b/dev-python/gpep517/gpep517-16.ebuild
new file mode 100644
index 000000000000..30dbb097b1ca
--- /dev/null
+++ b/dev-python/gpep517/gpep517-16.ebuild
@@ -0,0 +1,48 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 8 -- sys-apps/portage dep
+EAPI=8
+
+DISTUTILS_USE_PEP517=no
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="A backend script to aid installing Python packages in Gentoo"
+HOMEPAGE="
+ https://pypi.org/project/gpep517/
+ https://github.com/projg2/gpep517/
+"
+SRC_URI="
+ https://github.com/projg2/gpep517/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+RDEPEND="
+ >=dev-python/installer-0.5.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-1.2.3[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -o tmp_path_retention_policy=all
+}
+
+python_install() {
+ python_domodule gpep517
+ python_newscript - gpep517 <<-EOF
+ #!${EPREFIX}/usr/bin/python
+ import sys
+ from gpep517.__main__ import main
+ sys.exit(main())
+ EOF
+}