summaryrefslogtreecommitdiff
path: root/dev-python/graphy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/graphy
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/graphy')
-rw-r--r--dev-python/graphy/Manifest3
-rw-r--r--dev-python/graphy/graphy-1.0-r1.ebuild49
-rw-r--r--dev-python/graphy/metadata.xml11
3 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/graphy/Manifest b/dev-python/graphy/Manifest
new file mode 100644
index 000000000000..aabcd71bbb8e
--- /dev/null
+++ b/dev-python/graphy/Manifest
@@ -0,0 +1,3 @@
+DIST graphy_1.0.tar.bz2 69099 BLAKE2B c14e969c7eb3713c9eece2a7b05f018e5a72cbd20b1ab1bb49897c7d569bd9a63b3b73530983d4015a92cbdd0c76cab9fd4aeeb1b0f7525eb2226732947a1452 SHA512 39b85b21dd0e984a3b7895a090d6676d2fc12e629bcb5f2e486ad02b6cacdd57ab150c1aa4364cae571cd8e6fbca20b5744c079be532b6f4ea2668899c9932e3
+EBUILD graphy-1.0-r1.ebuild 907 BLAKE2B be9a3845842b256474981a50b5428389d72ed05c6e5b434e624bbccd46ccba6df8e6e8dae2e7173ec3b64c00dea5f4ca66ded66c721597486b563b07b714362d SHA512 42e76ba2ebc22fe16e7ab91dbbd6c295f686103310491decc0c9b871a717bbbba69acaef4ed86f3a488c8a6c4fc90150b89bffa184c1833ae770379ad86edf4a
+MISC metadata.xml 326 BLAKE2B 7af692f2b9ede8b539ed85fde2864db5c211fb3fb5d11164d97c9f2c19213069dc3701a6b6b2ca556c14bf92d172eb05d38e663b3e4c42f2705ce104743a06cd SHA512 013f991fae51821c931d805c76bc412a131abb57390dbe03f47f6ed3cb32ff3b7608b6878bdca8f8d675fe09c6c5ecc694c476adddecef3411177e87393a526f
diff --git a/dev-python/graphy/graphy-1.0-r1.ebuild b/dev-python/graphy/graphy-1.0-r1.ebuild
new file mode 100644
index 000000000000..67fe60064caa
--- /dev/null
+++ b/dev-python/graphy/graphy-1.0-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+MY_P=${PN}_${PV}
+
+DESCRIPTION="Simple Chart Library for Python"
+HOMEPAGE="https://pypi.org/project/Graphy/"
+SRC_URI="https://${PN}.googlecode.com/files/${MY_P}.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="examples"
+
+S=${WORKDIR}/${MY_P}
+
+python_prepare_all() {
+ esvn_clean
+ distutils-r1_python_prepare_all
+}
+
+python_compile() {
+ :
+}
+
+python_test() {
+ local PYTHONPATH
+ mkdir -p "${BUILD_DIR}"/lib || die
+ cp -r graphy "${BUILD_DIR}"/lib/ || die
+ "${PYTHON}" "${BUILD_DIR}"/lib/graphy/all_tests.py \
+ || die "Tests fail with ${EPYTHON}"
+}
+
+python_install() {
+ python_domodule graphy
+ python_optimize
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/graphy/metadata.xml b/dev-python/graphy/metadata.xml
new file mode 100644
index 000000000000..e81f2f46b144
--- /dev/null
+++ b/dev-python/graphy/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="google-code">graphy</remote-id>
+ </upstream>
+</pkgmetadata>