summaryrefslogtreecommitdiff
path: root/dev-python/grpcio/grpcio-1.18.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-05-18 00:10:51 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-05-18 00:10:51 +0100
commiteccb70a7f91b2d22582587f26d1a28bb31408b45 (patch)
tree3223e1fd54201bcf4ebecac6fbe87361cbe643e2 /dev-python/grpcio/grpcio-1.18.0.ebuild
parenta2810985afabcc31d3eace5e61d8ea25b852ba17 (diff)
gentoo resync : 18.05.2019
Diffstat (limited to 'dev-python/grpcio/grpcio-1.18.0.ebuild')
-rw-r--r--dev-python/grpcio/grpcio-1.18.0.ebuild3
1 files changed, 2 insertions, 1 deletions
diff --git a/dev-python/grpcio/grpcio-1.18.0.ebuild b/dev-python/grpcio/grpcio-1.18.0.ebuild
index c2e61e26d6d3..77cc606e199b 100644
--- a/dev-python/grpcio/grpcio-1.18.0.ebuild
+++ b/dev-python/grpcio/grpcio-1.18.0.ebuild
@@ -4,7 +4,7 @@
EAPI=7
PYTHON_COMPAT=( python2_7 python3_{5,6} )
-inherit distutils-r1
+inherit distutils-r1 multiprocessing
DESCRIPTION="High-performance RPC framework (python libraries)"
HOMEPAGE="https://grpc.io"
@@ -33,5 +33,6 @@ python_compile() {
export GRPC_PYTHON_BUILD_SYSTEM_OPENSSL=1
export GRPC_PYTHON_BUILD_SYSTEM_ZLIB=1
export GRPC_PYTHON_BUILD_WITH_CYTHON=1
+ export GRPC_PYTHON_BUILD_EXT_COMPILER_JOBS="$(makeopts_jobs)"
distutils-r1_python_compile
}