summaryrefslogtreecommitdiff
path: root/dev-python/grpcio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-10-27 03:04:35 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-10-27 03:04:35 +0000
commit83d9fce566bb89f6976f36f5314bfc88b6d261fa (patch)
tree8d8a18f75ff0a6a98313046fcd757ee0135db98c /dev-python/grpcio
parentd0349ca0f4903608beca459a9db2068dab9fa6ea (diff)
gentoo auto-resync : 27:10:2024 - 03:04:35
Diffstat (limited to 'dev-python/grpcio')
-rw-r--r--dev-python/grpcio/Manifest2
-rw-r--r--dev-python/grpcio/grpcio-1.67.0-r1.ebuild (renamed from dev-python/grpcio/grpcio-1.67.0.ebuild)33
2 files changed, 25 insertions, 10 deletions
diff --git a/dev-python/grpcio/Manifest b/dev-python/grpcio/Manifest
index 2ed097acf394..aae251f0b57c 100644
--- a/dev-python/grpcio/Manifest
+++ b/dev-python/grpcio/Manifest
@@ -1,4 +1,4 @@
DIST grpc-1.67.0.gh.tar.gz 17317493 BLAKE2B 81aaf9a4d293dd41d9d068e81eb8a9898b610498722dd6f9c5ff88118fc5a31a936ac83c7cdb4f56c288d131c7721beed8e307dd91bf3de5cc25951cdb06de5a SHA512 5e76a3147ca051e5304d5d64eefe124cd446dd5d7bd9a65667bae5474b59f70b32368d225e8345c9414bddb968c1390b8bcd08ed97abb62b543528289b29ec35
DIST grpcio_tools-1.67.0.tar.gz 5159163 BLAKE2B 54a7db77514033c4747d20a13fded114828fed23f649587c649f5ad2716d4bb31b80eeda560d55ae087a564cb9d34563a612cc91df581ae6b9a761f307828397 SHA512 f9644b4424aa68f1ae4d679c7b635db9bbfc0b493c76caf7d2e9fe0a49e5e81b6f146666c8dba3fc1d1c0db141f8fb362dd0ede0842c34cb178009412a672ec5
-EBUILD grpcio-1.67.0.ebuild 2908 BLAKE2B 9e5adb365daab44674c640c7bd679a60bf7e4ea8390b7caab5af0d32710a34019845fe9d4ae94791a95fa01da5c50afb1198655dc97ee7ef1ab16f2bfe2246dc SHA512 d272861fdec15113218856c23caaf9a6c7506cba7a1f3d2aefe464255c84d920f0421f027a371fb348bfae2e09f1d8409dbd730a795db05a4a9191b15a0e9be2
+EBUILD grpcio-1.67.0-r1.ebuild 3551 BLAKE2B 91c82242fb5d5787cd66a36d6d2204c7cbeb63fd36be7a45d3e8c937fefcb319773612a8fdf1905057d093677c6fd9c543f618d896e7f55557c1530c1967684b SHA512 2ebda666f7105bfc3493730ce57373af787da4063932d74b86d4109ae1dc23af2414076ec01df68dae25956f519460b66d7e3ab9fe3a8e774e3359909817d7c8
MISC metadata.xml 359 BLAKE2B f52910dcf3d43b85556cce901ebcad89f3aaa992fbb366fcc905858634eac2add4d14a83bb4e534d64278e11653e28e50a3349cd641dd97949e7fb53a52d0dc3 SHA512 78ccb4fe497528d5dd9135feb3613038b9686b7892ac04136419cd7ccb935f73b5783dba0b1392b643bb1aeae24a73559c19ba14a1c51483b818e83a5c681a24
diff --git a/dev-python/grpcio/grpcio-1.67.0.ebuild b/dev-python/grpcio/grpcio-1.67.0-r1.ebuild
index 2583aa2206fd..92a90bd06766 100644
--- a/dev-python/grpcio/grpcio-1.67.0.ebuild
+++ b/dev-python/grpcio/grpcio-1.67.0-r1.ebuild
@@ -7,7 +7,7 @@ DISTUTILS_EXT=1
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{10..13} )
-inherit distutils-r1 multiprocessing pypi
+inherit distutils-r1 flag-o-matic multiprocessing pypi
MY_P=grpc-${PV}
DESCRIPTION="HTTP/2-based RPC framework"
@@ -16,13 +16,14 @@ HOMEPAGE="
https://github.com/grpc/grpc/
https://pypi.org/project/grpcio/
"
-# Tests need other packages from the source tree
+# Tests need other packages from the source tree, so use a GitHub
+# archive. grpcio-tools is required for tests, and requires a bunch
+# of bundled libraries However, we also need bundled abseil-cpp,
+# so take that one from grpcio-tools to avoid two sdists.
SRC_URI="
https://github.com/grpc/grpc/archive/v${PV}.tar.gz
-> ${MY_P}.gh.tar.gz
- test? (
- $(pypi_sdist_url grpcio-tools)
- )
+ $(pypi_sdist_url grpcio-tools)
"
S=${WORKDIR}/${MY_P}
@@ -31,7 +32,6 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
DEPEND="
- dev-cpp/abseil-cpp:=
dev-libs/openssl:=
dev-libs/re2:=
net-dns/c-ares:=
@@ -52,17 +52,32 @@ BDEPEND="
EPYTEST_XDIST=1
distutils_enable_tests pytest
+src_unpack() {
+ default
+
+ # reuse the bundled abseil-cpp from grpcio-tools sdist.
+ ln -s "${WORKDIR}/grpcio_tools-${PV}/third_party/abseil-cpp/absl" \
+ "${S}/third_party/abseil-cpp/absl" || die
+}
+
src_configure() {
export GRPC_PYTHON_BUILD_EXT_COMPILER_JOBS="$(makeopts_jobs)"
- export GRPC_PYTHON_BUILD_SYSTEM_ABSL=1
+ # system abseil-cpp crashes with USE=-debug, sigh
+ # https://bugs.gentoo.org/942021
+ #export GRPC_PYTHON_BUILD_SYSTEM_ABSL=1
export GRPC_PYTHON_BUILD_SYSTEM_CARES=1
export GRPC_PYTHON_BUILD_SYSTEM_OPENSSL=1
export GRPC_PYTHON_BUILD_SYSTEM_RE2=1
export GRPC_PYTHON_BUILD_SYSTEM_ZLIB=1
export GRPC_PYTHON_BUILD_WITH_CYTHON=1
- # -std= required by modern abseil-cpp, rest copied from setup.py
- export GRPC_PYTHON_CFLAGS="-std=c++17 -fvisibility=hidden -fno-wrapv -fno-exceptions"
+ # copied from setup.py, except for removed -std= that does not apply
+ # to C code and causes warnings
+ export GRPC_PYTHON_CFLAGS="-fvisibility=hidden -fno-wrapv -fno-exceptions"
+ # required by abseil-cpp
+ append-cxxflags -std=c++14
+ # silence a lot of harmless noise from bad quality code
+ append-cxxflags -Wno-attributes
}
python_test() {