summaryrefslogtreecommitdiff
path: root/dev-python/gsd/gsd-2.4.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
commitabaa75b10f899ada8dd05b23cc03205064394bc6 (patch)
treeeca3dd248b73b92013cba00a0fcc1edf2696e19a /dev-python/gsd/gsd-2.4.0.ebuild
parent24fd814c326e282c4321965c31f341dad77e270d (diff)
gentoo resync : 22.01.2021
Diffstat (limited to 'dev-python/gsd/gsd-2.4.0.ebuild')
-rw-r--r--dev-python/gsd/gsd-2.4.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/gsd/gsd-2.4.0.ebuild b/dev-python/gsd/gsd-2.4.0.ebuild
new file mode 100644
index 000000000000..df802dc1650b
--- /dev/null
+++ b/dev-python/gsd/gsd-2.4.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+inherit distutils-r1
+
+DESCRIPTION="GSD - file format specification and a library to read and write it"
+HOMEPAGE="https://github.com/glotzerlab/gsd"
+SRC_URI="https://github.com/glotzerlab/gsd/releases/download/v${PV}/${PN}-v${PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]"
+BDEPEND="
+ ${RDEPEND}"
+
+S="${WORKDIR}/${PN}-v${PV}"