summaryrefslogtreecommitdiff
path: root/dev-python/gst-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-02-17 10:35:54 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-02-17 10:35:54 +0000
commit463397cf1e064185110fe57c568d73f99a06f5d1 (patch)
tree9aa75eefc5154eaf0e3c33658b830fc54dc68052 /dev-python/gst-python
parentc8d60dada2ec8eb48b2d2b290cd6683ccec40e39 (diff)
gentoo resync : 17.02.2021
Diffstat (limited to 'dev-python/gst-python')
-rw-r--r--dev-python/gst-python/Manifest2
-rw-r--r--dev-python/gst-python/gst-python-1.16.3.ebuild60
2 files changed, 62 insertions, 0 deletions
diff --git a/dev-python/gst-python/Manifest b/dev-python/gst-python/Manifest
index 5d7be0d75ec7..593e1f7d12db 100644
--- a/dev-python/gst-python/Manifest
+++ b/dev-python/gst-python/Manifest
@@ -1,4 +1,6 @@
AUX 1.16.2-python3.8.patch 1400 BLAKE2B 67e870a837f8fe2a2b7a5cc38ed0528a1afc56035074e95437df260fbea52834217617a18520dea55e71fc5b71b4f86120125b1ef35d88daf19f35504ab6fd5f SHA512 1dd7623488f9612ad195f3e920e1ff8bab321c9009dcecc0d359807c2cef6b733777c6aed8f500c0925c3a6dba356a3e2a333991bf232f302e0f028eb3de1234
DIST gst-python-1.16.2.tar.xz 414912 BLAKE2B 016e59fc7d29047dcf49901d4ccb1ff2e96950dc723cd7e9dd31e0fe92257e881ced1c93e7e4e531320be8fb9d6cb8382d2c31e460448d5d630ec7c8a0378024 SHA512 c274591cb820a2576ca236de0d1a2c2c53a9db11afc689e0385afe3d38fadc59c9230d65198e79e4059abb90c0e5b6d71f1ee4cf1439d92feaaffd2ab5cd3a23
+DIST gst-python-1.16.3.tar.xz 419932 BLAKE2B 3c3d7d8dbde7d77d57e340c68503c436ab03f8768be4dd67561b13712bf88d7f8025118cf6a2ff115fbd41b28dc9a3208f612d1b72bf449fd7b23be4437f837f SHA512 2b038c4fc4891ddcf09e58c9e3e8d8462c150589dbb8a1f8d0a1266cffe49fd83531b2eb97cd57baab0f416a2bb1ba81383b55bb953545f3eedc50b6895986c4
EBUILD gst-python-1.16.2.ebuild 1607 BLAKE2B 1aa78d47124bbf30ebb5935aadaa604da1e210be332b6729e1fecd3f5ec236391cba222768331c0636037f2a966868a862130ef370c9840baaf3d6edb3026984 SHA512 1468188abf402361dd050bf9cf74b41e672e8d51eed084fe80d59a2344aae86b207269114dd342955b82c5596240f887d9071432df65d9dc50e7ca32ea437c31
+EBUILD gst-python-1.16.3.ebuild 1558 BLAKE2B 4309170c795f3e85264118217e35a0c4de8dd450dbaf9d8c8747c3bc7ad20e5c624c25aa1c5b07a309510a753db09ba0c53692f6f7ba725e7738e695e145029d SHA512 e7b41500c58db496a581e0630b71ba5759736b4e486bdd87812c9207214036f4fa64043763e3126cb153fb5afde1babb65720a607d2f87ace3b13ea9a2745976
MISC metadata.xml 266 BLAKE2B 3180109d2a1479e9436a76fb478dfb1b23db0daedbf0ef264a469fbbfecd858adf6ec01f3fdc5c56270d0a9e1e150ac947f4a1f893e967d6b1dc1f1b8f6d4ccb SHA512 aa2ce82fa0c848119ff309462722e1d7897da904f9e1dc9ae12dd61582823b69cf5a40faf8da0825ec397d2f01d44e82cb56730d9545abd619a17696091eca75
diff --git a/dev-python/gst-python/gst-python-1.16.3.ebuild b/dev-python/gst-python/gst-python-1.16.3.ebuild
new file mode 100644
index 000000000000..11df6763cff4
--- /dev/null
+++ b/dev-python/gst-python/gst-python-1.16.3.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_7,3_8,3_9} )
+
+inherit meson python-r1 xdg-utils
+
+DESCRIPTION="A Python Interface to GStreamer"
+HOMEPAGE="https://gstreamer.freedesktop.org/"
+SRC_URI="https://gstreamer.freedesktop.org/src/${PN}/${P}.tar.xz"
+
+LICENSE="LGPL-2+"
+SLOT="1.0"
+KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ppc ppc64 ~sparc x86 ~amd64-linux ~x86-linux ~x86-solaris"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ >=media-libs/gstreamer-${PV}:1.0[introspection]
+ >=media-libs/gst-plugins-base-${PV}:1.0[introspection]
+ >=dev-python/pygobject-3.8:3[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+ # Avoid building plugin - it must NOT be multi-python as gst-inspect will map in all libpython.so versions and crash or behave mysteriously.
+ # Python plugin support is of limited use (GIL gets in the way). If it's ever requested or needed, it should be a
+ # separate python-single-r1 media-plugins/gst-plugins-python package that only builds the plugin directory.
+ sed -e '/subdir.*plugin/d' -i meson.build || die
+ xdg_environment_reset
+}
+
+src_configure() {
+ configuring() {
+ meson_src_configure \
+ -Dpython="${EPYTHON}"
+ }
+ python_foreach_impl configuring
+}
+
+src_compile() {
+ python_foreach_impl meson_src_compile
+}
+
+src_test() {
+ python_foreach_impl meson_src_test
+}
+
+src_install() {
+ installing() {
+ meson_src_install
+ python_optimize
+ }
+ python_foreach_impl installing
+}