summaryrefslogtreecommitdiff
path: root/dev-python/guessit/guessit-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/guessit/guessit-9999.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/guessit/guessit-9999.ebuild')
-rw-r--r--dev-python/guessit/guessit-9999.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/guessit/guessit-9999.ebuild b/dev-python/guessit/guessit-9999.ebuild
new file mode 100644
index 000000000000..8c6ead3c27e3
--- /dev/null
+++ b/dev-python/guessit/guessit-9999.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1 git-r3
+
+DESCRIPTION="Python library for guessing information from video filenames"
+HOMEPAGE="https://github.com/guessit-io/guessit https://pypi.python.org/pypi/guessit"
+EGIT_REPO_URI="https://github.com/${PN}-io/${PN}.git"
+EGIT_BRANCH="develop"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS=""
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/babelfish-0.5.5[${PYTHON_USEDEP}]
+ >=dev-python/rebulk-0.9.0[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? (
+ >=dev-python/pytest-2.7.3[${PYTHON_USEDEP}]
+ dev-python/pytest-capturelog[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ )
+"
+
+python_prepare_all() {
+ # Disable benchmarks as they require unavailable pytest-benchmark.
+ rm guessit/test/test_benchmark.py || die
+ sed -i -e "s|'pytest-benchmark',||g" setup.py || die
+
+ # Disable unconditional dependency on dev-python/pytest-runner.
+ sed -i -e "s|'pytest-runner'||g" setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ esetup.py test
+}