summaryrefslogtreecommitdiff
path: root/dev-python/guppy/guppy-0.1.10-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /dev-python/guppy/guppy-0.1.10-r1.ebuild
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'dev-python/guppy/guppy-0.1.10-r1.ebuild')
-rw-r--r--dev-python/guppy/guppy-0.1.10-r1.ebuild48
1 files changed, 0 insertions, 48 deletions
diff --git a/dev-python/guppy/guppy-0.1.10-r1.ebuild b/dev-python/guppy/guppy-0.1.10-r1.ebuild
deleted file mode 100644
index f4cbb03c3eeb..000000000000
--- a/dev-python/guppy/guppy-0.1.10-r1.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-DESCRIPTION="Guppy-PE -- A Python Programming Environment"
-HOMEPAGE="http://guppy-pe.sourceforge.net/ https://pypi.org/project/guppy/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-IUSE="doc"
-
-DEPEND=""
-RDEPEND=""
-
-PATCHES=( "${FILESDIR}"/${PN}-0.1.9-rm_BrokenTests.patch )
-
-python_prepare_all() {
- sed -e 's:_PyLong_AsScaledDouble:_PyLong_Frexp:' -i src/sets/bitset.c || die
- distutils-r1_python_prepare_all
-}
-
-python_compile() {
- local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
- distutils-r1_python_compile
-}
-
-python_test() {
- "${PYTHON}" setup.py build install --home="${T}/test-${EPYTHON}" \
- || die "Installation of tests failed"
- pushd "${T}/test-${EPYTHON}/lib/python" > /dev/null
- "${PYTHON}" guppy/heapy/test/test_all.py || die "tests failed"
- popd > /dev/null
-}
-
-python_install_all() {
- # leave the html docs for install as the setup.py dictates but rm if set by IUSE doc
- if use doc; then
- local HTML_DOCS=( guppy/doc/. )
- find "${D}$(python_get_sitedir)" -name doc | xargs rm -rf
- fi
- distutils-r1_python_install_all
-}