summaryrefslogtreecommitdiff
path: root/dev-python/guppy/guppy-0.1.10-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/guppy/guppy-0.1.10-r1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/guppy/guppy-0.1.10-r1.ebuild')
-rw-r--r--dev-python/guppy/guppy-0.1.10-r1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/guppy/guppy-0.1.10-r1.ebuild b/dev-python/guppy/guppy-0.1.10-r1.ebuild
new file mode 100644
index 000000000000..f4cbb03c3eeb
--- /dev/null
+++ b/dev-python/guppy/guppy-0.1.10-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Guppy-PE -- A Python Programming Environment"
+HOMEPAGE="http://guppy-pe.sourceforge.net/ https://pypi.org/project/guppy/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+DEPEND=""
+RDEPEND=""
+
+PATCHES=( "${FILESDIR}"/${PN}-0.1.9-rm_BrokenTests.patch )
+
+python_prepare_all() {
+ sed -e 's:_PyLong_AsScaledDouble:_PyLong_Frexp:' -i src/sets/bitset.c || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile() {
+ local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
+ distutils-r1_python_compile
+}
+
+python_test() {
+ "${PYTHON}" setup.py build install --home="${T}/test-${EPYTHON}" \
+ || die "Installation of tests failed"
+ pushd "${T}/test-${EPYTHON}/lib/python" > /dev/null
+ "${PYTHON}" guppy/heapy/test/test_all.py || die "tests failed"
+ popd > /dev/null
+}
+
+python_install_all() {
+ # leave the html docs for install as the setup.py dictates but rm if set by IUSE doc
+ if use doc; then
+ local HTML_DOCS=( guppy/doc/. )
+ find "${D}$(python_get_sitedir)" -name doc | xargs rm -rf
+ fi
+ distutils-r1_python_install_all
+}