summaryrefslogtreecommitdiff
path: root/dev-python/gwcs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/gwcs
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/gwcs')
-rw-r--r--dev-python/gwcs/Manifest3
-rw-r--r--dev-python/gwcs/gwcs-0.7.ebuild51
-rw-r--r--dev-python/gwcs/metadata.xml20
3 files changed, 74 insertions, 0 deletions
diff --git a/dev-python/gwcs/Manifest b/dev-python/gwcs/Manifest
new file mode 100644
index 000000000000..241acf79cdde
--- /dev/null
+++ b/dev-python/gwcs/Manifest
@@ -0,0 +1,3 @@
+DIST gwcs-0.7.tar.gz 276681 BLAKE2B 23985cb7adae038c08edd42bcc5b589f4534aea070a49d8e8e0d70b06424564dad333945dc852c4fa4025d242bb5293ed4dca030784de7d3579d78f2c6f56cac SHA512 fe7b11c748f76175ea7a3d0a584ac61d783ef06db849c7dc77f220e40e8e9f44a5090f3f2de50a51d0df66e04f7aec32aac14fd406d4d41d32d70c53f04a9961
+EBUILD gwcs-0.7.ebuild 1315 BLAKE2B 0efc7844100f2880ce57a5452416bdb649a5563a2099abe3cf69628cec9e9361fd239735c7a0bb153a1d3fe421d11dc287610b9b8f6822eb57453a73699ac7bc SHA512 3e5098eaffc05a4eeae795b09c3e9a3d6f681e690710447978b5994620e4466f6d68abd4241e15adcfd1dfb178a11b1cd066c8e9854efbe9e4e4d6f10a695d28
+MISC metadata.xml 801 BLAKE2B 0d0ea1c1a90acfb7b12826a5e670429314012319c83faaf791824d71858a8daaa87add995fa0f5e175d4374b843494759784bae5f69a5093c7f1539a0873b8cb SHA512 9a20c6faf196c7076f94c28ff3dbb1c63ba144b799b6d4c35051afb39d3cf90247bfe38fcb5ec4a53f210d629f5d86c38282eeac3cb24913d1cab0fa58e2c273
diff --git a/dev-python/gwcs/gwcs-0.7.ebuild b/dev-python/gwcs/gwcs-0.7.ebuild
new file mode 100644
index 000000000000..05508faaaf57
--- /dev/null
+++ b/dev-python/gwcs/gwcs-0.7.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python for managing the World Coordinate System"
+HOMEPAGE="http://gwcs.readthedocs.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+RDEPEND="
+ dev-python/astropy[${PYTHON_USEDEP}]
+ dev-python/asdf[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/configparser[${PYTHON_USEDEP}]' python2_7 )"
+DEPEND="${RDEPEND}
+ dev-python/astropy-helpers[${PYTHON_USEDEP}]
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${PN}-${PV/_}"
+python_prepare_all() {
+ # use system astropy-helpers instead of bundled one
+ sed -i -e '/auto_use/s/True/False/' setup.cfg || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ python_setup
+ PYTHONPATH="${BUILD_DIR}"/lib \
+ esetup.py build_sphinx --no-intersphinx
+ fi
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/gwcs/metadata.xml b/dev-python/gwcs/metadata.xml
new file mode 100644
index 000000000000..033a8d077fdc
--- /dev/null
+++ b/dev-python/gwcs/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci-astronomy@gentoo.org</email>
+ <name>Gentoo Astronomy Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ GWCS takes a general approach to the astronomy World Coodinate
+ System. It supports a data model which includes the entire
+ transformation pipeline from input coordinates (detector by
+ default) to world coordinates. The goal is to provide a flexible
+ toolkit which is easily extendible by adding new transforms and
+ frames.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">gwcs</remote-id>
+ <remote-id type="github">spacetelescope/gwcs</remote-id>
+ </upstream>
+</pkgmetadata>