summaryrefslogtreecommitdiff
path: root/dev-python/h5py
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-12 21:55:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-12 21:55:15 +0000
commit7218e1b46bceac05841e90472501742d905fb3fc (patch)
tree56fae051db521b8fce8014cbc8b11484885b14b3 /dev-python/h5py
parent6d691ad5b6239929063441bbd14c489e92e7396e (diff)
gentoo resync : 12.03.2021
Diffstat (limited to 'dev-python/h5py')
-rw-r--r--dev-python/h5py/Manifest2
-rw-r--r--dev-python/h5py/h5py-3.2.1.ebuild68
2 files changed, 70 insertions, 0 deletions
diff --git a/dev-python/h5py/Manifest b/dev-python/h5py/Manifest
index dd569581e598..71948645d326 100644
--- a/dev-python/h5py/Manifest
+++ b/dev-python/h5py/Manifest
@@ -1,4 +1,6 @@
AUX h5py-2.10.0-tests.patch 1090 BLAKE2B 2c915f28055d6368a5bd43b281d61879e91ae4506e2038b17c7111bae9ebecbb8eb5ca2a2cb8c32b2f6c8cd7c0629cffd926774c3d995fbd0fb6ad09db8c4310 SHA512 7ee887648d025d994eb6e495bad7ab41f7b8c2e9bb65800d9c34c1e31fc1020455202bac87c7cbf2a037a68c7cac43704f02074ae4396053ae03694fab949314
DIST h5py-2.10.0.tar.gz 301057 BLAKE2B 2e9da02224493b79b2df75ff9aa5cb16ab668d07bb95066356749be09091c54032efb3db8b53bdf0fbbbac2bcde532f9f051627327dcf3f35fb578b701ecc165 SHA512 c49b04f7dcddf03f36d4f063d79ecbe544e0b1daee432d4a76cfa83dac3a1f2cb144f40a74fb85ea17cb5b778f57f709969ea5d1a2afc5bdd5aecbc9d732898d
+DIST h5py-3.2.1.tar.gz 368170 BLAKE2B 2c198d0cfbd988a8531284e16f563ae630afbdd0b32d41ff1b8e33741ac9c678328a07dbb925d67c538100088de9423a45e65c76f3a1daaa0f7b08229916546d SHA512 c98f935f800f340239fdd5132534a3b79995dc952250521f0bd6972a60c34c21bb56d7ca3f1c655ad9d1e47fc5792f434f88a0919ae75bc9102e659bf4f1c284
EBUILD h5py-2.10.0-r1.ebuild 1603 BLAKE2B c1ec4e72f614eb760f020ffb04fbb5988c79019eb9bc233e9f1359cdc6376e0a9ba4e1a2c51134755c0df088c126729f235cdada2d4ed1f4e9faea05d3e5d888 SHA512 a115a6a1122c2af0ffdeac399a5dd330d456c71864b7848e35664bad2a7dde1f2482e5a9e46a8da9e2196018145ceed7338dbc1b02b78749616a70f0d27d18d1
+EBUILD h5py-3.2.1.ebuild 1596 BLAKE2B 39b1af073d49d022b37f9c908c9f8ca09016631360da7f5bdb72f926cfcb456a9563b8649bb5ef68b2622f52d2b1605803f076364f16f0eda1f1d457cfd35dcc SHA512 4618aeb23fe13de94b3ac8ab96a5837084f8a4bc59dba4310e6f6f35aa4a50315d822302584a937b3b8015bc213c556a3aafad590db5c9e3fe2b6b3387309803
MISC metadata.xml 1015 BLAKE2B 4b62b6e3d38b745ff2e27bfdd14e6ca380264089c9953e09e6f8c12e223fc9ad45072b8c884ee9a7c24329a00e71a93207d3ffb21b17e8377bf195fb20b54ad1 SHA512 1880b779b8917357e6301273a304314e73686cea70325c2ee17c1bd901190bf0b07575584275039d199df6b190df9be3ab6617ee9f2babb0b609c408cba5af52
diff --git a/dev-python/h5py/h5py-3.2.1.ebuild b/dev-python/h5py/h5py-3.2.1.ebuild
new file mode 100644
index 000000000000..82dc31d6252c
--- /dev/null
+++ b/dev-python/h5py/h5py-3.2.1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1 flag-o-matic
+
+DESCRIPTION="Simple Python interface to HDF5 files"
+HOMEPAGE="https://www.h5py.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+# disable mpi until mpi4py gets python3_8
+#IUSE="examples mpi"
+IUSE="examples"
+
+#RDEPEND="sci-libs/hdf5:=[mpi=,hl(+)]
+DEPEND="sci-libs/hdf5:=[hl(+)]"
+RDEPEND="${DEPEND}
+ $(python_gen_cond_dep '
+ dev-python/cached-property[${PYTHON_USEDEP}]
+ ' python3_7)
+ dev-python/numpy[${PYTHON_USEDEP}]"
+
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pkgconfig[${PYTHON_USEDEP}]
+ test? (
+ dev-python/QtPy[testlib,${PYTHON_USEDEP}]
+ dev-python/cached-property[${PYTHON_USEDEP}]
+ )"
+# mpi? ( virtual/mpi )
+# mpi? ( dev-python/mpi4py[${PYTHON_USEDEP}] )
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/alabaster
+
+#pkg_setup() {
+# use mpi && export CC=mpicc
+#}
+
+python_prepare_all() {
+ # avoid pytest-mpi dep, we do not use mpi anyway
+ sed -i -e 's:pytest-mpi::' pytest.ini || die
+ distutils-r1_python_prepare_all
+
+ export H5PY_SETUP_REQUIRES=0
+}
+
+python_test() {
+ cd "${BUILD_DIR}/lib" || die
+ pytest -vv -m "not mpi" ||
+ die "Tests failed with ${EPYTHON}"
+ # tests generate .pytest_cache which should not be installed
+ rm -r .pytest_cache || die
+}
+
+python_install_all() {
+ use examples && dodoc -r examples
+
+ distutils-r1_python_install_all
+}