summaryrefslogtreecommitdiff
path: root/dev-python/h5py
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/h5py
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/h5py')
-rw-r--r--dev-python/h5py/Manifest5
-rw-r--r--dev-python/h5py/h5py-2.7.0.ebuild66
-rw-r--r--dev-python/h5py/h5py-2.7.1.ebuild66
-rw-r--r--dev-python/h5py/metadata.xml25
4 files changed, 162 insertions, 0 deletions
diff --git a/dev-python/h5py/Manifest b/dev-python/h5py/Manifest
new file mode 100644
index 000000000000..131e29696574
--- /dev/null
+++ b/dev-python/h5py/Manifest
@@ -0,0 +1,5 @@
+DIST h5py-2.7.0.tar.gz 256471 BLAKE2B c232eb86d00b9d1bb76903ea04bfd384bae7c9eb7b301de6aa450a46918f69132ab8d8d5a3f9b54095feee436a8aa9e9045c27ca1a120d665d6031c14218f0f5 SHA512 7c1e5d8b47c176521f5f62cfc4f782c09a0e003c5cbc07a673ccc3dfbe97df930b33801ef7311360892e3fad1d7d72561a8578aed9cb630d44e1a73543bb5da4
+DIST h5py-2.7.1.tar.gz 264225 BLAKE2B ffb0b52127f6cb9634b5ac3266a36bc0003144d302bdc300fff5f6f33e52b5a12e954cc2ef9fdfe9dfa0eddc810b30ee3f556cab2a31338500db666b87e64ddc SHA512 b702e3875c2767d2fabe66601820c517671fb5fc3321334aba081950b625435a1262554f39187cd1b41c6069e2b3826db6f0b610bfed2abe5db8a4dd8a29ecfd
+EBUILD h5py-2.7.0.ebuild 1383 BLAKE2B 97660943e83ecee56fc008a312482ea9dae7be654ded10855c3dbd1b7648ab8edebe7d01f086ad42d46773ee19a28e1c2adc3aee7500020fb81a35ecdd695113 SHA512 f7687d5f281f9892660784a1f47192212cba546ee85cf1499c2a6d75efdcb9622d71884422f03395830746026630ce5bdec74c32a1e806c05d42c88ae6fcff7b
+EBUILD h5py-2.7.1.ebuild 1385 BLAKE2B f64206a537b19fac7fee1356dc00ef1ca70bcd5e6c3871eacdf4c9f8630411ed63fe63085f875ca4add7d9536ca7310756e3fbf971e8b1713a7017feffd1034b SHA512 441204b99fb0b8bd64aae4cdd3557d4bfb391d19462bde2ec9241f2b0eb847eace1ae6ddec7b6f21039dd0ca25da96347555b61a0df2e1a87ae1da04866fb744
+MISC metadata.xml 1015 BLAKE2B 4b62b6e3d38b745ff2e27bfdd14e6ca380264089c9953e09e6f8c12e223fc9ad45072b8c884ee9a7c24329a00e71a93207d3ffb21b17e8377bf195fb20b54ad1 SHA512 1880b779b8917357e6301273a304314e73686cea70325c2ee17c1bd901190bf0b07575584275039d199df6b190df9be3ab6617ee9f2babb0b609c408cba5af52
diff --git a/dev-python/h5py/h5py-2.7.0.ebuild b/dev-python/h5py/h5py-2.7.0.ebuild
new file mode 100644
index 000000000000..4e74bc6c5354
--- /dev/null
+++ b/dev-python/h5py/h5py-2.7.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1 flag-o-matic
+
+DESCRIPTION="Simple Python interface to HDF5 files"
+HOMEPAGE="http://www.h5py.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE="doc test examples mpi"
+
+RDEPEND="
+ sci-libs/hdf5:=[mpi=,hl(+)]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+
+DEPEND="
+ ${RDEPEND}
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/pkgconfig[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/alabaster[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.3.1[${PYTHON_USEDEP}]
+ )
+ mpi? ( dev-python/mpi4py[${PYTHON_USEDEP}] )"
+
+pkg_setup() {
+ use mpi && export CC=mpicc
+}
+
+python_prepare_all() {
+ append-cflags -fno-strict-aliasing
+ distutils-r1_python_prepare_all
+}
+
+python_configure() {
+ esetup.py configure $(usex mpi --mpi '')
+}
+
+python_compile_all() {
+ if use doc; then
+ cd "${S}"/docs || die
+ sed '/html_theme/s:default:alabaster:g' -i conf.py || die
+ emake html
+ fi
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ DOCS=( README.rst ANN.rst )
+ use doc && HTML_DOCS=( docs/_build/html/. )
+ use examples && DOCS+=( examples )
+
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/h5py/h5py-2.7.1.ebuild b/dev-python/h5py/h5py-2.7.1.ebuild
new file mode 100644
index 000000000000..30bee0302c8f
--- /dev/null
+++ b/dev-python/h5py/h5py-2.7.1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1 flag-o-matic
+
+DESCRIPTION="Simple Python interface to HDF5 files"
+HOMEPAGE="http://www.h5py.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test examples mpi"
+
+RDEPEND="
+ sci-libs/hdf5:=[mpi=,hl(+)]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+
+DEPEND="
+ ${RDEPEND}
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/pkgconfig[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/alabaster[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.3.1[${PYTHON_USEDEP}]
+ )
+ mpi? ( dev-python/mpi4py[${PYTHON_USEDEP}] )"
+
+pkg_setup() {
+ use mpi && export CC=mpicc
+}
+
+python_prepare_all() {
+ append-cflags -fno-strict-aliasing
+ distutils-r1_python_prepare_all
+}
+
+python_configure() {
+ esetup.py configure $(usex mpi --mpi '')
+}
+
+python_compile_all() {
+ if use doc; then
+ cd "${S}"/docs || die
+ sed '/html_theme/s:default:alabaster:g' -i conf.py || die
+ emake html
+ fi
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ DOCS=( README.rst ANN.rst )
+ use doc && HTML_DOCS=( docs/_build/html/. )
+ use examples && DOCS+=( examples )
+
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/h5py/metadata.xml b/dev-python/h5py/metadata.xml
new file mode 100644
index 000000000000..9ca11da4f83c
--- /dev/null
+++ b/dev-python/h5py/metadata.xml
@@ -0,0 +1,25 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ HDF5 for Python (h5py) is a general-purpose simple Python interface to the
+ Hierarchical Data Format library, version 5. Existing Python and
+ Numpy concepts are used for the interface. Almost all HDF5 features
+ are available from Python, including things like compound datatypes
+ (as used with Numpy recarray types), HDF5 attributes, hyperslab and
+ point-based I/O, and more recent features in HDF 1.8 like resizable
+ datasets and recursive iteration over entire files.
+</longdescription>
+ <upstream>
+ <remote-id type="google-code">h5py</remote-id>
+ <remote-id type="pypi">h5py</remote-id>
+ </upstream>
+</pkgmetadata>