summaryrefslogtreecommitdiff
path: root/dev-python/hachoir-regex/hachoir-regex-1.0.5-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/hachoir-regex/hachoir-regex-1.0.5-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/hachoir-regex/hachoir-regex-1.0.5-r1.ebuild')
-rw-r--r--dev-python/hachoir-regex/hachoir-regex-1.0.5-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/hachoir-regex/hachoir-regex-1.0.5-r1.ebuild b/dev-python/hachoir-regex/hachoir-regex-1.0.5-r1.ebuild
new file mode 100644
index 000000000000..994d5ca78c35
--- /dev/null
+++ b/dev-python/hachoir-regex/hachoir-regex-1.0.5-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Manipulation of regular expressions (regex)"
+HOMEPAGE="https://bitbucket.org/haypo/hachoir/wiki/hachoir-regex https://pypi.python.org/pypi/hachoir-regex"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+python_configure_all() {
+ mydistutilsargs=(
+ --setuptools
+ )
+}
+
+python_test() {
+ "${PYTHON}" test_doc.py || die "Tests fail with ${EPYTHON}"
+}