summaryrefslogtreecommitdiff
path: root/dev-python/hatchling
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-14 06:17:35 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-14 06:17:35 +0000
commitc24da107a8903eb6e86d811f19448c01fa81ba15 (patch)
tree18d4e577f4494130eaebf6bad5507ccc61b6ee78 /dev-python/hatchling
parent55b20c97078ded20d0e7c6b3ef33d673c861d8b4 (diff)
gentoo auto-resync : 14:03:2023 - 06:17:35
Diffstat (limited to 'dev-python/hatchling')
-rw-r--r--dev-python/hatchling/Manifest2
-rw-r--r--dev-python/hatchling/hatchling-1.12.2.ebuild77
2 files changed, 0 insertions, 79 deletions
diff --git a/dev-python/hatchling/Manifest b/dev-python/hatchling/Manifest
index 640b6cbee9f6..f19fde8f225a 100644
--- a/dev-python/hatchling/Manifest
+++ b/dev-python/hatchling/Manifest
@@ -1,5 +1,3 @@
-DIST hatch-hatchling-v1.12.2.gh.tar.gz 381872 BLAKE2B 6290daca1f2d2cd4eb9479b2f34b782881651c0106008c8876c355e5f3aa12cdbd0168765fdc04dd7870f9b88d44cc1be8d3849b2f20393bf64bebe9dbf09dd9 SHA512 74404b3b5369f6a8350cbde9675de6d9d7a72aca721714d47d8c4052c341affed1ebb4f4caae96877c2ccf2c4bab29b8323643e2a3d7de67bfe5888f3a08cdca
DIST hatch-hatchling-v1.13.0.gh.tar.gz 383610 BLAKE2B 0a3dc20f6c1c504c94c09897e23e6ade844318488093cf849e332cf08f7be178ddb3ae61d8ff01af93438c01216b056a3566e9d8758a0151e4d7498447a9524f SHA512 fb14e1d088676dfc2b76dda207aa514232c3c5b8472d7332c0d53e0bd4dbd1d0e3bd1ac9f261f72e1a32610c565485f5e382fc7071e80066735a04eb8cade13e
-EBUILD hatchling-1.12.2.ebuild 2087 BLAKE2B 74174d5bb78177af97ebfc1980e845f7033346a7421f98272168f20f16edd268a2414dbda28ba25ca8536710e50875ba033b8717c41a793dc11a856bcfad4e90 SHA512 5a2048812fbb9774666895f2b9ffd99027a83d38492b9303bcecbef1cef2ce1858860452f6f4d330ec442370484b893026c07170c1eaad741f8c07701fd0e9d5
EBUILD hatchling-1.13.0.ebuild 2094 BLAKE2B 2e7a1d5a394a93f6d58a50b039fc9297393513803b0ae7bb551680a32321ed5940577acc02e6988865b0b026e0538f9b6efe24a9770e8c771ea5138e1de16aec SHA512 1cbe612df37be3a58213f1defd8df82469313a009cd77a9774e7ea16c615efe8fb0fd4127dc7e349daac0d9c1dd49fc3ff7629f14719f5d63dd4382c05514477
MISC metadata.xml 365 BLAKE2B 5a40a6cf6df042e6e8387830babd0171c9d8bc5d490fe2175b83d1588d827e826b49044ef29de48553515996b742fc475bb9699dcfa8ec05229162b22e0ed317 SHA512 f11bb25bc12c2bb0b0a0a4691115b9a2af525d9e44b33e0d6db98c7fcef0b49b5989fb7574ee8b27bc88f1dd2543bfdd492a6614de172e2c4edabbee8bf6161e
diff --git a/dev-python/hatchling/hatchling-1.12.2.ebuild b/dev-python/hatchling/hatchling-1.12.2.ebuild
deleted file mode 100644
index 4a2101315a07..000000000000
--- a/dev-python/hatchling/hatchling-1.12.2.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=standalone
-PYTHON_TESTED=( pypy3 python3_{9..11} )
-PYTHON_COMPAT=( "${PYTHON_TESTED[@]}" )
-
-inherit distutils-r1
-
-TAG=${P/-/-v}
-MY_P=hatch-${TAG}
-DESCRIPTION="Modern, extensible Python build backend"
-HOMEPAGE="
- https://pypi.org/project/hatchling/
- https://github.com/pypa/hatch/
-"
-SRC_URI="
- https://github.com/pypa/hatch/archive/${TAG}.tar.gz
- -> ${MY_P}.gh.tar.gz
-"
-S=${WORKDIR}/${MY_P}/backend
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-
-# deps are listed in backend/src/hatchling/ouroboros.py
-RDEPEND="
- >=dev-python/editables-0.3[${PYTHON_USEDEP}]
- >=dev-python/packaging-21.3[${PYTHON_USEDEP}]
- >=dev-python/pathspec-0.10.1[${PYTHON_USEDEP}]
- >=dev-python/pluggy-1.0.0[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- >=dev-python/tomli-1.2.2[${PYTHON_USEDEP}]
- ' 3.8 3.9 3.10)
-"
-BDEPEND="
- ${RDEPEND}
- test? (
- $(python_gen_cond_dep '
- dev-python/atomicwrites[${PYTHON_USEDEP}]
- dev-python/click[${PYTHON_USEDEP}]
- dev-python/httpx[${PYTHON_USEDEP}]
- dev-python/platformdirs[${PYTHON_USEDEP}]
- dev-python/rich[${PYTHON_USEDEP}]
- dev-python/tomli-w[${PYTHON_USEDEP}]
- dev-python/virtualenv[${PYTHON_USEDEP}]
- ' "${PYTHON_TESTED[@]}")
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- if ! has "${EPYTHON}" "${PYTHON_TESTED[@]/_/.}"; then
- einfo "Skipping tests on ${EPYTHON}"
- return
- fi
-
- local -x EPYTEST_DESELECT=(
- # these run pip to install stuff
- tests/backend/dep/test_core.py::test_dependency_found
- tests/backend/dep/test_core.py::test_extra_met
- tests/backend/dep/test_core.py::test_extra_no_dependencies
- tests/backend/dep/test_core.py::test_extra_unmet
- tests/backend/dep/test_core.py::test_unknown_extra
- tests/backend/dep/test_core.py::test_version_unmet
- )
-
- # top-level "tests" directory contains tests both for hatch
- # and hatchling
- cd "${WORKDIR}/${MY_P}" || die
- local -x PYTHONPATH="src:${PYTHONPATH}"
- epytest tests/backend
-}