summaryrefslogtreecommitdiff
path: root/dev-python/hcloud-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-07-19 22:05:27 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-07-19 22:05:27 +0100
commit121ed4eec41fbf03e1998d09eede1bf449da63b9 (patch)
treece9341d77d1507f67d4a3a1472da9011b5baa0a8 /dev-python/hcloud-python
parentdd762ff83c330186ee2ede002e08b2f780cddd51 (diff)
gentoo resync : 19.07.2019
Diffstat (limited to 'dev-python/hcloud-python')
-rw-r--r--dev-python/hcloud-python/Manifest2
-rw-r--r--dev-python/hcloud-python/hcloud-python-1.3.0.ebuild37
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/hcloud-python/Manifest b/dev-python/hcloud-python/Manifest
index c4e038af620a..774252ddeabb 100644
--- a/dev-python/hcloud-python/Manifest
+++ b/dev-python/hcloud-python/Manifest
@@ -1,3 +1,5 @@
DIST hcloud-python-1.2.1.tar.gz 63592 BLAKE2B 9a6d2dae97ff405ebd9b92bc833c9d953c13840e68be4eb43fed375a60e55cf4bf9b4b742b26fb03401f631b7f7127815961861cb673adf4839c829141c8ed00 SHA512 cb70d190350457fc3c6e474bc6c943070102762595dac2f386041956f64255f390a928a2f2411be861645cd65b015ab9e0c931b36aeed0076b06d9f67ac72d1c
+DIST hcloud-python-1.3.0.tar.gz 71208 BLAKE2B 1a074f64aaff87991ef5c565bb8976184a1f5ca54c0d2fe19ac3dc4f8425d3a2d92ef13cbcec7ecbfb8958572ab5561953098cf0ed9f141ba43c3eb0a90ffc10 SHA512 6dfff2301ad91db3c79fc8f68a05b5a886f86824a34f044d14a6a35771d23fdba9764055c797d11f404cccf3ae6338af940e4814113859d7809733629d7c2659
EBUILD hcloud-python-1.2.1.ebuild 1056 BLAKE2B 94a8aeb9cf22f4263222ab52e186c8604912c1a0931d96e3a47698019245d318753fc5d5686255fa0ef6f9460fe55a94b2125804407da5f94ca92f4577189a37 SHA512 ac4b6bb887fb0b1ff076c4ba02dd1a33256f238eab49f250db3b8a1908c68784dfe5c51b5dfa2b7db7f5dc57496e472c8be8d50d152392984c2f2c6674722e18
+EBUILD hcloud-python-1.3.0.ebuild 876 BLAKE2B 62435cbddd008731368ceee8965656420e7b9f6a6b35b974e27b98ae9bf23ec9a50d3b467d472307f266a2368f9345a4695659228fc7c1eca48167f694ffb613 SHA512 b3d65bdd8814d8c8d6b0c5b62e35fb2563938db46d8213619c265eb9e737b4e9ba661264f5fb2eb7a1838bb8c6561a9bc62e0a1b1548f4e62bccb3b1527d44a1
MISC metadata.xml 246 BLAKE2B 5439993f129fd56fc43062bce991abdd20627118aa0e723a343c721cbc910de4f8b7b34b6f1587acfe0a60d488d4b1d093c69eb7d78f6accade89bced7d69b93 SHA512 482630597bd2d56c1eaed7099225b4475aec8768e20bad70ea9d6b96791fa38359ba572ab9ad0fc7ea72f1ab736ed1e92fc3c156c3427b008c7220285edce11c
diff --git a/dev-python/hcloud-python/hcloud-python-1.3.0.ebuild b/dev-python/hcloud-python/hcloud-python-1.3.0.ebuild
new file mode 100644
index 000000000000..d9ca18e4f9c9
--- /dev/null
+++ b/dev-python/hcloud-python/hcloud-python-1.3.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Official Hetzner Cloud python library"
+HOMEPAGE="https://github.com/hetznercloud/hcloud-python"
+SRC_URI="https://github.com/hetznercloud/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc examples"
+
+COMMON_DEPEND="dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]"
+
+DEPEND="${COMMON_DEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+RDEPEND="${COMMON_DEPEND}
+ dev-python/future[${PYTHON_USEDEP}]"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_install_all() {
+ use examples && dodoc -r examples
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+
+ distutils-r1_python_install_all
+}