summaryrefslogtreecommitdiff
path: root/dev-python/hcloud-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-26 01:13:45 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-26 01:13:45 +0000
commit7bd77a6744e2cd6d203240181996a998985e0288 (patch)
tree75dc88e47dcab0692b84f1b2684ffa9fde351aff /dev-python/hcloud-python
parentc33b50e5d2446c439465ff4575253db72ef2b8f6 (diff)
gentoo auto-resync : 26:11:2022 - 01:13:45
Diffstat (limited to 'dev-python/hcloud-python')
-rw-r--r--dev-python/hcloud-python/Manifest4
-rw-r--r--dev-python/hcloud-python/hcloud-python-1.18.0.ebuild40
-rw-r--r--dev-python/hcloud-python/hcloud-python-1.18.1.ebuild2
3 files changed, 2 insertions, 44 deletions
diff --git a/dev-python/hcloud-python/Manifest b/dev-python/hcloud-python/Manifest
index b5b5e68e9e1b..5cbe1f0b8c79 100644
--- a/dev-python/hcloud-python/Manifest
+++ b/dev-python/hcloud-python/Manifest
@@ -1,5 +1,3 @@
-DIST hcloud-python-1.18.0.gh.tar.gz 99047 BLAKE2B c32b048653bea1910ed8a82d0e08603a154dc89208c0cf8b9e046078277460fedffe6568c7c3cf56a8408bb0423d38464c4fd57dded4523886560823e3ee65da SHA512 8339b5da4df7f5e1f38fbd7a3f205387bfd7a65a7c4eaa757c4c35056b70c06230fe9b8a597b54bac082af975184bd5ef33a6e2747b60a67cc34d6771435452c
DIST hcloud-python-1.18.1.gh.tar.gz 99042 BLAKE2B 159b2fb29021ca7993f75c4731867ed1bc57e2c9a3cf68a45acf43bb45e9a0862717907d1dfce45c960064ad82b71422e76b290db3516ea3744be95797db5e1e SHA512 6d172c214d25ae846b5561e4caa6b70d4f4e765e064ae971d5b216ceb743ab269f735e2c9adb68f1cf99ef429621b6998a34c8c7befa6d527dc3b774c0639bae
-EBUILD hcloud-python-1.18.0.ebuild 942 BLAKE2B 273b6e0a3dbb1d2d6d58d76a47e15c91f4bbd308f5229b50d108507541fb4dd2e15529356600e176e3050a9342820b785bd934c749514e0a9ad18f09e5bdaee1 SHA512 3b9854433067aa9e4835def83e102a2c49b58ccfc8420ba5aa23392e8964a3fc6195d702f5d452d0d0bd7faaace877a6cbd58ee26465132700743040f32edb5e
-EBUILD hcloud-python-1.18.1.ebuild 955 BLAKE2B 323d181fd16af30b73a5d63217c87a23fd5d04bb6cd537d639a5300a597ede9ea7707a6c23ed2dedabf39913fdf6bceaf4a178fb881764bec91c97c48415e546 SHA512 f827c2ce86dfbeda231fe73cc784e16f5aea37678713a79e0dfdf5b4a39a98153402273c88494ea881af919b782da7c5b7f2aa0b798027ee18e17bd229898ea8
+EBUILD hcloud-python-1.18.1.ebuild 954 BLAKE2B 5a189e7cb370de93dc1fb8b0d2d0d297d646b0da70cfef6ce17f66b63475f6ab1ba157945b0eb6e3877aec97c8db61c946c34950695f30da903c6aac20923fee SHA512 fd6013d779f6ea4647fdd3d975b4759e1812d27907cb4114a452e446a7417c8a9d5061da6a1af9c3f365e7c8cd3aa0ec03dc6dc45a249abe217453ab78a8e497
MISC metadata.xml 483 BLAKE2B c945a22b776b5bf73deabf93718a1dea3a9b98f7257467e845106f71910347a803f96ef969227d7c10a119f1e35b904bcb7501b9672bf3ce5a2bef112d903e56 SHA512 4a6540a06d57eb3bc8c455d982531427157fbf1a85abf4b909032b0880c9e2847b295b3c9b02378be35e88f74876357503dd04bbe544ff9a9612df2b1c321b1c
diff --git a/dev-python/hcloud-python/hcloud-python-1.18.0.ebuild b/dev-python/hcloud-python/hcloud-python-1.18.0.ebuild
deleted file mode 100644
index f0eb128c1b5d..000000000000
--- a/dev-python/hcloud-python/hcloud-python-1.18.0.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..11} )
-inherit distutils-r1
-
-DESCRIPTION="Official Hetzner Cloud python library"
-HOMEPAGE="https://github.com/hetznercloud/hcloud-python"
-SRC_URI="
- https://github.com/hetznercloud/${PN}/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64"
-IUSE="doc examples"
-
-RDEPEND="
- >=dev-python/future-0.17.1[${PYTHON_USEDEP}]
- >=dev-python/python-dateutil-2.7.5[${PYTHON_USEDEP}]
- >=dev-python/requests-2.20[${PYTHON_USEDEP}]
-"
-
-distutils_enable_sphinx docs \
- dev-python/sphinx_rtd_theme
-distutils_enable_tests pytest
-
-python_install_all() {
- use examples && dodoc -r examples
- distutils-r1_python_install_all
-}
-
-python_test() {
- # Integration tests need docker:
- # https://github.com/hetznercloud/hcloud-python/blob/master/.travis.yml#L16
- epytest --ignore tests/integration
-}
diff --git a/dev-python/hcloud-python/hcloud-python-1.18.1.ebuild b/dev-python/hcloud-python/hcloud-python-1.18.1.ebuild
index aaae59edb2ea..333c6899ef33 100644
--- a/dev-python/hcloud-python/hcloud-python-1.18.1.ebuild
+++ b/dev-python/hcloud-python/hcloud-python-1.18.1.ebuild
@@ -16,7 +16,7 @@ SRC_URI="
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~amd64"
+KEYWORDS="amd64"
IUSE="examples"
RDEPEND="