summaryrefslogtreecommitdiff
path: root/dev-python/hcloud
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-10-11 04:04:15 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-10-11 04:04:15 +0100
commit61af1efe96cf1037982d2fc90af0749b5ec5a0c6 (patch)
treefd4966f3b19ef9b18ed5024d7e2f48ef73eb2fee /dev-python/hcloud
parent3aae425b3c39d02e2dc917db0fae8c225c158ca1 (diff)
gentoo auto-resync : 11:10:2024 - 04:04:14
Diffstat (limited to 'dev-python/hcloud')
-rw-r--r--dev-python/hcloud/Manifest2
-rw-r--r--dev-python/hcloud/hcloud-2.3.0.ebuild49
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/hcloud/Manifest b/dev-python/hcloud/Manifest
index c68e60637621..149e49a37d1e 100644
--- a/dev-python/hcloud/Manifest
+++ b/dev-python/hcloud/Manifest
@@ -1,3 +1,5 @@
DIST hcloud-python-2.2.1.gh.tar.gz 119705 BLAKE2B 585602989a834696354257cd26ad135b78d9cb4fbb9362948c8349eabb5a8a78158ae5d750d0ecabfc2dadbcb7f23a49f3ac41a67a7c91a55f4a9495435be5c5 SHA512 32ac9da7e88817ee16bfa31eef51404c7e973511f00950c575a857722418a29641d852dffec9554185a39999dd3951c7c7fddc3f4df2d3f9b5b614426c9d7e78
+DIST hcloud-python-2.3.0.gh.tar.gz 119846 BLAKE2B eab64db78ee9e5f33539142a869663d7a12cc08f25581a82e1d87d620452d1ce4877ff65654724f30ac602a7513e371f1f59455dcff5cdc2b94ba6751136d7b3 SHA512 8591b5406d51c8f71fdcb16bb423cc2317310484d3ef6a784d63fdb2dca9ec10d33a9fd6347f3c37e7a7c4772869a15013f8c6a83b5a2b867da0c41184c88d45
EBUILD hcloud-2.2.1.ebuild 1131 BLAKE2B d48357b1df12bfc680b99f284e36cbff05ea7eda1da03ece87716892216d713586faf4c6666805adcd5f9064f939ec8eb9f62823e3dcf1208ccd935e535205b0 SHA512 54a16490b36d75bc840f7e567c7479af0a6237224626cd2d168053469e3242066690b5d6a4197440d09646a7b3602a75f2e1addce9c202a85b9e3b5f0a8dd439
+EBUILD hcloud-2.3.0.ebuild 1132 BLAKE2B 9d958a4f4753e27be5b55a91cfbe4c0e54b058ac1add4b72b9b33cd1c73b8cd679b7b798508a6e029a6cf1519353b78108b9fcc0f450c2e15d2540e8a80e9284 SHA512 d83a35004bcdcaed9c1a96c6bad6a692e4ac52fd3b3b5392762fab068a482039c21361a818fa4eb0e97090f5497a70603476292e3dd4fdb1a5749961bedf1b39
MISC metadata.xml 483 BLAKE2B c945a22b776b5bf73deabf93718a1dea3a9b98f7257467e845106f71910347a803f96ef969227d7c10a119f1e35b904bcb7501b9672bf3ce5a2bef112d903e56 SHA512 4a6540a06d57eb3bc8c455d982531427157fbf1a85abf4b909032b0880c9e2847b295b3c9b02378be35e88f74876357503dd04bbe544ff9a9612df2b1c321b1c
diff --git a/dev-python/hcloud/hcloud-2.3.0.ebuild b/dev-python/hcloud/hcloud-2.3.0.ebuild
new file mode 100644
index 000000000000..64eceb0a363c
--- /dev/null
+++ b/dev-python/hcloud/hcloud-2.3.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+MY_P=hcloud-python-${PV}
+DESCRIPTION="Official Hetzner Cloud python library"
+HOMEPAGE="
+ https://github.com/hetznercloud/hcloud-python/
+ https://pypi.org/project/hcloud/
+"
+# sdist is missing doc assets as of 1.19.0
+# https://github.com/hetznercloud/hcloud-python/pull/183
+SRC_URI="
+ https://github.com/hetznercloud/hcloud-python/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="examples"
+
+RDEPEND="
+ >=dev-python/python-dateutil-2.7.5[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.20[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs \
+ dev-python/myst-parser \
+ dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # Integration tests need docker:
+ # https://github.com/hetznercloud/hcloud-python/blob/master/.travis.yml#L16
+ tests/integration
+)
+
+python_install_all() {
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}