summaryrefslogtreecommitdiff
path: root/dev-python/healpy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/healpy
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/healpy')
-rw-r--r--dev-python/healpy/Manifest6
-rw-r--r--dev-python/healpy/healpy-1.10.3.ebuild38
-rw-r--r--dev-python/healpy/healpy-1.11.0.ebuild43
-rw-r--r--dev-python/healpy/metadata.xml17
4 files changed, 104 insertions, 0 deletions
diff --git a/dev-python/healpy/Manifest b/dev-python/healpy/Manifest
new file mode 100644
index 000000000000..f82972e17791
--- /dev/null
+++ b/dev-python/healpy/Manifest
@@ -0,0 +1,6 @@
+DIST healpy-1.10.3.tar.gz 4018897 SHA256 43bdccb0081b3b5a72a9c1f523c367bc2cba91f989a60047d8043685a3beb81b SHA512 c5862fceb597ffbc5c53204479fa9dba19287e3c08744e25edef3eaecfa726e61e8558d50d73e2bf4d19b7d0adc0ac928a38c4808fc92fe855f5eae101e18baa WHIRLPOOL f3d883f8de8c35573d865ab444818b5b3e3cbeac4176961cd8db39931a09b0d52a7f2fe7c6f3862823d32cd2ec2a569a17f6dc9e1da8510f35940f9ddbb7b66a
+DIST healpy-1.11.0.tar.gz 4033412 SHA256 8c3c7982ae188549315a11f4d1aa6528cd1ccf078017ca20120ff2cf1b47babe SHA512 35926c769f2fd4ebc3cd61357d742e9e1747325187e465bd3be62b4281506bd02cf3d8b982583819219e994dfa3936d6bc61914218325bb6b4ddfcffc50c802f WHIRLPOOL 59cb954d30b6df3db07ae4aa94e576c94f19eaf8e99e7416bf162c362089490999b6e85a62f94c09d62d37292b82d2bfaf7e89de1b93882e0b35cd6ab8887a59
+EBUILD healpy-1.10.3.ebuild 953 SHA256 5ac31854dbf4f28ab6b907eacd656ed02d5dd5867526e2d1b048864ed9f6e517 SHA512 3bfa350217f621fd59ed84a95cde8f6dc452304228459f53d201fb2b75db2f78912d622ebe8e8376220e8f09a323c9500405165ccf485a9df46716b36606fe13 WHIRLPOOL c433ddd699e5e307b60c3a5c34386a592b6e915ecbbb6fd6cd0dbc3968660d1ad3cff0bc0bbfe181bc38d4ad3d5615e3c42399cca4a483fa53fc205036ebdccb
+EBUILD healpy-1.11.0.ebuild 1048 SHA256 2511ce5d456ad267ec6f0ed9b2d59761632af50377b0d2cbe52b86cfba2cce66 SHA512 92ab0e948a8717f4e6be8f1164c46a974707a5e19311908f3519336adf37e8006f23d210479554ee4002f6762dc202f2cb52ca8367aadd620e001d30226a0616 WHIRLPOOL 62ce1e94f9531c2c14bbba52ce2a7a330600b2971208f8702643288790d69f2a06ec58a36b1289bbccbba79de38286771f7f2aaf1cd03b996fc81b56825dc269
+MISC ChangeLog 471 SHA256 edccd66667eccd41ab6a161f101719b69db7df548c2d87d1851aa8c9d3547520 SHA512 f938d33c53011414e3defa75144916eb5cbec1bd15313e20256895d680209b141b8bb82bc87f1018583931f1aa02c4bd2e4ee8d5097cea991b127accba5a4b2a WHIRLPOOL 7dd745d0f75c4cb14596e140426a01fdfcd2966a4fabd002ab238b3c8279dccbed3eae6fde28a754f882c5c3ec26ce7dcb925b99d49cb7ef561ddf70bd4fff1b
+MISC metadata.xml 609 SHA256 c705ce298601801e95338a2a24cf56cdf3a9a6435961d3e3fc7893ea245d68ad SHA512 e8d86f81b4a62f3f15bb2210cfbc9eb51568525349c34e10bc32de76654f18c7937ee1c5390915c8a225be35baefb8b45d8cb982a41e314da77b91c30ae8749f WHIRLPOOL f4d99bcab4e795a035511e4c2d5408111f3b94a2dda09225e7cfc46a514a4ede2f2ccef085b3b580af9c688a24591b39a6bebf9ab3f4f5fc3c6526e862d332b8
diff --git a/dev-python/healpy/healpy-1.10.3.ebuild b/dev-python/healpy/healpy-1.10.3.ebuild
new file mode 100644
index 000000000000..f84e392eec9a
--- /dev/null
+++ b/dev-python/healpy/healpy-1.10.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python wrapper for healpix"
+HOMEPAGE="https://github.com/healpy"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ dev-python/astropy[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ sci-astronomy/healpix:=[cxx]
+ sci-libs/cfitsio:="
+DEPEND="${RDEPEND}
+ dev-python/astropy-helpers[${PYTHON_USEDEP}]
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ virtual/pkgconfig
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+DOCS=( README.rst CHANGELOG.rst CITATION )
+
+python_test() {
+ echo "backend: Agg" > matplotlibrc || die
+ MPLCONFIGDIR=. esetup.py test || die
+ rm matplotlibrc || die
+}
diff --git a/dev-python/healpy/healpy-1.11.0.ebuild b/dev-python/healpy/healpy-1.11.0.ebuild
new file mode 100644
index 000000000000..c517d95ea5cf
--- /dev/null
+++ b/dev-python/healpy/healpy-1.11.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python wrapper for healpix"
+HOMEPAGE="https://github.com/healpy"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ dev-python/astropy[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ sci-astronomy/healpix:=[cxx]
+ sci-libs/cfitsio:="
+DEPEND="${RDEPEND}
+ dev-python/astropy-helpers[${PYTHON_USEDEP}]
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ virtual/pkgconfig
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cython[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( README.rst CHANGELOG.rst CITATION )
+
+python_test() {
+ echo "backend: Agg" > matplotlibrc || die
+ MPLCONFIGDIR=. esetup.py test || die
+ rm matplotlibrc || die
+}
diff --git a/dev-python/healpy/metadata.xml b/dev-python/healpy/metadata.xml
new file mode 100644
index 000000000000..39b8f2351616
--- /dev/null
+++ b/dev-python/healpy/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci-astronomy@gentoo.org</email>
+ <name>Gentoo Astronomy Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ Healpy provides a python package to manipulate healpix maps. It is
+ based on the standard numeric and visualisation tools for Python,
+ Numpy and matplotlib.
+</longdescription>
+ <upstream>
+ <remote-id type="pypi">healpy</remote-id>
+ <remote-id type="github">healpy/healpy</remote-id>
+ </upstream>
+</pkgmetadata>