summaryrefslogtreecommitdiff
path: root/dev-python/helpdev/helpdev-0.7.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-04 21:16:38 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-04 21:16:38 +0000
commitf932718a139f93e19a6883c061f81b365a408592 (patch)
tree216b44e4ea101b2d02ea32782355ed127f7b1df4 /dev-python/helpdev/helpdev-0.7.1-r1.ebuild
parentf5f1e7d30401ef31b8776c96a80cf5caae0a4e81 (diff)
gentoo auto-resync : 04:11:2022 - 21:16:37
Diffstat (limited to 'dev-python/helpdev/helpdev-0.7.1-r1.ebuild')
-rw-r--r--dev-python/helpdev/helpdev-0.7.1-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/helpdev/helpdev-0.7.1-r1.ebuild b/dev-python/helpdev/helpdev-0.7.1-r1.ebuild
new file mode 100644
index 000000000000..06bea21ab338
--- /dev/null
+++ b/dev-python/helpdev/helpdev-0.7.1-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Helping users and developers to get information about the environment"
+HOMEPAGE="https://gitlab.com/dpizetta/helpdev"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/importlib_metadata[${PYTHON_USEDEP}]
+ ' 3.8 )
+ dev-python/psutil[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pip[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs \
+ dev-python/sphinx_rtd_theme
+distutils_enable_tests pytest