summaryrefslogtreecommitdiff
path: root/dev-python/hiro
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/hiro
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/hiro')
-rw-r--r--dev-python/hiro/Manifest6
-rw-r--r--dev-python/hiro/hiro-0.2.ebuild22
-rw-r--r--dev-python/hiro/hiro-0.3.ebuild22
-rw-r--r--dev-python/hiro/metadata.xml12
4 files changed, 62 insertions, 0 deletions
diff --git a/dev-python/hiro/Manifest b/dev-python/hiro/Manifest
new file mode 100644
index 000000000000..6fc0cfce0ee9
--- /dev/null
+++ b/dev-python/hiro/Manifest
@@ -0,0 +1,6 @@
+DIST hiro-0.2.tar.gz 9384 SHA256 5b71a8d446c4c4efbebab4e06c9973a173c425e0eda218a86fa47244b61a9187 SHA512 69a66223e678c87363ac4beab8a58bec7976b93fe1b354ac1030842e31463adda84f444732ac48868f6b4f11f4a132a1142889466474bff2a77964449c710b65 WHIRLPOOL 7bccec85bf160ead6d9dafa9a0ee6f2f390fdd2d60d2454762dd3521d3eaae7af94f503f169ae8c926ab0dae15c79fa080bf68f453eb4de11b849fbd5a620ed4
+DIST hiro-0.3.tar.gz 9355 SHA256 33c0a32d709fc980d54b096f1b1055a18e8dffb8e307f8ac7543fae10ededbfd SHA512 c5ace67410ac0e946aa7f93b61448760ab9bba5610621a585f17d1ad99444161a2495a73e20b67d50f1b8b0a4c1b54a9f25732319431905891b7c5fc58c6000d WHIRLPOOL 6d9b68ea51dedc60cd9a5cbbc7f9e0ef8995b23e134e993bb86b373f29673ebfa164615a0b2990c73cdb4fd5633e70df92c276646a4db2ac12b7f624a24efbbd
+EBUILD hiro-0.2.ebuild 528 SHA256 600460d84a7d953b9e5b4af0a07420cb169862b70a385bf698779389077c7451 SHA512 a664b3c4b7575c25a665288836a013fa757d516679ec947bf9879393471653f0794ddcba07ac80f13aa7d452bdbffab2b93e2850916c98e8ff19d8dc12f65014 WHIRLPOOL a63d674059e75ff8ad105f95d24a9b108ba3a97891f6ee4bfad0559c47abec7877a6047b7e60cbd666ac78bbaf06d193d995417e620c2992550b3e0084fe1e80
+EBUILD hiro-0.3.ebuild 530 SHA256 b19925d540f3e0cd61ae5a1ce25b14e3042dc0448282aba80ea07e9d370afd19 SHA512 28c3af48fc074438b7193cc42fafe0bfe040a4d2191eaa0668041a82de4b5642506cc288d7959b54c487a8bd497ab2be35146f65d89e3ff89ca972a95c7a730f WHIRLPOOL a6d922daf20e5f8cb795e865dca0172b3e0ca739cbdff1561b02b0c6240ea1446e53f4eb0709ca896b94202121ba6f291ce63ce6da32964be8f761dfe35f2555
+MISC ChangeLog 296 SHA256 aaa66ec843ce2896b10382ea9b5736e76e26cac6bca9e7cf1bf7491fc03f3db9 SHA512 03b50efb3f8a8e225846bc6a889e7d7e64bd2a2a8640745fadba760fc1782cfda8f38f3512ed33325b2687c8774c8db1f3523a2efd192ece6c29fb681bda63ac WHIRLPOOL ea16d39f71bcb27d0da23acc8c0cae0d7b43c6e81268640342deb29aff7c8b66cbd200e7a46d5fd99ceaac0e587f67d53c42d12070fe799aeaa1e61bbe4c2bfe
+MISC metadata.xml 361 SHA256 ef8f631179bf6196b6fd8a10098bc66a50b1339084af2a9ed7330e9c10241c75 SHA512 dd0603e5ffcb021686962cba814ad6631e0affa111ff455c1465d0c245c14e3a8d92947257ee90e5737b58f0c8d452ab6e48e5fcd0bbad9e62ea170207e70f45 WHIRLPOOL e8e9d14b56e5501712af7caad3b6d83b2a62d2e8a84ea44076a197483b9ef5b4e5febf87a67b64d8f158751c776fec3012ae95d95f08dabf9f3f849157c203cc
diff --git a/dev-python/hiro/hiro-0.2.ebuild b/dev-python/hiro/hiro-0.2.ebuild
new file mode 100644
index 000000000000..ec92685fd8a1
--- /dev/null
+++ b/dev-python/hiro/hiro-0.2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+inherit distutils-r1
+
+DESCRIPTION="Time manipulation utilities for python"
+HOMEPAGE="https://github.com/alisaifee/hiro"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+
+RDEPEND="dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
diff --git a/dev-python/hiro/hiro-0.3.ebuild b/dev-python/hiro/hiro-0.3.ebuild
new file mode 100644
index 000000000000..17cde81a8dd8
--- /dev/null
+++ b/dev-python/hiro/hiro-0.3.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+inherit distutils-r1
+
+DESCRIPTION="Time manipulation utilities for python"
+HOMEPAGE="https://github.com/alisaifee/hiro"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
diff --git a/dev-python/hiro/metadata.xml b/dev-python/hiro/metadata.xml
new file mode 100644
index 000000000000..eca22bdc769c
--- /dev/null
+++ b/dev-python/hiro/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">alisaifee/hiro</remote-id>
+ <remote-id type="pypi">hiro</remote-id>
+ </upstream>
+</pkgmetadata>