summaryrefslogtreecommitdiff
path: root/dev-python/hpack/hpack-3.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-17 00:25:50 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-17 00:25:50 +0000
commit48dbe17904ac8ee6f006488d8f21734b0d253db4 (patch)
tree90c7f087cbefd4ac6b893072d309e75dbf019f76 /dev-python/hpack/hpack-3.0.0.ebuild
parent7972abc05090180dcc09d2b16af4020ce1cd1841 (diff)
gentoo auto-resync : 17:03:2023 - 00:25:50
Diffstat (limited to 'dev-python/hpack/hpack-3.0.0.ebuild')
-rw-r--r--dev-python/hpack/hpack-3.0.0.ebuild40
1 files changed, 0 insertions, 40 deletions
diff --git a/dev-python/hpack/hpack-3.0.0.ebuild b/dev-python/hpack/hpack-3.0.0.ebuild
deleted file mode 100644
index 5486b7db607d..000000000000
--- a/dev-python/hpack/hpack-3.0.0.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{9..10} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Pure-Python HPACK header compression"
-HOMEPAGE="
- https://python-hyper.org/hpack/en/latest/
- https://pypi.org/project/hpack/"
-SRC_URI="https://github.com/python-hyper/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-
-# dev-python/pytest-relaxed causes tests to fail
-BDEPEND="
- test? (
- >=dev-python/hypothesis-3.4.2[${PYTHON_USEDEP}]
- !!dev-python/pytest-relaxed[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-PATCHES=(
- "${FILESDIR}"/hpack-3.0.0-hypothesis-healthcheck.patch
-)
-
-python_test() {
- local deselect=(
- # relies on outdated exception strings
- test/test_table.py::TestHeaderTable::test_get_by_index_out_of_range
- )
-
- epytest hpack test ${deselect[@]/#/--deselect }
-}