summaryrefslogtreecommitdiff
path: root/dev-python/html5lib/html5lib-1.0.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /dev-python/html5lib/html5lib-1.0.1-r1.ebuild
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'dev-python/html5lib/html5lib-1.0.1-r1.ebuild')
-rw-r--r--dev-python/html5lib/html5lib-1.0.1-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/html5lib/html5lib-1.0.1-r1.ebuild b/dev-python/html5lib/html5lib-1.0.1-r1.ebuild
new file mode 100644
index 000000000000..751b9bc332dc
--- /dev/null
+++ b/dev-python/html5lib/html5lib-1.0.1-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{5,6,7,8}} pypy{,3} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="HTML parser based on the HTML5 specification"
+HOMEPAGE="https://github.com/html5lib/html5lib-python/ https://html5lib.readthedocs.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="test"
+
+RDEPEND=">=dev-python/six-1.9[${PYTHON_USEDEP}]
+ dev-python/webencodings[${PYTHON_USEDEP}]"
+BDEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-expect[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )"
+
+RESTRICT+=" !test? ( test )"
+
+PATCHES=(
+ # https://github.com/html5lib/html5lib-python/pull/429
+ "${FILESDIR}/html5lib-python-1.0.1-support-pytest4.patch"
+)
+
+distutils_enable_tests pytest