summaryrefslogtreecommitdiff
path: root/dev-python/http-parser
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
commitf516638b7fe9592837389826a6152a7e1b251c54 (patch)
tree8bfecb640b7b6403d7a3d662d923eed630033da7 /dev-python/http-parser
parent1a61119f9f7b057830e2ce0563f913ec86f282ad (diff)
gentoo resync : 30.05.2020
Diffstat (limited to 'dev-python/http-parser')
-rw-r--r--dev-python/http-parser/Manifest4
-rw-r--r--dev-python/http-parser/http-parser-0.8.3.ebuild2
-rw-r--r--dev-python/http-parser/http-parser-0.9.0.ebuild41
3 files changed, 45 insertions, 2 deletions
diff --git a/dev-python/http-parser/Manifest b/dev-python/http-parser/Manifest
index 2350aaa9bbed..9d91527a282b 100644
--- a/dev-python/http-parser/Manifest
+++ b/dev-python/http-parser/Manifest
@@ -1,3 +1,5 @@
DIST http-parser-0.8.3.tar.gz 83040 BLAKE2B 8ccfd15154e34756229159576340536e447a1b76375df7c3f56b96c79957a3b28569fd4a4e77303fd1d254aa5652478f7e319e7556150de563f5b12c58482de4 SHA512 aca583d976dcf172244179cc4199336f296dbb2e2838dded23e64d55f23298fe600f9c24ba6cb6d1d5faad3022710154949fd39adecaef763f7589a58d03fbd1
-EBUILD http-parser-0.8.3.ebuild 932 BLAKE2B da73e93617f35cf701f367c2e275e43009888450aadb7890979a0e0c68712545175d038d1edd860b81c8a0286cb83bc40aa3b6e582e331e353cdfd254e214f6e SHA512 4bbffc97a8b41d6aa6d146c81221dff7d818bd9a9e8bca8b0d817b5c3ba6f7dbd15676e70b9ca04d1a42271a40007c5ae302581babeb262b8b84a0288e3f5f00
+DIST http-parser-0.9.0.gh.tar.gz 101174 BLAKE2B 92b74dffd2c35672bc383ccda59f93723c0f83ecb0fbf0470f5daacdd37f68d4d63de7d4ea53f86d2109349a793b7535cc864f014311dee6ac5e67d0ca751931 SHA512 75e51bef43d9d7698aad69f8bfe651e24784b97603cac55f33bf4c12c86792c8c71d6206f31847d052e4d8621a5ea65a7b34eca5bebdb8189f58e6d98d33139d
+EBUILD http-parser-0.8.3.ebuild 926 BLAKE2B 46bffc6a2319555ea102393d3529a6a11ee81371a120b60d4255bd518254ce62179b62a5ab791b4ac4a64cf46955864508fb208fa01acbfc1dca8e4574acb15d SHA512 4d7389cef4c82d51dae23765dd30511a695ea84d05e9b87034af6622a2f0f5ebcd27265d916be7720d2fcc23dde65eee6252d1d576c1defd85c46959cb17881e
+EBUILD http-parser-0.9.0.ebuild 888 BLAKE2B 49b7b1bd729c6c7103761e200b4dd45a69c70394661b9ce02597a6d2432e669aecdf594d26d8e3480bf3abd48a723d4577c1c2cbafd8133cc368fa65dbecd9b6 SHA512 5bc12cf93fcd27e63ed1e3d6b959701d3ca635e389681af3a75f795c6596406b8a13ac5aee5102c7b92674ecd30d1a3fadb436a7c83cbcdd00768bcf43b12af1
MISC metadata.xml 385 BLAKE2B 16371b248416d43a094b0038919816277b3dbced190f2684cbc6d0ff9cff6007cb7e5e44d867eff942f46173edf5018a4b15383454344fcfe003544aa3e64fba SHA512 5b4b7b992bf4036ee076a2714bd0b91540b071fac6194ade8327e71062d7dfc5597f68934c275d72756c5ebb25e334059df4112946a1a84ab20ca0710ee16760
diff --git a/dev-python/http-parser/http-parser-0.8.3.ebuild b/dev-python/http-parser/http-parser-0.8.3.ebuild
index 5337b6d34946..896c88cd6aa9 100644
--- a/dev-python/http-parser/http-parser-0.8.3.ebuild
+++ b/dev-python/http-parser/http-parser-0.8.3.ebuild
@@ -3,7 +3,7 @@
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_6} )
+PYTHON_COMPAT=( python3_6 )
inherit distutils-r1 flag-o-matic
diff --git a/dev-python/http-parser/http-parser-0.9.0.ebuild b/dev-python/http-parser/http-parser-0.9.0.ebuild
new file mode 100644
index 000000000000..775ab3cd8575
--- /dev/null
+++ b/dev-python/http-parser/http-parser-0.9.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="HTTP request/response parser for python in C"
+HOMEPAGE="https://github.com/benoitc/http-parser"
+SRC_URI="
+ https://github.com/benoitc/http-parser/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="examples"
+
+BDEPEND="dev-python/cython[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_compile() {
+ if [[ ${EPYTHON} != python3* ]]; then
+ local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
+ fi
+
+ distutils-r1_python_compile
+}
+
+python_install_all() {
+ local DOCS=( README.rst )
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ distutils-r1_python_install_all
+}