summaryrefslogtreecommitdiff
path: root/dev-python/httpbin/httpbin-0.7.0-r5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-01 17:44:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-01 17:44:07 +0100
commit5bd02f229a9c4ce484e49ec36dcb1f4eb5dfcdae (patch)
treebd9151b602024702907ff1e5d953f6945b67f25c /dev-python/httpbin/httpbin-0.7.0-r5.ebuild
parentb447ac3a6d1bb09ddb6a5686620670e223b37642 (diff)
gentoo auto-resync : 01:10:2023 - 17:44:07
Diffstat (limited to 'dev-python/httpbin/httpbin-0.7.0-r5.ebuild')
-rw-r--r--dev-python/httpbin/httpbin-0.7.0-r5.ebuild59
1 files changed, 0 insertions, 59 deletions
diff --git a/dev-python/httpbin/httpbin-0.7.0-r5.ebuild b/dev-python/httpbin/httpbin-0.7.0-r5.ebuild
deleted file mode 100644
index 1199c113d762..000000000000
--- a/dev-python/httpbin/httpbin-0.7.0-r5.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="HTTP Request and Response Service"
-HOMEPAGE="
- https://github.com/postmanlabs/httpbin/
- https://pypi.org/project/httpbin/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="
- dev-python/brotlicffi[${PYTHON_USEDEP}]
- dev-python/decorator[${PYTHON_USEDEP}]
- dev-python/flask[${PYTHON_USEDEP}]
- dev-python/itsdangerous[${PYTHON_USEDEP}]
- dev-python/markupsafe[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- >=dev-python/werkzeug-2.0[${PYTHON_USEDEP}]
-"
-
-PATCHES=(
- # do not import raven if it's not going to be used
- # (upstream removed it completely in git anyway)
- "${FILESDIR}"/${P}-optional-raven.patch
- # fix tests with new versions of werkzeug
- "${FILESDIR}"/${P}-test-werkzeug.patch
- # use brotlicffi instead of brotlipy
- "${FILESDIR}"/${P}-brotlicffi.patch
- # fix compat with werkzeug 2.1
- # https://github.com/postmanlabs/httpbin/pull/674
- "${FILESDIR}"/${P}-werkzeug-2.1.patch
-)
-
-distutils_enable_tests unittest
-
-src_prepare() {
- # a new version of flask or whatever converts relative redirects
- # to absolute; this package is dead anyway, so just skip
- # the relevant tests
- sed -e 's:test_redirect:_&:' \
- -e 's:test_relative:_&:' \
- -i test_httpbin.py || die
- # broken
- sed -e 's:test_digest_auth:_&:' \
- -e 's:test_base64:_&:' \
- -i test_httpbin.py || die
-
- distutils-r1_src_prepare
-}