summaryrefslogtreecommitdiff
path: root/dev-python/httpcore
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-07 09:21:27 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-07 09:21:27 +0000
commit85ba3f2cfe9ff2b952efb1f3c3c08840f8093246 (patch)
treec8adb7f2695744136c00d176bd0ebd80677049aa /dev-python/httpcore
parentf9c971dedd369d9f45a38f3fae51467e864f5324 (diff)
gentoo auto-resync : 07:11:2022 - 09:21:27
Diffstat (limited to 'dev-python/httpcore')
-rw-r--r--dev-python/httpcore/Manifest2
-rw-r--r--dev-python/httpcore/httpcore-0.15.0-r1.ebuild54
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/httpcore/Manifest b/dev-python/httpcore/Manifest
index a79de314ab23..b54d10420af3 100644
--- a/dev-python/httpcore/Manifest
+++ b/dev-python/httpcore/Manifest
@@ -1,3 +1,5 @@
+DIST httpcore-0.15.0-h11-0.14.patch 7087 BLAKE2B 08a7b1a155392637cea9b6d59d01fc60b7a73416db9d87eb2477843cf6c46d1f4e342ce1b4b3ed362f0bf9d4dea7dca40dc7496c0b04a698c8924df7cbdb7f5f SHA512 9235d06a53b1839d7df945499f666477627dca5cbccde98b52d571d1d50380eb74b8d1b6538ea1cf5150062476780e5bf96290910c7c5513199d696f765a6868
DIST httpcore-0.15.0.gh.tar.gz 76220 BLAKE2B e9a346d4f77cde82be5a3eb468123ae453753e57b54382f0b2c60b16afd3433cba173d9a796df20d76edbd8b5bcf2d61c32302bdd30c8d587036b3ac6f0425fd SHA512 3c25630d582448e3c7d46176c8862e4d92c6c4aac954bfe46b06e26297b32f996db2e002a87c7187accb5bf4ef86e82d7f9051404bee651ce5254119571d0c95
+EBUILD httpcore-0.15.0-r1.ebuild 1331 BLAKE2B 5cef5d5c3767dee8b2184ca8ffc85793a6a25e244c9a4a899c5ee8b32f3252577ff8ae7e7da3570c75af1a3af1296e8350bf4c2cc010495f0a2ccf3f36a17174 SHA512 466904d140fa94c3f6d790f98bc5206221270acbbfd575ef056be359dfc461c616c495c7658d86517515c653b3cd6a11677770d4492c2f7f8bf8bda5ebd80adb
EBUILD httpcore-0.15.0.ebuild 1251 BLAKE2B c00e6bc3e7650f8c485de280b612590cc141e91f732229d9657560780340bede351a7efde15121f179c206ef560e24e76b706ef1406fc7b2236c42621c8c63d0 SHA512 a4a7468d09059fa610d1617c779defc01a70aaf37f81295917c68904763fb2ec0cfb13d3efcc2dcead3c3366b047b748ade6a167bb23bb98a5939415cbea08d8
MISC metadata.xml 454 BLAKE2B f8a48d9ab81e5f74623dd0c8490e5de5cc711fda7f4614932e7ac6caa80bd23436037ddf9327d6bddc3d39c8b601b4ee74a85c0a10bacb20514cbf8278e34d1f SHA512 af962141bd55f51b27e0d4b61bcf7d5426e816df4f8c65be257d8fddd597664afe04e78ebe7e11caaebf06ae4fe17b88f568dc440403865ba6b8e3b47d796aa6
diff --git a/dev-python/httpcore/httpcore-0.15.0-r1.ebuild b/dev-python/httpcore/httpcore-0.15.0-r1.ebuild
new file mode 100644
index 000000000000..35bc983a2b8e
--- /dev/null
+++ b/dev-python/httpcore/httpcore-0.15.0-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="A minimal low-level HTTP client"
+HOMEPAGE="
+ https://www.encode.io/httpcore/
+ https://github.com/encode/httpcore/
+ https://pypi.org/project/httpcore/
+"
+SRC_URI="
+ https://github.com/encode/httpcore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ https://github.com/encode/httpcore/commit/4cf288e0007cb73561b9020af9228f076ba2a94e.patch
+ -> ${P}-h11-0.14.patch
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ =dev-python/anyio-3*[${PYTHON_USEDEP}]
+ dev-python/certifi[${PYTHON_USEDEP}]
+ <dev-python/h11-0.15[${PYTHON_USEDEP}]
+ <dev-python/h2-5[${PYTHON_USEDEP}]
+ =dev-python/sniffio-1*[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-httpbin[${PYTHON_USEDEP}]
+ dev-python/pytest-trio[${PYTHON_USEDEP}]
+ dev-python/socksio[${PYTHON_USEDEP}]
+ dev-python/trio[${PYTHON_USEDEP}]
+ dev-python/trustme[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ "${DISTDIR}"/${P}-h11-0.14.patch
+)
+
+pkg_postinst() {
+ optfeature "SOCKS support" dev-python/socksio
+}