summaryrefslogtreecommitdiff
path: root/dev-python/httplib2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/httplib2
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/httplib2')
-rw-r--r--dev-python/httplib2/Manifest2
-rw-r--r--dev-python/httplib2/httplib2-0.20.4.ebuild22
2 files changed, 18 insertions, 6 deletions
diff --git a/dev-python/httplib2/Manifest b/dev-python/httplib2/Manifest
index e05010316928..ac8f202da975 100644
--- a/dev-python/httplib2/Manifest
+++ b/dev-python/httplib2/Manifest
@@ -1,4 +1,4 @@
AUX httplib2-0.12.1-use-system-cacerts.patch 582 BLAKE2B ee2a407452ab557eec0934a175958ac7f1d1af3ad588b7f288b9e9f0a3d2b08146fdee05943e2681a1462986098256fa818d9561a4541ba0ed3b95984172271f SHA512 ff1b982e9f95f6efa53064b2a8d2748bf5a91a26fdaeb584f044d8e036b91034dbcf4719cb08855de412d6abcc33fe82e18fbd250c14d0ae2fea47b412fcafc3
DIST httplib2-0.20.4.gh.tar.gz 371778 BLAKE2B 85e2dd0b6213cc5015d4f2f7f923209a61649f948f003eaf3c95c956cb08e6f5bf9dc4e40109c0ddea6a18ab47870a21c7d367ea1eeec2644507568f4e271005 SHA512 46396a9bb439e61939e481a2502567a6dc40686471267ea4c357f141ac138193107f90ac465db683e4ab71e5d92249b810657bff0cb74af7a37a9a23c8320741
-EBUILD httplib2-0.20.4.ebuild 1546 BLAKE2B 8e37a27490458756776938f00235a9e45020606cafa5ed56809ed3986010546b9b9f1390197d484143d2cab8d3f192bb7c5729919e3b76a091858149a108e10d SHA512 5b349a40a60d798fc7f18385fbaff37f9432d39f27556647c6b42a7bb0d845094812c04b1b7169ef807313cd8271f7c9ff6ae5b8350e35c0a2f694ee659c8332
+EBUILD httplib2-0.20.4.ebuild 1852 BLAKE2B 6608f583a6ce3aa68915ba0a663f1f0c08a97284d64894951f487f68d92dfe5cfcce9b3d5922eb02cbcf0bf23b165c377649e1f6d1746a42aa90ed8fcf7e58d8 SHA512 7f8a13de8acc2ba1880c5d343cb8f18fca81536bcb54ac0d4085699943bb56cf1acc115341a3286c19d329da4ddf98c9fe21a709ed8b374bc1d3fbf0dd23fb96
MISC metadata.xml 406 BLAKE2B fcac2ef4d82fd109083a57097d0e8b99e1fbb3103a2e8ffa29cd77acc0300b0d91d30661a5721f25680b822a1e0f22e4e457fa05bd8948c68b0e3712146a3de6 SHA512 5a94811b95720f0bdb57c725e35313ecc5a15f12a8f75e39c9034440eed957cfb3dd9e86437c0c7b1df51f47602723a7e94ce2b62509dab4eaa4feac02e1558c
diff --git a/dev-python/httplib2/httplib2-0.20.4.ebuild b/dev-python/httplib2/httplib2-0.20.4.ebuild
index e88cb3072ace..afa4a1e94840 100644
--- a/dev-python/httplib2/httplib2-0.20.4.ebuild
+++ b/dev-python/httplib2/httplib2-0.20.4.ebuild
@@ -4,15 +4,19 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
inherit distutils-r1
DESCRIPTION="A comprehensive HTTP client library"
-HOMEPAGE="https://pypi.org/project/httplib2/"
+HOMEPAGE="
+ https://pypi.org/project/httplib2/
+ https://github.com/httplib2/httplib2/
+"
SRC_URI="
https://github.com/httplib2/httplib2/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz"
+ -> ${P}.gh.tar.gz
+"
LICENSE="MIT"
SLOT="0"
@@ -20,12 +24,15 @@ KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 ~riscv ~s390 sparc x86 ~am
RDEPEND="
app-misc/ca-certificates
- dev-python/pyparsing[${PYTHON_USEDEP}]"
+ dev-python/pyparsing[${PYTHON_USEDEP}]
+"
BDEPEND="
test? (
dev-libs/openssl
dev-python/pytest-timeout[${PYTHON_USEDEP}]
- )"
+ dev-python/six[${PYTHON_USEDEP}]
+ )
+"
distutils_enable_tests pytest
@@ -33,6 +40,8 @@ PATCHES=( "${FILESDIR}"/${PN}-0.12.1-use-system-cacerts.patch )
src_prepare() {
sed -i -e '/--cov/d' setup.cfg || die
+ # cryptography dep is entirely optional, and has a good fallback
+ sed -i -e 's:from cryptography.*:pass:' tests/__init__.py || die
distutils-r1_src_prepare
}
@@ -50,6 +59,9 @@ python_test() {
# broken by recerting (TODO)
tests/test_https.py::test_min_tls_version
tests/test_https.py::test_max_tls_version
+
+ # new cryptography or openssl-3?
+ tests/test_https.py::test_client_cert_password_verified
)
# tests in python* are replaced by tests/