summaryrefslogtreecommitdiff
path: root/dev-python/httplib2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-30 09:03:01 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-10-30 09:03:01 +0000
commita41f630aea0b4b71a6c9a088571f1eaaf8413d53 (patch)
tree2434c552b001d6b577a10a50bea2dd828676f27d /dev-python/httplib2
parentb77e1a6cc7c668e135d139c5ec5ad0ae1c11b857 (diff)
gentoo auto-resync : 30:10:2022 - 09:03:01
Diffstat (limited to 'dev-python/httplib2')
-rw-r--r--dev-python/httplib2/Manifest2
-rw-r--r--dev-python/httplib2/httplib2-0.21.0.ebuild70
2 files changed, 72 insertions, 0 deletions
diff --git a/dev-python/httplib2/Manifest b/dev-python/httplib2/Manifest
index af114b65af89..a1bd380795df 100644
--- a/dev-python/httplib2/Manifest
+++ b/dev-python/httplib2/Manifest
@@ -1,4 +1,6 @@
AUX httplib2-0.12.1-use-system-cacerts.patch 582 BLAKE2B ee2a407452ab557eec0934a175958ac7f1d1af3ad588b7f288b9e9f0a3d2b08146fdee05943e2681a1462986098256fa818d9561a4541ba0ed3b95984172271f SHA512 ff1b982e9f95f6efa53064b2a8d2748bf5a91a26fdaeb584f044d8e036b91034dbcf4719cb08855de412d6abcc33fe82e18fbd250c14d0ae2fea47b412fcafc3
DIST httplib2-0.20.4.gh.tar.gz 371778 BLAKE2B 85e2dd0b6213cc5015d4f2f7f923209a61649f948f003eaf3c95c956cb08e6f5bf9dc4e40109c0ddea6a18ab47870a21c7d367ea1eeec2644507568f4e271005 SHA512 46396a9bb439e61939e481a2502567a6dc40686471267ea4c357f141ac138193107f90ac465db683e4ab71e5d92249b810657bff0cb74af7a37a9a23c8320741
+DIST httplib2-0.21.0.gh.tar.gz 373245 BLAKE2B d7194773c2b61cbf579da5aea7f52cb3481eed86896be215b942de7f9418a39c4a934868c9e01b6bfb050a32e4b7bc7ff775b28af5ba5db2827131e436bf0b04 SHA512 8269014f05f5e4b668c7dea8ae708b27a60b4216d712a93ab58b74f399ab5bc0dcdcd8c1411ccff587c7bdb6bc20917451ad969e5bef2d5c5262327cabe17bbb
EBUILD httplib2-0.20.4.ebuild 1859 BLAKE2B 4283796260e559d3187cc44eeb7f7dcf5386154b63c361521a0bd71da7b03b6e57eeb15bb9dcc280de0db5e74280b932a490aac2baec50d9d473081343d4b774 SHA512 b74e27d7178ce8d364402db7ec7237d93d190dfa916ac07cae84bea3d9abd7b7b3aafb4944f8a7d72bbb78032650c0cf926955f2ed1b26c6c41a2fcd384bff08
+EBUILD httplib2-0.21.0.ebuild 1867 BLAKE2B e83721e037b795859955961f38673a52adcde04f4cd95c03c81f565876d87460a6761c3607515a3dd5ebadfffc1c421f8acd7702a47bb79da842e71c526c9698 SHA512 924696f46fa3f376a9e3f2e1f85f29c38e36f6a9e35b21e5408c2d97b67505a9af96e93761b23d1ce9082e68d3c15354a06b571c3050b12034c85e1283f43a5b
MISC metadata.xml 406 BLAKE2B fcac2ef4d82fd109083a57097d0e8b99e1fbb3103a2e8ffa29cd77acc0300b0d91d30661a5721f25680b822a1e0f22e4e457fa05bd8948c68b0e3712146a3de6 SHA512 5a94811b95720f0bdb57c725e35313ecc5a15f12a8f75e39c9034440eed957cfb3dd9e86437c0c7b1df51f47602723a7e94ce2b62509dab4eaa4feac02e1558c
diff --git a/dev-python/httplib2/httplib2-0.21.0.ebuild b/dev-python/httplib2/httplib2-0.21.0.ebuild
new file mode 100644
index 000000000000..76ca9a5de17e
--- /dev/null
+++ b/dev-python/httplib2/httplib2-0.21.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A comprehensive HTTP client library"
+HOMEPAGE="
+ https://pypi.org/project/httplib2/
+ https://github.com/httplib2/httplib2/
+"
+SRC_URI="
+ https://github.com/httplib2/httplib2/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+RDEPEND="
+ app-misc/ca-certificates
+ dev-python/pyparsing[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-libs/openssl
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+PATCHES=( "${FILESDIR}"/${PN}-0.12.1-use-system-cacerts.patch )
+
+src_prepare() {
+ sed -i -e '/--cov/d' setup.cfg || die
+ # cryptography dep is entirely optional, and has a good fallback
+ sed -i -e 's:from cryptography.*:pass:' tests/__init__.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # broken by using system certificates
+ tests/test_cacerts_from_env.py::test_certs_file_from_builtin
+ tests/test_cacerts_from_env.py::test_certs_file_from_environment
+ tests/test_cacerts_from_env.py::test_with_certifi_removed_from_modules
+
+ # broken by new PySocks, probably
+ tests/test_proxy.py::test_server_not_found_error_is_raised_for_invalid_hostname
+ tests/test_proxy.py::test_socks5_auth
+
+ # broken by recerting (TODO)
+ tests/test_https.py::test_min_tls_version
+ tests/test_https.py::test_max_tls_version
+
+ # new cryptography or openssl-3?
+ tests/test_https.py::test_client_cert_password_verified
+ )
+
+ # tests in python* are replaced by tests/
+ # upstream fails at cleaning up stuff
+ epytest tests
+}