summaryrefslogtreecommitdiff
path: root/dev-python/httpx
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /dev-python/httpx
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'dev-python/httpx')
-rw-r--r--dev-python/httpx/Manifest2
-rw-r--r--dev-python/httpx/httpx-0.19.0.ebuild27
2 files changed, 15 insertions, 14 deletions
diff --git a/dev-python/httpx/Manifest b/dev-python/httpx/Manifest
index 43d12d87050e..d989b87c1925 100644
--- a/dev-python/httpx/Manifest
+++ b/dev-python/httpx/Manifest
@@ -1,3 +1,3 @@
DIST httpx-0.19.0.tar.gz 1667455 BLAKE2B b8d4cb0b6e7f643b62b507930ccf1534d73d93261cab9281ef57d6392f00da325e897d5339aebacfa07aeae8278d3a81b78d6501a1587ffeaef68cc5087bfdaa SHA512 3b327f07d62cf0430672d4f1a4f884618e588496f049522de327f5c34f7260eb21739b7f1fbd6f43a21962bc8737547f3eddbc22751546647f56c9cd7212840a
-EBUILD httpx-0.19.0.ebuild 1628 BLAKE2B 99df3bbe0cae1f2cc014b2a77d6bb76690002e4e2548ddbb240507c17ec939815b67a2bad2b3744a82f8919908338448543804b8a96757d3f1a7e1933697544d SHA512 90c2fba934a8a483df50e848839184bfe1a452dff8aa7abe451f80196ec02b6fb17ab2a23b3996865002feaaa66193ecb6c1a1eb07253357c5b32a10a586a36d
+EBUILD httpx-0.19.0.ebuild 1855 BLAKE2B 159c2c051f1f013cfc5b2a81092173ae41f642498c73eccf3d704140be4b83b5542d16a607283679417ac9234d738a27bcd02010feaf46e1de3247a8dde366cb SHA512 6baf835094b28e8ebbce53842c354740d97b91f2fcc7a1bc6700fb4dee11e909ec42436d39e4605af5ee0c3eac33f13204f03f2e63d7a734e943dd6ddde7c414
MISC metadata.xml 445 BLAKE2B ad37f769e6ead3490624a9a4ce9eab3ba0c040adcb11c52e306fa13dcae8e3ae779efae6b5b3528890de6a9d440657d3bd3fce2004a1774ae88920a7cd05c66b SHA512 73af0d42f1735eecd27559c58514a20d85d775f59500cfc6e7b87d759a4b9951317c62eae2a990df63b80747255510bf970f05295c4548d1a81cd1cc7b7c2b81
diff --git a/dev-python/httpx/httpx-0.19.0.ebuild b/dev-python/httpx/httpx-0.19.0.ebuild
index f5ee2bdc0bc9..e739250c670f 100644
--- a/dev-python/httpx/httpx-0.19.0.ebuild
+++ b/dev-python/httpx/httpx-0.19.0.ebuild
@@ -17,7 +17,7 @@ SRC_URI="https://github.com/encode/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="amd64 arm arm64 ppc ppc64 sparc x86"
+KEYWORDS="amd64 arm arm64 hppa ppc ppc64 sparc x86"
RDEPEND="
dev-python/certifi[${PYTHON_USEDEP}]
@@ -41,19 +41,20 @@ BDEPEND="
distutils_enable_tests pytest
+EPYTEST_DESELECT=(
+ # Internet
+ tests/client/test_proxies.py::test_async_proxy_close
+ tests/client/test_proxies.py::test_sync_proxy_close
+ # known to fail, unimportant test
+ "tests/test_decoders.py::test_text_decoder[data3-iso-8859-1]"
+ tests/models/test_responses.py::test_response_no_charset_with_iso_8859_1_content
+)
+
python_prepare_all() {
+ # increase timeout for slower systems
+ sed -e 's/pool=/&10*/' -i tests/test_timeouts.py || die
# trio does not support py3.10
- sed -i '/^import trio/d' tests/concurrency.py || die
- sed -i '/pytest.param("trio", marks=pytest.mark.trio)/d' tests/conftest.py || die
+ sed -e '/^import trio/d' -i tests/concurrency.py || die
+ sed -e '/pytest.param("trio", marks=pytest.mark.trio)/d' -i tests/conftest.py || die
distutils-r1_python_prepare_all
}
-
-python_test() {
- local deselect=(
- # Internet
- tests/client/test_proxies.py::test_async_proxy_close
- tests/client/test_proxies.py::test_sync_proxy_close
- )
-
- epytest ${deselect[@]/#/--deselect }
-}