summaryrefslogtreecommitdiff
path: root/dev-python/httpx
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-12-08 02:07:29 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-12-08 02:07:29 +0000
commit494168b06b81a32b889c3cb1f721f925d0a6824f (patch)
tree0ec763ffa61af808a83f365fb6680258d2e28a50 /dev-python/httpx
parent2198f8593ae0312add1bdccb49edfcb935e5f8a6 (diff)
gentoo auto-resync : 08:12:2024 - 02:07:28
Diffstat (limited to 'dev-python/httpx')
-rw-r--r--dev-python/httpx/Manifest2
-rw-r--r--dev-python/httpx/httpx-0.28.1.ebuild98
2 files changed, 100 insertions, 0 deletions
diff --git a/dev-python/httpx/Manifest b/dev-python/httpx/Manifest
index 35f9699c535b..037abf17c133 100644
--- a/dev-python/httpx/Manifest
+++ b/dev-python/httpx/Manifest
@@ -1,6 +1,8 @@
AUX httpx-0.27.0-opt-trio.patch 506 BLAKE2B da0ccdd398a706a16e21f93ffdc6c9c6d6d0622361f99bc956810e501eb8d82015beaf4274bb396eca0d8d22a833319ad6389271705662b0346839d9158a1d8f SHA512 629cb4e557f3a69af754f115cc8cd0e152d7e046b984aea4db808a1ac6b09302f9231e639c3edaeb169474d83ac2f5c8e69a28d7288e4c10635e4812880e19fa
DIST httpx-0.27.2.gh.tar.gz 2185609 BLAKE2B 7e77cab0e9bda032cd595549e43dfc102f90bb8668b62f6b1f0df6bce6b6358f34aa1f51457a315eb774dde8c76083d180c02ff45283dd348c39b4a659307713 SHA512 c7852ae3e982bacee1587b66aed506f3f7e12caf296e651d3cdd9c111a7d737af49473be455bcabccc8e52487ad18b4821ea56b39500c3b77ed2325fc55505ae
DIST httpx-0.28.0.gh.tar.gz 4117883 BLAKE2B 0fa645a5767355d4c29d7eedb137c73ddf620ddb7b2b84550f6538fcf9e9900b27bcd91d7177392f6490db3cd6db92e1b7b6ab62e19e97b4a4a8cce0d72c65d9 SHA512 2b3a3a84af81dd130ad574e87369769c8cd76fd40793dd41032e89d2632f25468dcf7ae7279302cd0b3d32dafa9f4c17b7b4c9eae81b5dd7b9fcde1daa26e844
+DIST httpx-0.28.1.gh.tar.gz 4118011 BLAKE2B 76c24a3b3618798d5b65aaaa87ee583f9debf8cb7866204a3e12c151179d9f69a6ad23198c9ee7df61058f73b6ca84f453c3bced25a60f583d7b3ad7681839bb SHA512 5571957a3516533f1c1e76f311316811f6365e192d19ebae10c9ab0d0c4094d811063fd2be2995f3b6a41d6899a7882f27265badecf238a4f7903f976136d3ba
EBUILD httpx-0.27.2.ebuild 2309 BLAKE2B bb985f39d3e33a6489d12ba0420096ff2529af0c49902510ad0e3d717d5923a8f698401c5a7b816458385334b48d1998778c117dfdc1dcc0cd839df6ef6f96d8 SHA512 d0d6e68b96458510610b8014477f37f4cd31d6d7276e3fdd25ef53a88ff1810340102819403ee6123f9c13f25c6dd365826d3cdf49477ae11f0fd78f168947bf
EBUILD httpx-0.28.0.ebuild 2675 BLAKE2B 76a638328d154f1aacf469b280fc3efa72b73d1505fe3dd93b5e35cf5182c9991d43656bb42b3d324d97cb17c7cc6356d989b5ff2f65b28daf8e608676005d94 SHA512 1e880e33ef367a0b7c1736097ec6852cf74a35f5ead4e10b0d7a09014207d76f063d9b3569f7b593cde073398710aabb900af569d446c828e86e5c6b75643d2c
+EBUILD httpx-0.28.1.ebuild 2457 BLAKE2B 8892337555bbcedeebca77c6b5e39ebdd48af705d0d76cb21b16532bea11177f51ef263e418c54c3302817f99b5a50224526da392fa426a747fb5a6e87c2ebd6 SHA512 8d510743ae33d1319e2bf1c01d0ef2217bda54dada8b151869ca2523f95e3a37597ffa4f11c8298dde4be155bf9fadfb4359d21647c5be59740997bbdcc43577
MISC metadata.xml 518 BLAKE2B 063b5b95529cd5a31aac83998c0acbdfef208c34e931c96ae8ee767a326301a597a8297514b5c97bef2b3b706b8938d38c0e5f5d752307a9dd06984792c799a2 SHA512 3a29dffa0f951255a67468b28917590d4108ca12e14af03bfddef80f6d48e266fcccdd991e778ab9e267c0bc76ff0017e07905c1f2f45dc440a9af89f6cae6aa
diff --git a/dev-python/httpx/httpx-0.28.1.ebuild b/dev-python/httpx/httpx-0.28.1.ebuild
new file mode 100644
index 000000000000..8b67a3d249d1
--- /dev/null
+++ b/dev-python/httpx/httpx-0.28.1.ebuild
@@ -0,0 +1,98 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Fully-featured HTTP client which provides sync and async APIs"
+HOMEPAGE="
+ https://www.python-httpx.org/
+ https://github.com/encode/httpx/
+ https://pypi.org/project/httpx/
+"
+SRC_URI="
+ https://github.com/encode/httpx/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="cli"
+
+RDEPEND="
+ dev-python/anyio[${PYTHON_USEDEP}]
+ dev-python/certifi[${PYTHON_USEDEP}]
+ =dev-python/httpcore-1*[${PYTHON_USEDEP}]
+ dev-python/idna[${PYTHON_USEDEP}]
+ cli? (
+ =dev-python/click-8*[${PYTHON_USEDEP}]
+ =dev-python/pygments-2*[${PYTHON_USEDEP}]
+ dev-python/rich[${PYTHON_USEDEP}]
+ )
+"
+# httptools cause tests to fail
+# https://github.com/encode/httpx/discussions/3429
+BDEPEND="
+ dev-python/hatch-fancy-pypi-readme[${PYTHON_USEDEP}]
+ test? (
+ dev-python/brotlicffi[${PYTHON_USEDEP}]
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/h2[${PYTHON_USEDEP}]
+ dev-python/socksio[${PYTHON_USEDEP}]
+ dev-python/trustme[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ dev-python/uvicorn[${PYTHON_USEDEP}]
+ >=dev-python/zstandard-0.18.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/trio[${PYTHON_USEDEP}]
+ ' 3.{10..13})
+ !!dev-python/httptools[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ local PATCHES=(
+ "${FILESDIR}/${PN}-0.27.0-opt-trio.patch"
+ )
+
+ if ! use cli; then
+ sed -i -e '/^httpx =/d' pyproject.toml || die
+ fi
+ sed -i -e '/rich/s:,<14::' pyproject.toml || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local args=()
+ local EPYTEST_DESELECT=(
+ # Internet
+ tests/client/test_proxies.py::test_async_proxy_close
+ tests/client/test_proxies.py::test_sync_proxy_close
+ )
+
+ use cli || EPYTEST_IGNORE+=(
+ tests/test_main.py
+ )
+
+ if ! has_version "dev-python/trio[${PYTHON_USEDEP}]"; then
+ args+=( -o filterwarnings= -k "not trio" )
+ fi
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p anyio "${args[@]}"
+}
+
+pkg_postinst() {
+ optfeature "HTTP/2 support" dev-python/h2
+ optfeature "SOCKS proxy support" dev-python/socksio
+ optfeature "Decoding for brotli compressed responses" dev-python/brotlicffi
+}