summaryrefslogtreecommitdiff
path: root/dev-python/httpx
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-03 21:56:14 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-03 21:56:14 +0000
commit9d352bec7c48de973d3fa345f92f733fe075f19a (patch)
tree64f90676327e8109f90198f42bb1f1784c68e969 /dev-python/httpx
parent782ce86e028f083bc3ad28d3a1fd28a344f0413b (diff)
gentoo auto-resync : 03:11:2023 - 21:56:13
Diffstat (limited to 'dev-python/httpx')
-rw-r--r--dev-python/httpx/Manifest2
-rw-r--r--dev-python/httpx/httpx-0.25.1.ebuild87
2 files changed, 89 insertions, 0 deletions
diff --git a/dev-python/httpx/Manifest b/dev-python/httpx/Manifest
index c142b823d5d9..86e26f165312 100644
--- a/dev-python/httpx/Manifest
+++ b/dev-python/httpx/Manifest
@@ -1,3 +1,5 @@
DIST httpx-0.25.0.gh.tar.gz 2169337 BLAKE2B 632a11917c35150be4aa9a946ae90493ba19b37697f97f82c36334a1004c57e9c256af54bcd0afbc2d5a67bd48f28c578285dd48473c8ccfd4b1c11e2c6bc069 SHA512 0be0f7ed53061d1dd9e0010d5a10adc6508bd49bf51e5ccf44f0aa2f54bdd067e3a7d1f37dfab80d3d374984aca2f20c346e46b8bc518826ce3371abc7291ee3
+DIST httpx-0.25.1.gh.tar.gz 2162706 BLAKE2B f13340d5b051fa2020c12825c31df8f5566c3900baa54267cf0718eaff35b600186cfee5a0db5d7fd1a86fbb94bb0d164c7c9be3d6508cd30fc2fbc75cc0c833 SHA512 ad67f45162e328dba3d74abc75cdae02cc4da1605e21456fbb2023f9f515efa6ec6c5799927a4a4557cf439819f9b05dc2805002e29b97102dadcf934cbd0e2b
EBUILD httpx-0.25.0.ebuild 2206 BLAKE2B 690e1315316e1ff5f0d1cb79f645dd255156ec69990b013e17ebf50b5b49ce7e77ae7c4ee5ff0f5f1cd46d0c94d81a66f6d6239cb2d93be09437676a3bf84b5f SHA512 3546e54bfd458f124cab9706b740d4feb478c5c94b799cd38267e1b8c99af68b730610b19a081fda4449059ec3f3865ebd17a7b4c6ce5be982934cfcf4f73e60
+EBUILD httpx-0.25.1.ebuild 2161 BLAKE2B 39c46318db49d41545df8100ae10498a0d45c2ce5b3e32d71946e70c41e501d65ade28ffb29f49802f437ca5e07f6c758f843a354f220860653af6f6a1261223 SHA512 6b82f766f7ff0bac2451854d0b4bf6971f432e3db4c450c80a200aac9829258ff2f191f3ad7f334c8aa09ee0f5e367b6f3f22f7398ce7b9ab5cbcc133408880a
MISC metadata.xml 518 BLAKE2B 063b5b95529cd5a31aac83998c0acbdfef208c34e931c96ae8ee767a326301a597a8297514b5c97bef2b3b706b8938d38c0e5f5d752307a9dd06984792c799a2 SHA512 3a29dffa0f951255a67468b28917590d4108ca12e14af03bfddef80f6d48e266fcccdd991e778ab9e267c0bc76ff0017e07905c1f2f45dc440a9af89f6cae6aa
diff --git a/dev-python/httpx/httpx-0.25.1.ebuild b/dev-python/httpx/httpx-0.25.1.ebuild
new file mode 100644
index 000000000000..347658370c43
--- /dev/null
+++ b/dev-python/httpx/httpx-0.25.1.ebuild
@@ -0,0 +1,87 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Fully-featured HTTP client which provides sync and async APIs"
+HOMEPAGE="
+ https://www.python-httpx.org/
+ https://github.com/encode/httpx/
+ https://pypi.org/project/httpx/
+"
+SRC_URI="
+ https://github.com/encode/httpx/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="cli"
+
+RDEPEND="
+ dev-python/anyio[${PYTHON_USEDEP}]
+ dev-python/certifi[${PYTHON_USEDEP}]
+ dev-python/httpcore[${PYTHON_USEDEP}]
+ dev-python/idna[${PYTHON_USEDEP}]
+ dev-python/sniffio[${PYTHON_USEDEP}]
+ cli? (
+ =dev-python/click-8*[${PYTHON_USEDEP}]
+ =dev-python/pygments-2*[${PYTHON_USEDEP}]
+ dev-python/rich[${PYTHON_USEDEP}]
+ )
+"
+BDEPEND="
+ dev-python/hatch-fancy-pypi-readme[${PYTHON_USEDEP}]
+ test? (
+ dev-python/brotlicffi[${PYTHON_USEDEP}]
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/h2[${PYTHON_USEDEP}]
+ dev-python/socksio[${PYTHON_USEDEP}]
+ dev-python/trio[${PYTHON_USEDEP}]
+ dev-python/trustme[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ dev-python/uvicorn[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ if ! use cli; then
+ sed -i -e '/^httpx =/d' pyproject.toml || die
+ fi
+ sed -i -e '/rich/s:,<14::' pyproject.toml || die
+
+ # use brotlicffi instead of brotli in tests
+ sed -i -e 's:import brotli:import brotlicffi as brotli:' \
+ tests/test_decoders.py || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # Internet
+ tests/client/test_proxies.py::test_async_proxy_close
+ tests/client/test_proxies.py::test_sync_proxy_close
+ )
+
+ use cli || EPYTEST_IGNORE+=(
+ tests/test_main.py
+ )
+
+ epytest
+}
+
+pkg_postinst() {
+ optfeature "HTTP/2 support" dev-python/h2
+ optfeature "SOCKS proxy support" dev-python/socksio
+ optfeature "Decoding for brotli compressed responses" dev-python/brotlicffi
+}