summaryrefslogtreecommitdiff
path: root/dev-python/hypercorn
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-30 21:45:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-10-30 21:45:44 +0000
commit77922838ba6e7b5f546528626d41f2e7f3fc2c08 (patch)
tree1fd5f253063a75764253e522032b50626e1a508e /dev-python/hypercorn
parent691395139ec5ea80983f870451c53bb6fff8298a (diff)
gentoo auto-resync : 30:10:2023 - 21:45:44
Diffstat (limited to 'dev-python/hypercorn')
-rw-r--r--dev-python/hypercorn/Manifest4
-rw-r--r--dev-python/hypercorn/hypercorn-0.15.0.ebuild49
-rw-r--r--dev-python/hypercorn/metadata.xml2
3 files changed, 53 insertions, 2 deletions
diff --git a/dev-python/hypercorn/Manifest b/dev-python/hypercorn/Manifest
index a32d27176743..977403e8d4eb 100644
--- a/dev-python/hypercorn/Manifest
+++ b/dev-python/hypercorn/Manifest
@@ -1,3 +1,5 @@
DIST hypercorn-0.14.4.gh.tar.gz 156001 BLAKE2B 262cbaba3df674b07dd5f6c15418cac18b46c2303a8ff616c8d2e968ff233d15bf616f2d3d0dbacda03f819251453be1b00cee4b98fdfaaed49f40cdcfb43119 SHA512 461b6fab72586b3bdea25ded6c0439595a8f84d5fb0b1a264f976926d9d34cb21f52bd10c84b9180d08fb05942f9fdb842343d4c6c476dcd60a26399387a2373
+DIST hypercorn-0.15.0.gh.tar.gz 156271 BLAKE2B 906b1b9c90c8150498ce6b8ac6f5de50373980381cd5ead206dd38be166b7e2ff0a1460aa08b2e4039d70b0412f2e38646836a867c623a2f0ff820f985cd79bc SHA512 a110f7e74eab99924c842715bdd9b32f0b3003eab4a4105968cf6779b69cb6e403dd8fd1b9910400994d25b9bf1a4d0956c99458bfcda70b1b8db2688859bacd
EBUILD hypercorn-0.14.4.ebuild 1159 BLAKE2B 3b1e86f45579c7293aa5e96a52e3929f261cd00f8aea4306202083597e4b2c2dd5cabb6d48a5cd0f12499bc3f231ea9c1a650a394e1f6f9feb40c2e1dee750c3 SHA512 bcc900808c8efa5926d1c4dabcc29695ca9f8185f6f0b183128ed20eb5808ab15b24ef1d89491d39e6ce210d1619be6b741ce3069a4cb8629d766998030c8e3c
-MISC metadata.xml 394 BLAKE2B ed2b00d93cd09682484b86b44f0e6cf0af2ebe7725c47afc5bdbc57b519b251fb0537c36d460ab4b427eeaddc4e61cd8970e3e91c3361279138171f838198fe8 SHA512 642d8e2b74e9ad6c79ee233589392202135328a37b04b29144aedd66f44a34bcdb36d38f5b7dee3c0e3ce2693f2b47cb86a9617d5c32ead5f3462ca1d047da0b
+EBUILD hypercorn-0.15.0.ebuild 1134 BLAKE2B a6a76a620cf5fdeac38894ef610266b676b3732748a7ee6c85e138e0d42c684b25245d97d71a8beb2bfdef31a4e88a507bfbc10064dcb4313b134d3f2c063edd SHA512 a575a55f0ffd171eab15c142512109c1d07607b3251912c36e784d81783eb5a364b74afb322a971617aaf8658a5b7e4fee9b5ad750ff5aa7b634e2a4f2231b37
+MISC metadata.xml 394 BLAKE2B ebdd676a74e00f1952cd6bd0fec099f8a1b0e4f8d6b4a0ceb671dcb294138312d5320e10ae8b9033307b47349a0668bc5d3299ab1d603bf34e95df7c8fc955df SHA512 d8d4a3952b536c5e35e2f68096c4707ec4634d7db70f179e01e8b4ca57983062584c8d4a81d833b9d9a6ebcd83cf8b7389ca1d19e2e656b00da72b74ac87146f
diff --git a/dev-python/hypercorn/hypercorn-0.15.0.ebuild b/dev-python/hypercorn/hypercorn-0.15.0.ebuild
new file mode 100644
index 000000000000..9a1a1dc9e096
--- /dev/null
+++ b/dev-python/hypercorn/hypercorn-0.15.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="A ASGI Server based on Hyper libraries and inspired by Gunicorn"
+HOMEPAGE="
+ https://github.com/pgjones/hypercorn/
+ https://pypi.org/project/Hypercorn/
+"
+SRC_URI="
+ https://github.com/pgjones/hypercorn/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/exceptiongroup-1.1.0[${PYTHON_USEDEP}]
+ dev-python/h11[${PYTHON_USEDEP}]
+ >=dev-python/h2-3.1.0[${PYTHON_USEDEP}]
+ dev-python/priority[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/taskgroup[${PYTHON_USEDEP}]
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.10)
+ >=dev-python/wsproto-0.14.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-trio[${PYTHON_USEDEP}]
+ >=dev-python/trio-0.22.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e 's:--no-cov-on-fail::' pyproject.toml || die
+ distutils-r1_src_prepare
+}
diff --git a/dev-python/hypercorn/metadata.xml b/dev-python/hypercorn/metadata.xml
index 1d8855d3b9ff..aef6884c023c 100644
--- a/dev-python/hypercorn/metadata.xml
+++ b/dev-python/hypercorn/metadata.xml
@@ -7,7 +7,7 @@
</maintainer>
<stabilize-allarches/>
<upstream>
- <remote-id type="pypi">hypercorn</remote-id>
+ <remote-id type="pypi">Hypercorn</remote-id>
<remote-id type="github">pgjones/hypercorn</remote-id>
</upstream>
</pkgmetadata>