summaryrefslogtreecommitdiff
path: root/dev-python/hypercorn
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-01 17:49:46 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-01 17:49:46 +0000
commitc16ac3f2fa4ccc7440fd13db1e5872a3e319f48c (patch)
tree4a3b9bbf32f7a7f613e6b67f3af294606333846a /dev-python/hypercorn
parent94605f5ed96183fd23685900c001b8cf2047c521 (diff)
gentoo auto-resync : 01:01:2024 - 17:49:46
Diffstat (limited to 'dev-python/hypercorn')
-rw-r--r--dev-python/hypercorn/Manifest2
-rw-r--r--dev-python/hypercorn/hypercorn-0.16.0.ebuild49
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/hypercorn/Manifest b/dev-python/hypercorn/Manifest
index 2b456a5dd03e..67c3e2947478 100644
--- a/dev-python/hypercorn/Manifest
+++ b/dev-python/hypercorn/Manifest
@@ -1,5 +1,7 @@
DIST hypercorn-0.14.4.gh.tar.gz 156001 BLAKE2B 262cbaba3df674b07dd5f6c15418cac18b46c2303a8ff616c8d2e968ff233d15bf616f2d3d0dbacda03f819251453be1b00cee4b98fdfaaed49f40cdcfb43119 SHA512 461b6fab72586b3bdea25ded6c0439595a8f84d5fb0b1a264f976926d9d34cb21f52bd10c84b9180d08fb05942f9fdb842343d4c6c476dcd60a26399387a2373
DIST hypercorn-0.15.0.gh.tar.gz 156271 BLAKE2B 906b1b9c90c8150498ce6b8ac6f5de50373980381cd5ead206dd38be166b7e2ff0a1460aa08b2e4039d70b0412f2e38646836a867c623a2f0ff820f985cd79bc SHA512 a110f7e74eab99924c842715bdd9b32f0b3003eab4a4105968cf6779b69cb6e403dd8fd1b9910400994d25b9bf1a4d0956c99458bfcda70b1b8db2688859bacd
+DIST hypercorn-0.16.0.gh.tar.gz 159038 BLAKE2B d17fde74af7f3a0157af22465f52a46967b8c4297eb5f602614d5337ca511d365e391630495535b56650fc4bfac864d30c5b281c04beddb0fec9bfcecd0f0c00 SHA512 75d75f0a0c1726b83d8ee38d5a15f4241130369904c9925cc3b87d1bf92f0d6a59ae7e7c83434c60ceae4bb628f6a51a42eda00c68a226c0bea6ef1c6fb8cb2c
EBUILD hypercorn-0.14.4.ebuild 1159 BLAKE2B 3b1e86f45579c7293aa5e96a52e3929f261cd00f8aea4306202083597e4b2c2dd5cabb6d48a5cd0f12499bc3f231ea9c1a650a394e1f6f9feb40c2e1dee750c3 SHA512 bcc900808c8efa5926d1c4dabcc29695ca9f8185f6f0b183128ed20eb5808ab15b24ef1d89491d39e6ce210d1619be6b741ce3069a4cb8629d766998030c8e3c
EBUILD hypercorn-0.15.0.ebuild 1197 BLAKE2B a03f5bf566a5bdd2c7317dbfc956a4614cad3eded6684904282a1adff180fba388ef01d4f2542476599b24d5acdb975ab4b7426e648731bbbfd60f76c976ee1d SHA512 6137a4f1923f441b8663694428d5f07d72b70c9d5e88be285482eb3ea05ca33ce7fd3040693f05d74e533fbafacf9ad117eeca90e609f4a28e52cd9da309cb5c
+EBUILD hypercorn-0.16.0.ebuild 1202 BLAKE2B 795e5a8224e598a862e4708484789c77d11dacbfb0247ee0dd48b3e683112019b42e7bbaf290628d843561490954eb3b3b8c1414ca7041093f263f4ff711750d SHA512 417e35846745a263aa2355389f2c45df85d3daa6b2e250c3583f4e94bdbcc22ecd24bdd0c170561bf195fb48019b25a21a13e3b20d4060430d85e5f4e9ab9ff9
MISC metadata.xml 394 BLAKE2B ebdd676a74e00f1952cd6bd0fec099f8a1b0e4f8d6b4a0ceb671dcb294138312d5320e10ae8b9033307b47349a0668bc5d3299ab1d603bf34e95df7c8fc955df SHA512 d8d4a3952b536c5e35e2f68096c4707ec4634d7db70f179e01e8b4ca57983062584c8d4a81d833b9d9a6ebcd83cf8b7389ca1d19e2e656b00da72b74ac87146f
diff --git a/dev-python/hypercorn/hypercorn-0.16.0.ebuild b/dev-python/hypercorn/hypercorn-0.16.0.ebuild
new file mode 100644
index 000000000000..2e24cd3a010c
--- /dev/null
+++ b/dev-python/hypercorn/hypercorn-0.16.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="A ASGI Server based on Hyper libraries and inspired by Gunicorn"
+HOMEPAGE="
+ https://github.com/pgjones/hypercorn/
+ https://pypi.org/project/Hypercorn/
+"
+SRC_URI="
+ https://github.com/pgjones/hypercorn/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/exceptiongroup-1.1.0[${PYTHON_USEDEP}]
+ dev-python/h11[${PYTHON_USEDEP}]
+ >=dev-python/h2-3.1.0[${PYTHON_USEDEP}]
+ dev-python/priority[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/taskgroup[${PYTHON_USEDEP}]
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.10)
+ >=dev-python/wsproto-0.14.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-trio[${PYTHON_USEDEP}]
+ >=dev-python/trio-0.22.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e 's:--no-cov-on-fail::' pyproject.toml || die
+ distutils-r1_src_prepare
+}