summaryrefslogtreecommitdiff
path: root/dev-python/hyperlink
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-python/hyperlink
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-python/hyperlink')
-rw-r--r--dev-python/hyperlink/Manifest4
-rw-r--r--dev-python/hyperlink/hyperlink-19.0.0.ebuild2
-rw-r--r--dev-python/hyperlink/hyperlink-20.0.1.ebuild26
3 files changed, 30 insertions, 2 deletions
diff --git a/dev-python/hyperlink/Manifest b/dev-python/hyperlink/Manifest
index a468b9407d65..9af8ec22524f 100644
--- a/dev-python/hyperlink/Manifest
+++ b/dev-python/hyperlink/Manifest
@@ -1,3 +1,5 @@
DIST hyperlink-19.0.0.tar.gz 99099 BLAKE2B 1213bbc404ebf04f178e3f8b986c343f64cd6a75202942d1cfaeab640d1523388beaafcd2662f414c9fb1eb87f746f3edeb5b5e395b9fc0acb7e82697f45f7a2 SHA512 5d5723bc0bd0c381edd3a9ef7bab3ba9ad4252027d5a4afa61e6cfff3e5b8457994b6dd36ecc356e638d41f797fe3367a3010249e0e77bee6e9e94336c1e7c2e
-EBUILD hyperlink-19.0.0.ebuild 578 BLAKE2B 07923943659db3f4b9d2b1f32d4d2fb1d84ad82c7409a660f62007d97093d2e0864bed9ddbd355a71a37d57f3adb687f9e166f7c1b6a0ddb0b8eb9fe7f4fcd79 SHA512 09d4cdda6b666d8013f66bf14e8f0dba506bd3ca9cac28a7613771ad3cd4c698454abfd40e5a561be7fef76e8aaa125655597b804d0e4fd5725c7953109e0e19
+DIST hyperlink-20.0.1.tar.gz 140291 BLAKE2B ee8c741d4cb87e4a577e1c9a45614f5f47e086f27b60a75897b66684ab5927da73ccaba47b16b770f0277a52351cc732cf74762e29c83644c220ed59c67a18d0 SHA512 f935c09d35baf8a8a3c8d4dc6aaf64135d13dda4636187f5d47f3fe4de675498efa29cd93d802c0912db2fa371d0e58213767b1c3c42e5a14bb837ea96a72193
+EBUILD hyperlink-19.0.0.ebuild 568 BLAKE2B 50b5ab528343078e69ae3dbf0135f34b74a660618090fe7cb215535f32a4f348bd98c57baf63f972a0469318cceddce108361314e6a767cf7645a7afda564f44 SHA512 122381a0f3253cfc5e0e6511d71114e8552767d39b6b5d09ccdcedb1f56337948ea0af20f7b74b7681f415e5e68670b17c712e10e936746207c0ef165866d710
+EBUILD hyperlink-20.0.1.ebuild 670 BLAKE2B 83e8672955c293c7e6bdb3bb7378e36ca3d3d7c06015785d96cfa82d4d050372d029c5d5d258e61cea5d48a47278f6f901578c44c059c01c6b0ed4150e53ac29 SHA512 cdb48e07b8a670f2068b9210d6d831d93f3549bf77ac5795982462852635b411a8a6ff651ae3d2adc4f616ddc9619b26bc812682a161d53cfa092a1b517fb702
MISC metadata.xml 673 BLAKE2B 054899b405550c1b1e891ad235cf2dd553275aa2d791c874073c83510123d4c995656d9777b022211369b705b3c068fa48abf2b6f3f63e5a78bd0a77fa367248 SHA512 4ddbf3e9d95f7699b5099d8c296aa3a777d9685e93e7f84734773c49d2a9174055cbed229cc0a1ddd2e10e3f414a6c93dd08eb3bfbc0717a4bf828ccf350060d
diff --git a/dev-python/hyperlink/hyperlink-19.0.0.ebuild b/dev-python/hyperlink/hyperlink-19.0.0.ebuild
index 4457f97f42f9..3d1b449904b3 100644
--- a/dev-python/hyperlink/hyperlink-19.0.0.ebuild
+++ b/dev-python/hyperlink/hyperlink-19.0.0.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{6,7,8,9} )
+PYTHON_COMPAT=( python3_{6,7,8,9} )
inherit distutils-r1
diff --git a/dev-python/hyperlink/hyperlink-20.0.1.ebuild b/dev-python/hyperlink/hyperlink-20.0.1.ebuild
new file mode 100644
index 000000000000..d1adb23821d0
--- /dev/null
+++ b/dev-python/hyperlink/hyperlink-20.0.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="A featureful, correct URL for Python"
+HOMEPAGE="https://github.com/python-hyper/hyperlink https://pypi.org/project/hyperlink/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/idna[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+src_test() {
+ # suppresses hypothesis health checks
+ local -x CI=1
+ distutils-r1_src_test
+}