summaryrefslogtreecommitdiff
path: root/dev-python/hyperlink
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/hyperlink
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/hyperlink')
-rw-r--r--dev-python/hyperlink/Manifest7
-rw-r--r--dev-python/hyperlink/hyperlink-17.1.1.ebuild31
-rw-r--r--dev-python/hyperlink/hyperlink-17.3.1.ebuild31
-rw-r--r--dev-python/hyperlink/hyperlink-18.0.0.ebuild29
-rw-r--r--dev-python/hyperlink/metadata.xml24
5 files changed, 122 insertions, 0 deletions
diff --git a/dev-python/hyperlink/Manifest b/dev-python/hyperlink/Manifest
new file mode 100644
index 000000000000..3d9bd08354d9
--- /dev/null
+++ b/dev-python/hyperlink/Manifest
@@ -0,0 +1,7 @@
+DIST hyperlink-17.1.1.tar.gz 23067 BLAKE2B 8bf1e61c6ba72c1cef4a9df62168b513004ae8ef2d4fcc13a1984bfdbf174c6175e2bcd241396c97d4e07dd06999718c217b27432fdf36d632b34c2b97bcb1b6 SHA512 13b20fd54c6bb5d7de3c9a04133fdd848413d1308d9944a2288c76d5f8b9bb0c54401ca5ed53460112209806407497526f2e68a92d119656eb58a9a618e9b708
+DIST hyperlink-17.3.1.tar.gz 91359 BLAKE2B 46ca9ddf54b8e5cd68cd5dd821b7a0ea2b218f0ba6d4072c7448433c6bf63891fb59999358c5efa605d21e28ab6e39a87cb84b1e3c8e2e8fce24892acf2eb679 SHA512 c0c9d99a530c938b1d1e97b8344c5a0fb18f894c8b0b294cc8ae6aa6a550a5a0272cc6be7a913d371f3ce3dd8695b7ed239999f3ae5e8ce97e3693625ae761bb
+DIST hyperlink-18.0.0.tar.gz 97625 BLAKE2B d189445c7375657614c38db9045d96789b78a2d4ebe67e23b897a450588fbe1e3916707bb67916eb893e93a716125e606ff8be27e63f3db4e63b8bda1436fa59 SHA512 21b5f88f7aaa3f2b0b60566fdb0fefdf6d42866060606dac181c8e3d357c76a5c23fa5dc982812af2b7d49dc1f9d623bd5bea89bf2cf31916c855bc4ae85589d
+EBUILD hyperlink-17.1.1.ebuild 750 BLAKE2B 28e596497a229d3939e08be7a20b553abba25dd5fdbf13b5bc625105638c84766267be03b92c04d6963fc3f109a2fae5c25973ac125ed9a3722de9b5aab1e66c SHA512 bcfa4f179f4a37e05e3e9e28720847e0bffc2f384d950026ece4526590555582248ab2a41fe64cb810dbe000e4bf74747452de90ace91daa08df60b7d524e38f
+EBUILD hyperlink-17.3.1.ebuild 774 BLAKE2B 6c87c7db5fc0877cf222ed2a0479e8cc174a324cf8bc57e53e90a5c3a7726bfe8d15967ff414c3776ca3f8fc3c8bea86a62a36e91e7c295f0b2f8f4571a6317a SHA512 129da86ef743fa68c780b221cb0d24b9c27da4466420e40b5ad9f90627dbb361d656a55a5d1ddee2e6b346b8885f395a9c5532ac37a0ca4b5a4fc603f8360ac4
+EBUILD hyperlink-18.0.0.ebuild 700 BLAKE2B 1c02d4a03cbd77c65632bd6dfa8b7123064c1fbe800c3979cdb91de764bad9bc5200140b8eb72b1114890f40ca1e51532286919e215e4f252953bf980a98e462 SHA512 52057072fcd07cec7247a47bd927959b0830f6a810756d1691a9ba8eeb0a75d25b5975794c3f43f6fe96655cf7c273c1b125887d35aff2d34dadf35872e393e0
+MISC metadata.xml 751 BLAKE2B b9e49354e3472ca16622fd269867df7f0c5f372afa5f93c36c2646f35e0fe1e1fcd6b25c66ef73e13e442019be449ea72b26fda807e3d220fa254c4d7a691f21 SHA512 7cd14daa771935591e7a130d9dbcd20630074d49ffd738d964b631798a0466392e0b669cc009f3c769614d704925699f2bc3239bd5e78ba0c2cd629dccd72591
diff --git a/dev-python/hyperlink/hyperlink-17.1.1.ebuild b/dev-python/hyperlink/hyperlink-17.1.1.ebuild
new file mode 100644
index 000000000000..ac6dfded277d
--- /dev/null
+++ b/dev-python/hyperlink/hyperlink-17.1.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy)
+
+inherit distutils-r1
+
+DESCRIPTION="A featureful, correct URL for Python"
+HOMEPAGE="https://github.com/python-hyper/hyperlink https://pypi.org/project/hyperlink/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/pytest-2.9.2[${PYTHON_USEDEP}]
+ >=dev-python/pytest-cov-2.3.0[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ PYTHONPATH="${S}/test:${BUILD_DIR}/lib" \
+ py.test -v || die
+ cd test
+}
diff --git a/dev-python/hyperlink/hyperlink-17.3.1.ebuild b/dev-python/hyperlink/hyperlink-17.3.1.ebuild
new file mode 100644
index 000000000000..4ee662544c76
--- /dev/null
+++ b/dev-python/hyperlink/hyperlink-17.3.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy)
+
+inherit distutils-r1
+
+DESCRIPTION="A featureful, correct URL for Python"
+HOMEPAGE="https://github.com/python-hyper/hyperlink https://pypi.org/project/hyperlink/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/pytest-2.9.2[${PYTHON_USEDEP}]
+ >=dev-python/pytest-cov-2.3.0[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ PYTHONPATH="${S}/test:${BUILD_DIR}/lib" \
+ py.test -v || die
+ cd test
+}
diff --git a/dev-python/hyperlink/hyperlink-18.0.0.ebuild b/dev-python/hyperlink/hyperlink-18.0.0.ebuild
new file mode 100644
index 000000000000..6eb930d31077
--- /dev/null
+++ b/dev-python/hyperlink/hyperlink-18.0.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy)
+
+inherit distutils-r1
+
+DESCRIPTION="A featureful, correct URL for Python"
+HOMEPAGE="https://github.com/python-hyper/hyperlink https://pypi.org/project/hyperlink/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/idna[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/pytest-2.9.2[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ pytest -vv || die
+}
diff --git a/dev-python/hyperlink/metadata.xml b/dev-python/hyperlink/metadata.xml
new file mode 100644
index 000000000000..381196fdc740
--- /dev/null
+++ b/dev-python/hyperlink/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>dolsen@gentoo.org</email>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <maintainer>
+ <email>mahmoud@hatnote.com</email>
+ <name>Mahmoud Hashemi</name>
+ </maintainer>
+ <remote-id type="pypi">hyperframe</remote-id>
+ </upstream>
+ <longdescription>
+ The humble, but powerful, URL runs everything around us.
+ Chances are you've used several just to read this text.
+ Hyperlink is a featureful, pure-Python implementation of the URL, with
+ an emphasis on correctness.
+ </longdescription>
+</pkgmetadata>