summaryrefslogtreecommitdiff
path: root/dev-python/icalendar
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-22 00:11:38 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-22 00:11:38 +0100
commit491d0101c89d81dec507f28215b3cb094800d600 (patch)
treea47cf0d9ff4a5f16976435358f5b956ac25f522c /dev-python/icalendar
parentbed3b604e16fc6075e29f1af8d47507a07035bd3 (diff)
gentoo auto-resync : 22:06:2024 - 00:11:37
Diffstat (limited to 'dev-python/icalendar')
-rw-r--r--dev-python/icalendar/Manifest2
-rw-r--r--dev-python/icalendar/icalendar-5.0.13.ebuild39
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/icalendar/Manifest b/dev-python/icalendar/Manifest
index 78245639e914..54374f10e654 100644
--- a/dev-python/icalendar/Manifest
+++ b/dev-python/icalendar/Manifest
@@ -1,3 +1,5 @@
DIST icalendar-5.0.12.tar.gz 115981 BLAKE2B b6a778f78977b2e967f639ca1a6209002c003c0729a993217da2fa7d3e407d5fa696740daae7b3c1084588140675a2fb1346b39042fe869195d917b3a2436f49 SHA512 0b608054b955223c1b876c8395b94a501f6b5afb92285561750749882cde2d55cbb48487f7fcd64188d2d6cd193f3bdb5634871352eb5b7a445c483075a62453
+DIST icalendar-5.0.13.tar.gz 119371 BLAKE2B ab0673af636b76682f1b0409df4333511c9cb19623dbdc639d84f46dcb9c14580ebfc1ea0465aa22b729852d5eaf76b12aa76041d189bcb3099f205caf43fac4 SHA512 df688298acc0bf3cf25aa08b16e149abab696e44540f11695a654065b90316189460481bde17d68e7c6760c1c4bfbbc74e9d7c7e3e640b5a1978d2c6faafbb78
EBUILD icalendar-5.0.12.ebuild 889 BLAKE2B 4d6a990a21619b54b043a7d2d7694c057ee542ded547172750e735a37fe74c6660ef038947359e60e588524fabb368b4b64cc9ad3282ebe56e723c99ff5404ab SHA512 c9716fd1d6c2b14a96d9b43caa5607947324b8d8fb9196ecae0e6fb2ea6cb88a3d4f19a785cfe45192917bb715e9d5019a96f75f57a739db74ad6e9398d2d757
+EBUILD icalendar-5.0.13.ebuild 892 BLAKE2B 0b5a0f31042ba16ef39652c61431d5641360303be803294a1698cf864387c0d264f63ea4a75602043ae3b59be5e53480e373772f510dd70087737dcae92e1ca8 SHA512 62275624510a0a831df65cd0b9ab1a2aa65cef1e16e8970315e7886a4f584eaa0952d2b08a958fb3cba410a9cb5e1787217d1b5474df36fcbf9409bc3643f8d1
MISC metadata.xml 503 BLAKE2B 284f63e95eb2d3015979a14774f8ff9df0df701b81f8aa2c7583f52d05973cfede1db8eb7904203b854165e10640cc50a0e3cf14d9aff090d9ff657c53098cee SHA512 d206db3c1255c8e475c4289c548f0224c7fc507aae513d3c15706998892ef8450400a97bd07dc7d52142a03cad4abae3595d5315d8912586440df74096edea67
diff --git a/dev-python/icalendar/icalendar-5.0.13.ebuild b/dev-python/icalendar/icalendar-5.0.13.ebuild
new file mode 100644
index 000000000000..8a7b69cb3587
--- /dev/null
+++ b/dev-python/icalendar/icalendar-5.0.13.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Package used for parsing and generating iCalendar files (RFC 2445)"
+HOMEPAGE="
+ https://github.com/collective/icalendar/
+ https://pypi.org/project/icalendar/
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # reset conf.py to not read version from an installed instance
+ sed -e "s:pkg_resources.get_distribution('icalendar').version:'${PV}':" \
+ -i docs/conf.py || die
+ distutils-r1_python_prepare_all
+}